Announcement

Collapse
No announcement yet.

8.02 "Another Cr*ppy Release Edition" ACRE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Strange as it seems, 8.02 (8.45.5) works pretty well for me. I have an R580+ on Ubuntu Hardy (8.04 Alpha 4), running a single display.

    - Desktop effects (compiz-fusion) works (OK...so what's the big deal?)

    - Video playback with VLC and Movie-Player no longer shows tearing. Overall image quality may be slightly degraded, I can't decide.

    - No phunnies with the control panel

    - Glxgears works fine, albeit at 10,500 it is about 1000 fps slower than 8.37

    - scrolling in firefox (3b3) is downright smooth and speedy.

    I know a lot of people are having problems with this one, but for me it works pretty well, and is much superior to 8.01

    The only problem I am having is that Ubuntu's update mangler keeps telling me that there is a newer version of the xorg-driver-fglrx and kernel headers available in repository, but they are still 8.01. Annoying, and I have to remember to deselect those packages when I run the updater.

    Comment


    • #62
      http://www.phoronix.com/forums/showthread.php?t=7839

      I just posted a thread on a problem I'm having trying to install this driver and then thought maybe I should've posted in this thread instead... for some reason, trouble finding source for the kernel module...

      Comment


      • #63
        Originally posted by rbmorse View Post
        The only problem I am having is that Ubuntu's update mangler keeps telling me that there is a newer version of the xorg-driver-fglrx and kernel headers available in repository, but they are still 8.01. Annoying, and I have to remember to deselect those packages when I run the updater.
        Put this in /etc/apt/preferences

        Code:
        Package: xorg-driver-fglrx
        Pin: version 8.455.2-0ubuntu1
        Pin-Priority: 1000
        
        Package: fglrx-kernel-source
        Pin: version 8.455.2-0ubuntu1
        Pin-Priority: 1000
        It will pin the 8.2.

        Comment


        • #64
          I ended up installing straight instead of from packages, couldn't find a way around that kernel module problem...

          Things seem to be working okay. XV actually works this time, however, glx/3-D seems broken. Not sure why. I guess I'll need to look into the workaround for it.

          Comment


          • #65
            Just to say I am very satisfied with this release.
            I replace a old system with a nv6600 by a new one with a 3850 and it run just fine.
            I use a 22" at 1680x1050, E8400, P35-DS3R, Kubuntu 7.10.

            No problem with glxgears at 15700 fps
            GoogleEarth, Celestia and Stelarium run smoothly.
            Enemy Territory is at 200 fps at the highest quality, ETQW support high quality setting.

            Globally a good base to test the future release with confidence.

            Comment


            • #66
              Quite satisfied w/ new driver.
              Althought still 1 big problem:
              Logout / Switchuser = blan/ck screen.

              Comment


              • #67
                Hey, for everyone with the problem of the white screen when using compiz:

                I had this problem, too. For me, the file /usr/lib/xorg/modules/dri/fglrx_dri.so was missing. So I just made a symbolic link to /usr/lib/dri/fglrx_dri.so and now compiz is running fine...

                Comment


                • #68
                  RS690 3D x86_64 corrupted fgl_glxgears/openarena

                  RS690 3D x86_64 corrupted fgl_glxgears/openarena

                  As noted on RS690 forums
                  https://groups.google.com/group/x1250

                  fgl_glxgears on x86_64 is giving the same kind of corruption, as noticed by some, earlier post, with glxgears. Please make a note of it.(file a bug somewhere ?)

                  I believe AMD/ATI problems will be solved by time bound development, tell the devs this bug/feature "x" needs to be solved/implemented, ask them how much time it will take, report that time to bug reporter, and if these deadlines are missed more than 3 times on that particular bug/feature, someone will be fired, preferably above junior programmer level. Keep the bug reporter informed of slipped deadlines, and new dates.

                  less hair pulling & more work done

                  Comment


                  • #69
                    Originally posted by Skywalker View Post
                    Same problem here. HD2600 Pro, 512 MB ram, PCIExpress. Intel quad 86_64 (I think 6600). Running x86_64 Fedora 8, kernel 2.6.23.15-137.fc8. Screen resolution 2560 x 1600.
                    same with M76 = HD2600 mobility radeon with 512MB ram.

                    running x86_64 gentoo linux.

                    i think it's a 64bit problem.... like the fact that i cannot enable anti-aliasing in 32bit applications...

                    @michael
                    I'm sorry to say that it's not so evident they are making improvements: since 7.12 the drivers are introducing many bugs for my platform...

                    nobody answered me when i asked why using the composite extensions i had a swap from warm colors to cold ones and viceversa.
                    nobody told me why, running a 64bits system i cannot enable anti-aliasing and v-sync on 3D 32bit apps (while all the other effects work)
                    nobody told me what's so difficult in implementing powerplay for mobile architectures.

                    I'd really love to read an answer to each question.

                    my trust in ati is not vanishing, i'm just wondering what's happening under the hood, if you say "could AMD be preparing for some major updates in the coming releases?"
                    I'd just like to know what's happening so maybe i could say: ok it doesn't matter if there are some bugs now, it's just important that they finish what they're work soon, and then fix all the bugs.

                    Comment


                    • #70
                      T60p compiz garbage

                      If I start compiz or run GLXGears I get complete garbage.

                      This is what fgl_glxgears looks like:


                      Any ideas?
                      Code:
                      Section "Device"
                      	Identifier  "aticonfig-Device[0]"
                      	Driver      "fglrx"
                      	Option      "HWCursor" "On"
                      	Option      "XAANoOffscreenPixmaps" "true"
                      	Option      "AllowGLXWithComposite" "true"
                      	Option      "OpenGLOverlay" "off"
                      	Option      "VideoOverlay" "on"
                      	Option 	    "TexturedVideo" "on"
                      EndSection
                      Removing these doesn't make a difference can I add any to fix it?

                      Last decent fglrx release was 7.11 for me, and it wasn't that good either. Still I do appreciate the effort AMD is making but it would be good if the drivers worked too.
                      Last edited by g.k.; 02-15-2008, 08:05 AM.

                      Comment


                      • #71
                        Originally posted by g.k. View Post
                        If I start compiz or run GLXGears I get complete garbage.
                        G.K., what is your screen resolution ? If it's not a multiple of 64, have you tried the "64 pixel" workaround (adding a "Virtual" line which rounds the screen resolution up to a multiple of 64) ?
                        Last edited by bridgman; 02-15-2008, 08:26 AM.

                        Comment


                        • #72
                          T60p working

                          Originally posted by bridgman View Post
                          G.K., what is your screen resolution ? If it's not a multiple of 64, have you tried the "64 pixel" workaround (adding a "Virtual" line which rounds the screen resolution up to a multiple of 64) ?
                          Yes, that works. Thanks v. much for that .

                          Here is the change I made to xorg.conf
                          Code:
                          	SubSection "Display"
                          		Viewport   0 0
                          		Depth     24
                          		Modes    "1400x1050"
                          		Virtual  1408 1088
                          	EndSubSection

                          Comment


                          • #73
                            Anyone else tried this 8.02 driver? Is scrolling in firefox and other apps really improved?

                            Comment


                            • #74
                              is something wrong with this dmsg output?
                              HTML Code:
                              fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
                              [fglrx] Maximum main memory to use for locked dma buffers: 430 MBytes.
                              [fglrx] ASYNCIO init succeed!
                              [fglrx] PAT is enabled successfully!
                              [fglrx] module loaded - fglrx 8.45.5 [Feb  1 2008] on minor 0
                              [fglrx] AGP detected, AgpState   = 0x1f000217 (hardware caps of chipset)
                              [fglrx] AGP enabled,  AgpCommand = 0x1f000314 (selected caps)
                              [fglrx] GART Table is not in FRAME_BUFFER range
                              [fglrx] Reserve Block - 0 offset =  0X0 length = 0X40000
                              [fglrx] Reserve Block - 1 offset =  0X3ff5000 length = 0Xb000
                              [fglrx] interrupt source 20008000 successfully enabled
                              [fglrx] enable ID = 0x00000004
                              [fglrx] Receive enable interrupt message with irqEnableMask: 20008000
                              [fglrx] interrupt source 10000000 successfully enabled
                              [fglrx] enable ID = 0x00000005
                              [fglrx] Receive enable interrupt message with irqEnableMask: 10000000
                              i have two problems described in my post before

                              after runing fgl_glxgears:
                              HTML Code:
                              [fglrx:firegl_lock] *ERROR* Process 3764 is using illegal context 0x00000006
                              [fglrx:firegl_lock] *ERROR* Process 3771 is using illegal context 0x00000006
                              [fglrx:firegl_lock] *ERROR* Process 3782 is using illegal context 0x00000006
                              [fglrx:firegl_lock] *ERROR* Process 3834 is using illegal context 0x0000000d
                              Last edited by Neithan; 02-15-2008, 12:11 PM.

                              Comment


                              • #75
                                Originally posted by g.k. View Post
                                Yes, that works. Thanks v. much for that .

                                Here is the change I made to xorg.conf
                                Code:
                                	SubSection "Display"
                                		Viewport   0 0
                                		Depth     24
                                		Modes    "1400x1050"
                                		Virtual  1408 1088
                                	EndSubSection
                                g.k.,

                                When you run compiz with the virtual workaround, do you get corruption in the lower-right corner of your screen, as well as 4 thick horizontal lines attached to the cursor? I have not been able to get rid of this...

                                (Thinkpad T60p, 1680x1050, FireGL v5250, Fedora 7)

                                Comment

                                Working...
                                X