Announcement

Collapse
No announcement yet.

8.02 "Another Cr*ppy Release Edition" ACRE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AIGLX still crashes with xorg-server-1.4

    Hi,
    I am using Gentoo together with xorg-server-1.4.0.90-r3 and my card is Mobility Radeon X1800. Unfortunately I still cannot get aiglx to work with the most recent xorg-server version. I still get the 'misssing texture from pixmap' (or somthing like that) error. Is it just me or does anyone have problems with aiglx and xorg-server-1.4.
    Cheers,

    Wojtek

    PS I have exactly the same problems with video scaling using xv as mentioned above. However, with xv I no longer get any flickering (!) so videos are watchable at last - in a small window though.

    [EDIT] I'm terribly sorry for the above post. Seems like there was a bug in Gentoo's ati-drivers ebuild and it actually downloaded and installed the previous version of the drivers. After modifying the ebuild aiglx works well with xorg-server-1.4. And I do get better performance with fullscreen xvideo (in terms of speed - the quality is still not the best). After all this seems to be a very nice release for me - thanks!
    Last edited by Wojtek; 02-19-2008, 10:35 AM.

    Comment


    • wow compiz-fusion works in Fedora 8 x64 now, and no more crashing upon first initialization. compiz is still kind of slow on my turion laptop, but using my own tweak utility increasing the mem bus to 200 and command rate of 1t helps a lot.

      Comment


      • This is the very first release that makes AIGLX work on my notebook, using X1400 Mobility, Mandriva Cooker and Xorg 1.4. First time to see compiz in action using AIGLX!

        Some issues still: video with kaffeine is still blocky (I will test VLC soon to see if can improve video playback), and resizing the windows under KDE is a bad joke... The performance must still be improved, but is the best release since 8.40, at least for me.

        Keep up the good work, ATI devs!

        Comment


        • So some more things work then whats in the release notes. Though xvideo is still broken its works better than it did in previous releaases. Is it to much trouble for ati to be a little more verbose in their release notes?

          Comment


          • X1950Pro, gentoo, xorg 1.4, kde 3.5.8, AIGLX, Q6600
            No tearing at video playback any more
            Better performance, but still firefox scrolling sux
            fgl_fglxgears,glxgears, googleearth, games all play fine with compiz enabled
            I have a million shaders etc on my card. Please improve performance on next drivers

            EDIT: Note:
            I tried both X1300 and X1950pro.
            When I play around with 3d effects, X1300 gives 100% CPU usage but X1950Pro gives about 15% CPU usage. Does this mean that hardware acceleration is better used in X1950?
            Last edited by alexopth69; 02-20-2008, 04:03 AM.

            Comment


            • Do you mean that under Xorg 7.3 3D is not corrupted??

              I will check that thing...

              Comment


              • Originally posted by djdoo View Post
                Do you mean that under Xorg 7.3 3D is not corrupted??

                I will check that thing...
                No its fine

                Comment


                • Originally posted by Compxpert View Post
                  So some more things work then whats in the release notes. Though xvideo is still broken its works better than it did in previous releaases. Is it to much trouble for ati to be a little more verbose in their release notes?
                  Mmm...sounds more like a complaint haha...I would care less if I got more than what was stated really. Pleasantly surprised I would say.

                  Comment


                  • I checked the 7.3 stuff and I still get 3D corruption here...

                    Damn...

                    Comment


                    • not just 3d corruption.. somehow my glxgears fps has plummetted with this release.. x1800xt here

                      Comment

                      Working...
                      X