Announcement

Collapse
No announcement yet.

AGP users, UNITE!!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by israel_miranda View Post
    Hey guys, I sent a private message to bridgman, asking him if there is any possibility of ATI creating a database of users using their proprietary driver who have problems, to help find the problem with the driver.
    Other than being organized by issue rather than by user, isn't Bugzilla that database already ? What we need is to cross-reference system configurations with problems, so we can (a) reproduce problems, (b) look for patterns and (c) eliminate possible causes more quickly.

    We do have a number of developers looking at Bugzilla reports, and from a developer POV having information organized by "problem" is much more useful than having it organized by "user".

    Comment


    • #32
      X - version (from a terminal)
      Reply With Quote
      ok I typed that command into the terminal and got this
      Code:
      Unrecognized option: -
      use: X [:<display>] [option]
      -a #                   mouse acceleration (pixels)
      -ac                    disable access control restrictions
      -audit int             set audit trail level
      -auth file             select authorization file
      -br                    create root window with black background
      +bs                    enable any backing store support
      -bs                    disable any backing store support
      -c                     turns off key-click
      c #                    key-click volume (0-100)
      -cc int                default color visual class
      -co file               color database file
      -core                  generate core dump on fatal error
      -dpi int               screen resolution in dots per inch
      dpms                   enables VESA DPMS monitor control
      -dpms                  disables VESA DPMS monitor control
      -deferglyphs [none|all|16] defer loading of [no|all|16-bit] glyphs
      -f #                   bell base (0-100)
      -fc string             cursor font
      -fn string             default font name
      -fp string             default font path
      -help                  prints message with these options
      -I                     ignore all remaining arguments
      -ld int                limit data space to N Kb
      -lf int                limit number of open files to N
      -ls int                limit stack space to N Kb
      -nolock                disable the locking mechanism
      -logo                  enable logo in screen saver
      nologo                 disable logo in screen saver
      -nolisten string       don't listen on protocol
      -noreset               don't reset after last client exists
      -reset                 reset after last client exists
      -p #                   screen-saver pattern duration (minutes)
      -pn                    accept failure to listen on all ports
      -nopn                  reject failure to listen on all ports
      -r                     turns off auto-repeat
      r                      turns on auto-repeat 
      -render [default|mono|gray|color] set render color alloc policy
      -s #                   screen-saver timeout (minutes)
      -sp file               security policy file
      -su                    disable any save under support
      -t #                   mouse threshold (pixels)
      -terminate             terminate at server reset
      -to #                  connection time out
      -tst                   disable testing extensions
      ttyxx                  server started from init on /dev/ttyxx
      v                      video blanking for screen-saver
      -v                     screen-saver without video blanking
      -wm                    WhenMapped default backing-store
      -wr                    create root window with white background
      -x string              loads named extension at init time 
      -maxbigreqsize         set maximal bigrequest size 
      +xinerama              Enable XINERAMA extension
      -xinerama              Disable XINERAMA extension
      -dumbSched             Disable smart scheduling, enable old behavior
      -schedInterval int     Set scheduler interval in msec
      +extension name        Enable extension
      -extension name        Disable extension
      -query host-name       contact named host for XDMCP
      -broadcast             broadcast for XDMCP
      -multicast [addr [hops]] IPv6 multicast for XDMCP
      -indirect host-name    contact named host for indirect XDMCP
      -port port-num         UDP port number to send messages to
      -from local-address    specify the local address to connect from
      -once                  Terminate server after one session
      -class display-class   specify display class to send in manage
      -cookie xdm-auth-bits  specify the magic cookie for XDMCP
      -displayID display-id  manufacturer display ID for request
      -kb                    disable the X Keyboard Extension
      +kb                    enable the X Keyboard Extension
      [+-]accessx [ timeout [ timeout_mask [ feedback [ options_mask] ] ] ]
                             enable/disable accessx key sequences
      -ardelay               set XKB autorepeat delay
      -arinterval            set XKB autorepeat interval
      
      
      Device Dependent Usage
      -modulepath paths      specify the module search path
      -logfile file          specify a log file name
      -configure             probe for devices and write an xorg.conf
      -config file           specify a configuration file, relative to the
                             xorg.conf search path, only root can use absolute
      -probeonly             probe for devices, then exit
      -scanpci               execute the scanpci module and exit
      -verbose [n]           verbose startup messages
      -logverbose [n]        verbose log messages
      -quiet                 minimal startup messages
      -pixmap24              use 24bpp pixmaps for depth 24
      -pixmap32              use 32bpp pixmaps for depth 24
      -fbbpp n               set bpp for the framebuffer. Default: 8
      -depth n               set colour depth. Default: 8
      -gamma f               set gamma value (0.1 < f < 10.0) Default: 1.0
      -rgamma f              set gamma value for red phase
      -ggamma f              set gamma value for green phase
      -bgamma f              set gamma value for blue phase
      -weight nnn            set RGB weighting at 16 bpp.  Default: 565
      -layout name           specify the ServerLayout section name
      -screen name           specify the Screen section name
      -keyboard name         specify the core keyboard InputDevice name
      -pointer name          specify the core pointer InputDevice name
      -nosilk                disable Silken Mouse
      -flipPixels            swap default black/white Pixel values
      -disableVidMode        disable mode adjustments with xvidtune
      -allowNonLocalXvidtune allow xvidtune to be run as a non-local client
      -disableModInDev       disable dynamic modification of input device settings
      -allowNonLocalModInDev allow changes to keyboard and mouse settings
                             from non-local clients
      -allowMouseOpenFail    start server even if the mouse can't be initialized
      -bestRefresh           choose modes with the best refresh rate
      -ignoreABI             make module ABI mismatches non-fatal
      -isolateDevice bus_id  restrict device resets to bus_id (PCI only)
      -version               show the server version
      -showDefaultModulePath show the server default module path
      -showDefaultLibPath    show the server default library path
      vtXX                   use the specified VT number
      -keeptty               don't detach controlling tty (for debugging only)
      -novtswitch            don't immediately switch to new VT
      -sharevts              share VTs with another X server
      
      
      Fatal server error:
      Unrecognized option: -
      which doesn't really tell me anything

      Comment


      • #33
        X -version

        without space after -.

        Comment


        • #34
          Thank you figured it was something simple

          Comment


          • #35
            Hi!

            My system:
            • MSI RX2600Pro T2D512Z AGP
            • TV-out (PAL, composite) ; 640x480,800x600(primary)
            • AsRock K7S41GX (sis471GX chipset)
            • Athlon MP 2000+ (mobile, i.e. essentially XP)
            • 512MB ddr memory
            • Gentoo
            • X.org 7.3; X.org server version 1.4.0.90 (tried older)
            • fglrx 8.02 (tried all older supposedly supporting HD2xxx)
            • No acceleration is working! (whoa, did someone get to the point to test AIGLX?!??)

            Comment


            • #36
              Mr. Hilarious, we have not released HD2xxx AGP support under Linux yet.

              Comment


              • #37
                Black Screen of the Death

                Computer settings :

                MB : MSI KT6 ultra
                CPU : AMD Barton 2500+ @ Idontremember (3000+?)
                Video card : Sapphire RadeonHD 2400pro AGP
                fglrx tested : 8.01
                OS : Debian Sid (unstable) up to date... (so Xorg 1:7.3+10)
                Kernel : linux 2.6.22 vanilla

                Comment


                • #38
                  My system (http://www.smolts.org/client/show?uu...e-473bc51bf94c)

                  * SAPPHIRE ATI Radeon 9600 128MB AGP
                  * DVI(20' LCD): 1600x1200;
                  * MSI K8T NEO2 (MS-6702E v1.x)
                  * Athlon64 3000+ (1.8Ghz)
                  * 1Gbyte DDR-SDRAM (400Mhz)
                  * Fedora 8 x86_64
                  * Kernel-2.6.23.15
                  * X.org 7.3; X.org server 1.3.0.0;
                  * fglrx 8.02
                  * AIGLX is working. But, i can't see totem with compiz. Only xv is working under Not compiz effect.

                  I some problem packaging in Fedora x86_64. Still script is not updated. So, i updated fedora-script to phorogit repository. when, I closed any 3d application, occur segfualt error. But, 3d application is working good, excepted fgl_glxgears.
                  Last edited by hoenny; 02-17-2008, 10:07 PM.

                  Comment


                  • #39
                    Originally posted by bridgman View Post
                    Other than being organized by issue rather than by user, isn't Bugzilla that database already ? What we need is to cross-reference system configurations with problems, so we can (a) reproduce problems, (b) look for patterns and (c) eliminate possible causes more quickly.

                    We do have a number of developers looking at Bugzilla reports, and from a developer POV having information organized by "problem" is much more useful than having it organized by "user".
                    Hi Bridgman, thanks for the help.
                    Sure bugzilla is the right place to report this.
                    I'm not familiarized to bugzilla, but I've been reading a little about it. I've made a little quick search about AGP related bugs, and seems (didn't read them all) to be some duplicated bugs.
                    I ask you guys to read these guidelines first:http://ati.cchtml.com/page.cgi?id=bug-writing.html
                    To avoid duplicated bugs and make bug reports as clear as possible. It's bad for everyone having duplicated bugs.

                    Bridgman, the site says the bugzilla is not official, so I imagine your official bug tracker is not open to the public.

                    Bridgman, what info would you like to be provided in a bug report? I think that should be more info on bugzilla, like kernel version, monitor type, resolution used and processor type. I see many ppl incluede this info, but I imagine would be better have a more standardized way(like including in the report form fields where you choose xorg version, kernel version, resolution, etc). I don't know, maybe this info really shouldn't matter much, but I'd like you to tell us what hardware/system info is really important to you guys trace and reproduce the bug.

                    Could you give us some info on how to start the driver in a debug mode? This would help a lot, mainly in my case because Xorg completely crashes the system without any error in any log, and the module loads flawlessly.

                    If you could tell us how to send backtrace info too would be great. I least I don't have an idea of how to do that.

                    Maybe you could post in this thread: http://www.phoronix.com/forums/showthread.php?t=5
                    some tips on how to make an ideal bug reports, like report only one problem per bug report, etc.

                    Bridgman, there seems to be some agp bugs open in bugzilla, so you think there is one which already represents our problem? Or does a new bug report has to be open if the bug is still in a new driver release?

                    Thanks a lot Bridgman, and sorry for the tons of questions

                    Comment


                    • #40
                      * HIS ATI Radeon X1650 pro 512MB AGP
                      * ASUS A7N8X-X (nforce2)
                      * Kernel-2.6.23(kernel.org)
                      * X.org 7.2; X.org server 1.3.0.0;
                      * fglrx 7.12,8.01,8.02
                      * compiz is running smooth


                      I've got the IRQ Error with 7.11, 7.12 fixed it for me.
                      To get 7.12 working i've had to set the AGP Aperture Size from 512MB to 256MB.
                      Since these changes, my system is running smoother and smoother from release to release.
                      I'm using Debian/lenny with a custom kernel(i'll send the config via pm if somebody want's it. )
                      Some agp-module experiments showed that the internal fglrx-agp isn't working for me:
                      (EE) fglrx(0): [agp] unable to acquire AGP, error -1023
                      (EE) fglrx(0): cannot init AGP
                      (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.

                      If i use the nvdia_agp module everything is running fine.

                      Comment


                      • #41
                        Damn!

                        Originally posted by uzi- View Post
                        * HIS ATI Radeon X1650 pro 512MB AGP
                        * ASUS A7N8X-X (nforce2)
                        * Kernel-2.6.23(kernel.org)
                        * X.org 7.2; X.org server 1.3.0.0;
                        * fglrx 7.12,8.01,8.02
                        * compiz is running smooth


                        I've got the IRQ Error with 7.11, 7.12 fixed it for me.
                        To get 7.12 working i've had to set the AGP Aperture Size from 512MB to 256MB.
                        Since these changes, my system is running smoother and smoother from release to release.
                        I'm using Debian/lenny with a custom kernel(i'll send the config via pm if somebody want's it. )
                        Some agp-module experiments showed that the internal fglrx-agp isn't working for me:
                        (EE) fglrx(0): [agp] unable to acquire AGP, error -1023
                        (EE) fglrx(0): cannot init AGP
                        (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.

                        If i use the nvdia_agp module everything is running fine.
                        You got it working with the nvidia agp driver??? I'd never thought of trying this.
                        If it works for you I'll try it!
                        But does it enable DRI?
                        Can you play any 3d games?
                        what does the error: (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized. exacly mean? what does GPS stands for?

                        well, send me your .config, or if possible paste it somewhere and put the link here.

                        Brigdman, what do you think about it?
                        is there any problem in using the nvidia_agp driver/module?
                        Last edited by israel_miranda; 02-15-2008, 11:24 AM.

                        Comment


                        • #42
                          Originally posted by bridgman View Post
                          Mr. Hilarious, we have not released HD2xxx AGP support under Linux yet.
                          bridgman, I was already aware of that (I found your post about it in some other thread - though, this is still not mentioned in the release notes). It just seemed that this thread was asking me to post the above information =)

                          p.s. if you need any help in beta testing or whatever then I'd be happy to help in that way, otherwise I think I'll just be quiet and wait
                          Last edited by Mr. Hilarious; 02-15-2008, 12:08 PM.

                          Comment


                          • #43
                            Here is my system spec

                            P4 2.4@3.33 Prescott
                            asus p4p800 se
                            Radeon 9800 Pro
                            1 GB of Ram

                            Mandriva 2008 with catalyste 8.45.5

                            Everything work very well 3D game, to compiz and video.

                            But I have a brand new Radeon HD 2600 PRO that do NOT work With any driver beside VESA !!!! And I'm piss't

                            If you guy's need help with testing for the HD 2xxx seri e I'm willing to help out. Because I'm too strap for cash to replace this card with a NVIDIA !!!

                            Comment


                            • #44
                              Spec's:

                              Video Card: ATI x1650XT (AGP) 512MB
                              Monitor: LCD Monitor; 1440x900
                              Motherboard: Intel Mobo D865GBF
                              Processor: Intel P4 HT 3.0
                              Memory: 1024 MB
                              Distro: ubuntu 7.10 (Gutsy)
                              Kernel: 2.6.22-14
                              Xorg: 7.2-5ubuntu13
                              fglrx: 8.45.4 w/ catalyst 1.8
                              AIGLX works fine*

                              Usually update fglrx along with monthly releases. Might pass this month just because I already did the daemon workaround.
                              *Compiz works fine except for the firefox scrolling issue (not too noticeable). Don't play games, but downloaded one out the repo, ran it, and had flickering while Compiz was running. Runs smooth without Compiz. Let me know if there's anything I can add.

                              Comment


                              • #45
                                Originally posted by nittanylion View Post
                                Spec's:

                                Video Card: ATI x1650XT (AGP) 512MB
                                Monitor: LCD Monitor; 1440x900
                                Motherboard: Intel Mobo D865GBF
                                Processor: Intel P4 HT 3.0
                                Memory: 1024 MB
                                Distro: ubuntu 7.10 (Gutsy)
                                Kernel: 2.6.22-14
                                Xorg: 7.2-5ubuntu13
                                fglrx: 8.45.4 w/ catalyst 1.8
                                AIGLX works fine*

                                Usually update fglrx along with monthly releases. Might pass this month just because I already did the daemon workaround.
                                *Compiz works fine except for the firefox scrolling issue (not too noticeable). Don't play games, but downloaded one out the repo, ran it, and had flickering while Compiz was running. Runs smooth without Compiz. Let me know if there's anything I can add.
                                nittanylion, did you check Xorg log for any errors?
                                If there is any error I'd appreciate you post here for exchange of information.
                                Thanks

                                Comment

                                Working...
                                X