Announcement

Collapse
No announcement yet.

fglrx 8.452 + TexturedXrender + Xrender composite = Color corruption

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx 8.452 + TexturedXrender + Xrender composite = Color corruption

    Hello.
    When I enable Xrender compositing (kwin4 or Metacity trunk) with TexturedXrender option active in my xorg.conf a full screen color corruption occurs.
    In detail, it seems that Red and Blue channels are swapped (RGB -> BGR). Everything go back normal disabling compositing.
    It is a driver bug or I have some wrong/weird configuration?

    My machine:
    - Peak HD2600Pro 256MB
    - Debian Lenny/Sid (mixed)
    - fglrx 8.452 drivers from ATI (not from Debian repository).
    - Xorg 7.2 (Debian Lenny)
    - xserver-xorg-core 1.3 (Debian Lenny)

    Thanks
    Last edited by meden; 02-06-2008, 06:57 PM. Reason: typo

  • #2
    UPDATE: the issue seems to be independent from compositing, but only related to Xrender (I get the same corruption using pixelize, a photo mosaic program).

    Comment


    • #3
      I have been able to confirm this issue. It is fglrx related, not KDE or distribution related.

      Comment


      • #4
        it's there since Catalyst 7.12... i thought i was the only one who had this problem!!!

        so you will be working on it now!? :-P

        ps. i only have it with compositing.... i don't use TexturedXrender... same version of Xorg server
        on a HD2600 mobility radeon.

        Comment


        • #5
          I think we are already working on it. AFAIK TexturedXRender has not yet been officially released, so enabling it gets you the work-in-process code.

          Comment


          • #6
            Originally posted by bridgman View Post
            I think we are already working on it. AFAIK TexturedXRender has not yet been officially released, so enabling it gets you the work-in-process code.
            always nice to read your answers :-)

            i mean when you say: "we are already working on it" :-P :-D

            Comment


            • #7
              great, i experiment that on Plasma and ePSXe with the SoftX video plugin ( the other 2 are not usable anymore with the ati-drivers > 8.40 ), but i disabled TexturedXrender and i still get the strange colors, i will try with Xrender 0.9.2 ( i have installed 0.9.4 )

              Comment


              • #8
                great, i experiment that on Plasma and ePSXe with the SoftX video plugin ( the other 2 are not usable anymore with the ati-drivers > 8.40 ), but i disabled TexturedXrender and i still get the strange colors, i will try with Xrender 0.9.2 ( i have installed 0.9.4 )
                I've only experienced this when enabling Textured2D along with TexturedXRender.

                Comment


                • #9
                  well guys, i have disabled both TexturedXRender and Textured2D and i still have the colors issue, also i have tried just using the Identifier and Driver line and i still get it.... i hope this gets fixed soon...

                  Comment


                  • #10
                    The issue is still there with Catalyst 8.3.

                    I made some further test, but I can't surely isolate the origin of such behaviour. It seems somehow related to a (combination of) XVideo, TexturedXRender and maybe Textured2D. The issue seems to appear only after an XVideo port is used for the first time by an application (colors change after the ANNOYING "blink video" bug - which yes, is STILL there...).

                    well guys, i have disabled both TexturedXRender and Textured2D and i still have the colors issue, also i have tried just using the Identifier and Driver line and i still get it
                    I guess that restarting X (even changing xorg options) doesn't make the issue disappear, as if the "video context" were corrupted (sorry, I'm not a technician...)

                    Anyway, running Compiz corrects everything, so I think that OpenGL acceleration is not affected.

                    Comment


                    • #11
                      Originally posted by Draco-LVNH View Post
                      well guys, i have disabled both TexturedXRender and Textured2D and i still have the colors issue, also i have tried just using the Identifier and Driver line and i still get it.... i hope this gets fixed soon...
                      I used to have the same problem. Disabling Textured2D worked for me. Just rememeber to edit something using aticonfig when you're done editing xorg.conf:

                      Code:
                      aticonfig --input=/etc/X11/xorg.conf --tls=1
                      Otherwise, fglrx won't load your changes. Finally, restart the X server.

                      Tiago
                      Last edited by tiagobt; 03-19-2008, 09:13 PM.

                      Comment


                      • #12
                        well, in my case i had taken out the XVideo from the problem, i had experimented it after a clean reboot without using XVideo.

                        Comment


                        • #13
                          What do you guys think of 2D acellaration on HD 2400 pro agp? E.g. browsing in konq gives frames (list of files appears very slow).

                          Comment

                          Working...
                          X