Announcement

Collapse
No announcement yet.

Amd CCC...nexuiz... and X full CPU...but glxgears fix the problem?!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Amd CCC...nexuiz... and X full CPU...but glxgears fix the problem?!

    Hi folks.... I finally managed to get (a little) work fglrx in my fedora...I had conflicts between runlevels..

    but now I have another problem..

    after boot, if I run the amd/ati control panel or a game....nothing happen... with top I see that X is at 84 % CPU and GLXINFO HI cpu usage too...

    for unlocking the problem, I just run GLXGEARS and all works....

    what happen? How to fix this issue?

    I'm using the fglrx 8.44 by livna... same problem with 8.45 (livna) and official installer...

    kernel: 2.6.23.14-107

    Code:
    # Xorg configuration created by livna-config-display
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AIGLX" "on"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "it"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "fglrx"
    #	Option	    "AGPMode" "8"
    	Option	    "RenderAccel" "on"
    	Option	    "XAANoOffscreenPixmaps"
    	Option	    "ColorTiling" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "VideoOverlay" "on"
    Option "AGPFastWrite" "on"
    Option "EnablePageFlip" "true"
    
    
    Option "UseFastTLS" "0"
    Option "BlockSignalsOnLock" "on"
    Option "ForceGenericCPU" "off"
    Option "KernelModuleParm" "locked-userpages=0"
    
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "Enable"
    EndSection

  • #2
    That error is in every driver since 8.41.7 and Xserver 1.4. If you use an older driver (with -ignoreABI override) then it works without that problem.

    Comment


    • #3
      Originally posted by Kano View Post
      That error is in every driver since 8.41.7 and Xserver 1.4. If you use an older driver (with -ignoreABI override) then it works without that problem.
      please explain better....

      where to put that string???

      Comment


      • #4
        Depends on the DM you use. Do you use KDM, GDM or whatever?

        Comment


        • #5
          Originally posted by Kano View Post
          Depends on the DM you use. Do you use KDM, GDM or whatever?

          gdm I use fedora like mom did it

          Comment


          • #6
            For Debian you would use this - I will not install Fedora:

            echo [server-Standard] >> /etc/gdm/gdm.conf
            echo command=/usr/bin/X -audit 0 -ignoreABI >> /etc/gdm/gdm.conf

            Also when you want to use 8.40.4 you will need this:

            http://mlau.at/files/fglrx-842-2623.patch
            Last edited by Kano; 01-29-2008, 06:17 PM.

            Comment


            • #7
              tnx for your reply... but doesn't work for me...


              tried also ignoreabi in other ways (tnx google ) but nothing to do

              Comment


              • #8
                Same here (I see problem, Kano's fix doesn't work...unless I'm screwing it up which is possible). Ubuntu 8.04 (alpha-2).

                I'd test it on my production machine running 7.10 except it has radeonhd, which I trust more than fglrx.

                Comment


                • #9
                  so.....the only solution is running glxgears at every xorg start? WOW great fglrx driver -_-"

                  Comment


                  • #10
                    That fix is for using 8.40.4 or older. My fglrx script has it included. As long as your xorg.conf has already a driver fglrx statement you can execute it for testing with -v 8.39.4 or -v 8.40.4 as options. It does not yet work with those pure default xorg.conf files.

                    http://kanotix.com/files/install-fglrx-debian.sh

                    Comment

                    Working...
                    X