Announcement

Collapse
No announcement yet.

Amd CCC...nexuiz... and X full CPU...but glxgears fix the problem?!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Amd CCC...nexuiz... and X full CPU...but glxgears fix the problem?!

    Hi folks.... I finally managed to get (a little) work fglrx in my fedora...I had conflicts between runlevels..

    but now I have another problem..

    after boot, if I run the amd/ati control panel or a game....nothing happen... with top I see that X is at 84 % CPU and GLXINFO HI cpu usage too...

    for unlocking the problem, I just run GLXGEARS and all works....

    what happen? How to fix this issue?

    I'm using the fglrx 8.44 by livna... same problem with 8.45 (livna) and official installer...

    kernel: 2.6.23.14-107

    Code:
    # Xorg configuration created by livna-config-display
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AIGLX" "on"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "it"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "fglrx"
    #	Option	    "AGPMode" "8"
    	Option	    "RenderAccel" "on"
    	Option	    "XAANoOffscreenPixmaps"
    	Option	    "ColorTiling" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "VideoOverlay" "on"
    Option "AGPFastWrite" "on"
    Option "EnablePageFlip" "true"
    
    
    Option "UseFastTLS" "0"
    Option "BlockSignalsOnLock" "on"
    Option "ForceGenericCPU" "off"
    Option "KernelModuleParm" "locked-userpages=0"
    
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "Enable"
    EndSection

  • #2
    That error is in every driver since 8.41.7 and Xserver 1.4. If you use an older driver (with -ignoreABI override) then it works without that problem.

    Comment


    • #3
      Originally posted by Kano View Post
      That error is in every driver since 8.41.7 and Xserver 1.4. If you use an older driver (with -ignoreABI override) then it works without that problem.
      please explain better....

      where to put that string???

      Comment


      • #4
        Depends on the DM you use. Do you use KDM, GDM or whatever?

        Comment


        • #5
          Originally posted by Kano View Post
          Depends on the DM you use. Do you use KDM, GDM or whatever?

          gdm I use fedora like mom did it

          Comment


          • #6
            For Debian you would use this - I will not install Fedora:

            echo [server-Standard] >> /etc/gdm/gdm.conf
            echo command=/usr/bin/X -audit 0 -ignoreABI >> /etc/gdm/gdm.conf

            Also when you want to use 8.40.4 you will need this:

            http://mlau.at/files/fglrx-842-2623.patch
            Last edited by Kano; 01-29-2008, 06:17 PM.

            Comment


            • #7
              tnx for your reply... but doesn't work for me...


              tried also ignoreabi in other ways (tnx google ) but nothing to do

              Comment


              • #8
                Same here (I see problem, Kano's fix doesn't work...unless I'm screwing it up which is possible). Ubuntu 8.04 (alpha-2).

                I'd test it on my production machine running 7.10 except it has radeonhd, which I trust more than fglrx.

                Comment


                • #9
                  so.....the only solution is running glxgears at every xorg start? WOW great fglrx driver -_-"

                  Comment


                  • #10
                    That fix is for using 8.40.4 or older. My fglrx script has it included. As long as your xorg.conf has already a driver fglrx statement you can execute it for testing with -v 8.39.4 or -v 8.40.4 as options. It does not yet work with those pure default xorg.conf files.

                    http://kanotix.com/files/install-fglrx-debian.sh

                    Comment


                    • #11
                      Originally posted by karlpiuemeno View Post
                      so.....the only solution is running glxgears at every xorg start? WOW great fglrx driver -_-"
                      Or, just don't run the control center (amdcccle).

                      If you do run the control center you have to kill it manually OR run glxgears after you close the CCC window.

                      Other than that, it works pretty well for me.

                      Comment


                      • #12
                        Originally posted by rbmorse View Post
                        Or, just don't run the control center (amdcccle).

                        If you do run the control center you have to kill it manually OR run glxgears after you close the CCC window.

                        Other than that, it works pretty well for me.
                        no.. xorg goes crazy also if I run only nexuiz...
                        for example..


                        I turn on my pc... ok desktop.... I open NEXUIZ... nothing happen.... I open terminal, glxgears... puff, nexuiz screen pops up!

                        same thing with amdccc.......
                        Last edited by karlpiuemeno; 01-30-2008, 11:11 AM.

                        Comment


                        • #13
                          Ok...then don't do that <g>.

                          Have you filed a bug report? Sometimes it helps.

                          Comment


                          • #14
                            bug already filled by someone

                            It is bug #1003 http://ati.cchtml.com/show_bug.cgi?id=1003
                            I have also submited simple workaround there. It works for me.


                            I've also made some deeper investigation - compare strace output (strace glxinfo) at first time and second time. Here are results (buggy output is submitted in bugzilla):
                            Line 528 bad:
                            Code:
                            ioctl(5, 0x4008642a, 0x7fffb2c30cb0)    = 0
                            not called in normal run

                            Line 576 good:
                            Code:
                            ioctl(5, 0x4008642a, 0x7fff22eeac50)    = 0
                            not called in badly run

                            loop seems to begin on line 754, where in
                            normal run couple of:
                            Code:
                            ioctl(5, 0xc03064a6, 0x7fff22eecca0)
                            is called,

                            and fews calls later output messages are printed.

                            In case of bug, loop begins:

                            Code:
                            select(4, [3], [3], NULL, NULL)         = 1 (out [3])
                            writev(3, [{"+\1\1\0", 4}], 1)          = 4
                            select(4, [3], [], NULL, NULL)          = 1 (in [3])
                            read(3, "\1\2&\0\0\0\0\0\f\0`\1\0\0\0\0D\f\0\0\0\0\0\0\340\37>\245"..., 4096) = 32
                            read(3, 0x605eb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
                            select(4, [3], [3], NULL, NULL)         = 1 (out [3])
                            writev(3, [{"\3\1\2\0\2\0\200\1\16\0\2\0\2\0\200\1", 16}], 1) = 16
                            select(4, [3], [], NULL, NULL)          = 1 (in [3])
                            read(3, "\1\0\'\0\3\0\0\0*\0\0\0\1\0\0\1\377\377\377\377\0\0\0\0"..., 4096) = 76
                            read(3, 0x605eb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
                            select(4, [3], [3], NULL, NULL)         = 1 (out [3])
                            writev(3, [{"\223\1\3\0\0\0\0\0\2\0\200\1", 12}], 1) = 12
                            select(4, [3], [], NULL, NULL)          = 1 (in [3])
                            read(3, "\1\334)\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0d\0d\0\0\0\0\0"..., 4096) = 32
                            read(3, 0x605eb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
                            ioctl(5, 0x4008642a, 0x7fffb2c32ac0)    = 0
                            (that strange ioclt 0x4008642a again

                            Can someone explain that ioctl. I can't find it in any kernel sources, so it must be some proprietary AMD/ATI driver call (or I overlooked something?).

                            I probably shuld write that to bugzilla, but no one seems to care ...

                            Comment

                            Working...
                            X