Announcement

Collapse
No announcement yet.

Freeze or restart with Radeon HD 2900 Pro

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Freeze or restart with Radeon HD 2900 Pro

    Hi,

    I've tried ATI Catalyst 7.12 and 8.1 drivers both with the ATI installer and with the livna packages on Fedora 8 (x86_64, fully updated). My system, with the Sapphire HD 2900 Pro (100212SR), either freezes with a black screen or restarts. I have the system connected to my plasma TV (Pioneer PDP-5070PU). I recorded appropriate timings for the TV using PowerStrip 3.76 in Windows.

    Almost all my xorg.conf variations lead to the following at the end of Xorg.0.log:

    [atiddx] ASYNCIO init succeed!
    Receive enable interrupt ret message
    ...irqEnableMask: 20008000
    ...dwIRQEnableId: 00000006
    Receive enable interrupt ret message
    ...irqEnableMask: 10000000
    ...dwIRQEnableId: 00000008
    Receive enable interrupt ret message
    ...irqEnableMask: 80020000
    ...dwIRQEnableId: 00000009
    Receive enable interrupt ret message
    ...irqEnableMask: 20000400
    ...dwIRQEnableId: 0000000a
    I've tried things mentioned here:
    http://www.my-guides.net/en/content/view/91/26/1/2/#ati

    ...and here:
    http://forums.fedoraforum.org/showth...3&page=1&pp=10

    ...including the downgrade of xorg-x11-server to FC7. Nothing seems to work.

    Here's my xorg.conf:
    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"

    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us+inet"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Pioneer"
    ModelName "PDP-5070PU"
    HorizSync 45.0 - 45.0
    VertRefresh 60.0 - 60.0
    Option "DPMS" "true"
    Mode "1280x720"
    DotClock 74.25
    HTimings 1280 1390 1430 1650
    VTimings 720 725 730 750
    Flags "doublescan" "+hsync"
    EndMode
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "fglrx"
    BusId "PCI:1:0:0"
    Option "OpenGLOverlay" "off"
    Option "VideoOverlay" "on"
    # Option "UseFastTLS" "0"
    # Option "BlockSignalsOnLock" "on"
    # Option "ForceGenericCPU" "off"
    # Option "KernelModuleParm" "locked-userpages=0"
    # Option "UseInternalAGPGART" "no"
    # Option "DesktopSetup" "clone"
    # Option "ForceMonitors" "auto,crt2"
    # Option "Mode2" "1360x768"
    # Option "HSync2" "47.687-47.687"
    # Option "VRefresh2" "59.984-59.984"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Monitor "Monitor0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x720"
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection
    As you can see, I've commented out options to try cloning the display onto the TV's PC input. But I'd be glad to get anything working at this point.

    Thanks for any assistance you can lend!
    Justin

  • #2
    Your card, like my HD2600XT AGP, has only DVI output connectors and the TV-out from what I could find on the internet.
    Reputedly, the current fglrx drivers don't work well with DVI-connected display devices, even via a dongle (like mine).

    The radeonhd driver may be a viable alternative for you for the time being?
    http://www.phoronix.com/scan.php?pag...item=843&num=1
    It works for me until ATI can get fglrx sorted for my card!

    Comment


    • #3
      Originally posted by Swoopy View Post
      Your card, like my HD2600XT AGP, has only DVI output connectors and the TV-out from what I could find on the internet.
      Yes, I'm using both included adapters: one DVI-I-to-HDMI and one DVI-I-to-15-pin-D-shell. One would think at least the traditional 15-pin D-shell VGA would work.

      Originally posted by Swoopy View Post
      The radeonhd driver may be a viable alternative for you for the time being?
      I'm a software developer and seek OpenGL acceleration as well as good performance with media applications (being that the system is connected to my plasma TV). While "vesa" and "radeonhd" both work, they are very limited in capabilities.

      I'm guessing that the Catalyst/fglrx drivers are apparently incapable as well. Everything works fine in Windows (with both connectors), so I know it can be done.

      Comment


      • #4
        It seems we are 'on the same boat' as far as Linux/Graphic requirements go (my Windows install works fine as yours does).
        Waiting until the radeonhd improves or until the fglrx improves is all I can currently do. (Mostly, I miss Google Earth in Linux. For photo editing, radeonhd suffices).
        At least with the fglrx team and the radeonhd team, we have two horses to bet on in the race to a working OpenGL ATI RadeonHD card in Linux!

        Comment


        • #5
          Finally, success with Radeon 2900

          Since the Radeon 2900 Pro was never recognized in Linux, I worked up the courage to flash its BIOS. Then I moved along to Fedora 9 and found that the system still hangs when using the Catalyst/fglrx 8.5 driver. After following steps to downgrade Xserver to the version used in Fedora 8 (found on FedoraForum.org), I have been able to successfully use the propriety drivers that offer OpenGL acceleration.

          Comment

          Working...
          X