Announcement

Collapse
No announcement yet.

Fglrx 8.01 cant be uninstalled completely

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fglrx 8.01 cant be uninstalled completely

    I did the failure and installed 8.01.
    After figuring out that it is still unusable for me, due to the overheating bug, i uninstalled it and replaced the xorg.conf with the one i backuped before.
    Now the free radeon driver i used without problems before cant be loaded properly.

    It seems that the fglrx kernel module is still beeing loaded.
    A rmmod fglrx... modprobe drm... modprobe radeon fixes the issue.
    But after reboot the fglrx module is loaded again and the radeon driver doesnt work.

    How can i remove this crappy module permanently?

    Thanks for replies.

  • #2
    remove module

    Originally posted by Nashwan View Post
    How can i remove this crappy module permanently?
    Some distros do auto-loading of modules at startup - I suppose that's what you're experiencing.
    Easiest way to prevent that is to remove the fglrx kernel module:
    Code:
    rm /lib/modules/`uname -r`/extra/fglrx.ko
    (note the back quotes around the uname command)

    Cheers,
    knutbert

    Comment


    • #3
      Originally posted by Nashwan View Post
      I did the failure and installed 8.01.
      After figuring out that it is still unusable for me, due to the overheating bug, i uninstalled it and replaced the xorg.conf with the one i backuped before.
      Now the free radeon driver i used without problems before cant be loaded properly.

      It seems that the fglrx kernel module is still beeing loaded.
      A rmmod fglrx... modprobe drm... modprobe radeon fixes the issue.
      But after reboot the fglrx module is loaded again and the radeon driver doesnt work.

      How can i remove this crappy module permanently?

      Thanks for replies.
      you could just add the following line to your /etc/modules.conf and /etc/modules.d/blacklist:

      blacklist fglrx
      this way udev won't load fglrx any more at startup and you won't be forced to uninstall fglrx when wanting to use xf86-video-ati. you could switch between them fine by modifying your driver option in the xorg.conf like this:
      in sectiondevice:
      Driver "radeon"
      in sectionmodule:
      Load "drm"
      for radeon driver or

      #Load "drm"
      and
      Driver "fglrx"
      when using fglrx. drm is needed when running radeon and is not needed, and should not be load when running fglrx, so you have to comment it. the device options don't need to be changed as the driver wouldn't use the options that doesn't recognize.

      Comment


      • #4
        Thanks

        Thank you very much for your answers.
        I fixed it by moving the fglrx.ko to another directory.

        @givemesugarr: I'm usind opensuse and can't find any modules.conf or blacklist.

        How could it be that the fglrx and some other files are still on my disk after removing the fglrx rpm?

        One more bug made by the ati developers?

        Comment


        • #5
          why the kernel module is not removed with the rpm package

          Originally posted by Nashwan View Post
          How could it be that the fglrx and some other files are still on my disk after removing the fglrx rpm?
          The kernel module ist not included in the rpm file list as it is compiled for your kernel by the script fglrx-kernel-build.sh.

          So when rpm removes all the files that were included in the rpm-package the kernel module is left over.

          Naturally, as the script fglrx-kernel-build.sh is called automatically after installation of the package, a corresponding remove-kernel-module script could be included as well...

          Regards,
          knutbert

          Comment


          • #6
            Uninstall is always a problem when the kernel module is not packaged. The same problem you get with dkms when you want to switch back. If you like you can delete every kernel module with one command:

            find /lib/modules -name fglrx.ko -exec rm -vf {} \;

            If you only want that for the currently running kernel:

            find /lib/modules/$(uname -r) -name fglrx.ko -exec rm -vf {} \;

            Comment

            Working...
            X