No announcement yet.

System lockup with catalyst 8.01

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I just wanted to add that I'm experiencing the same problem here. Logging out of my GNOME session or killing the X server via Ctrl-Alt-Backspace completely freezes the system. I'm using Ubuntu Hardy Heron (kernel 2.6.24-4) with the latest upgrades and the latest ATI Catalyst driver (Catalyst 8.01).
    If you need further information (logfiles, etc.) then feel free to ask me about it.

    My machine:
    - Samsung R60Plus Notebook,
    - Intel Core2Duo T5450 CPU
    - ATI Mobility Radeon X2300
    - 2048 MB RAM


    • #12
      I have the same problem when logging out or shutting down.
      Ubuntu Gutsy

      MSI GX710 Notebook
      ATi Radeon HD2600 mobility
      Catalyst 8.01

      regards Dennis


      • #13
        Originally posted by jasonxh View Post
        Hi bridgman, I wasn't aware that you are from AMD/ATI, so forgive me if anything I said sounds improper.
        No worries. If everyone started saying only nice things the forum wouldn't be fun any more

        Can everyone experiencing this lockup at shutdown please try disabling the three functions -- OpenGLOverlay, VideoOverlay and TexturedVideo -- and let us know what you find and what GPU you are running (and, if you feel generous, *which* of the options made the difference) ? It seems that this workaround is working for some folks but not for others, and it's not clear yet what conditions make the difference.


        • #14
          i'm sorry but no option works for me. i crashes always. using a hd2600xt


          • #15
            Originally posted by bridgman View Post
            Can everyone experiencing this lockup at shutdown please try disabling the three functions -- OpenGLOverlay, VideoOverlay and TexturedVideo -- and let us know what you find and what GPU you are running (and, if you feel generous, *which* of the options made the difference) ? It seems that this workaround is working for some folks but not for others, and it's not clear yet what conditions make the difference.
            Okay, so here I am, I did some testing on it and no matter what I do, it does crash.

            So first my sysspecs, then what I did:
            I am running gentoo unstable x86 with vanilla on a HD3850 512MB. My xorg-x11 server version is x11-base/xorg-server- and I am running latest 8.01 driver.

            The problem: It is not possible to shutdown X11 and use the terminal/restart from the terminal. *But* this does not happen always. I do at least have to use some app that is using OpenGL or running Xorg for some time. I don't know for sure which one it is. At least there is no problem when I directly start and quit Xorg, that is not enough...

            Here is what I did to try to fix the problem:
            1) First I did remove the file /etc/ati/amdpcsdb.
            2) Comment out *all* XVideo related options in /etc/X11/xorg.conf.
            3) Restart the whole system (restarting X was no option, that is the system basically crashed / showed no graphics output anymore on the terminal after quiting X).
            4) After the restart of the system and the start of xorg (the overlay option were *all* commented out in xorg.conf), I did have a look at the automatically created file /etc/ati/amdpcsdb. In there those options were set:
            5) After some hours of normal usage (that is viewing videos and such), I did try to shutdown the system. The same crash of unloading fglrx did occur. I was still able to ssh into the system, *but* unloading fglrx was not possible because rmmod did tell me that it was still being in use. So another ctrl+alt+del reboot.
            6) After the reboot I did just edit the file /etc/X11/xorg.conf to explicitly set these to 'off':
            Option "TexturedVideo" "off"
            Option "VideoOverlay" "off"
            Option "OpenGLOverlay" "off"
            Right after the start of Xorg, I did have a look at /var/log/Xorg.0.log and there was still the message that VideoOverlay was not supported on this card and that I should use TexturedVideo instead. I was a little surprised, but thought it could just be a general message, so I did not care. After some hours of normal usage, turning off Xorg did not work again, just a nice and black screen.
            7) One reboot later I did remove the file /etc/ati/amdpcsdb, started xorg and had another look at the log, now the enty regarding texturedvideo was gone, so I though everything should work when shutting down xorg.
            8) When shutting down xorg, the same as before did happen. The problem was not fixed.

            So what info can I provide now?
            1) The content of /etc/ati/amdpcsdb does override whatever is defined in /etc/X11/xorg.conf. IMO this is a bug...
            2) Nothing of those options did change anything.

            I hope that I can post some more chars, so that I don't have to double post, to post my current config and some log output...

            content of /etc/X11/xorg.conf after step '8)':
            Section "ServerLayout"
            	Identifier     "Server Layout"
            	Screen         "Screen0" 0 0
            	InputDevice    "Mouse1" "CorePointer"
            	InputDevice    "Keyboard1" "CoreKeyboard"
            Section "Files"
                FontPath 	"/usr/share/fonts/misc"
                FontPath 	"/usr/share/fonts/75dpi:unscaled"
                FontPath 	"/usr/share/fonts/100dpi:unscaled"
                FontPath 	"/usr/share/fonts/Type1"
                FontPath 	"/usr/local/share/fonts"
            Section "Module"
            	Load  "dbe"  	# Double buffer extension
            	SubSection "extmod"
            		Option	    "omit xfree86-dga"   # don't initialise the DGA extension
            	Load  "type1"
            	Load  "freetype"
            	Load  "glx"   # libglx.a
            	Load  "dri"   # libdri.a
            	Load  "drm"   # libdrm.a
            Section "InputDevice"
            	Identifier  "Keyboard1"
            	Driver      "kbd"
            	Option      "XkbModel" "cymotionlinux"
            	Option	    "XkbLayout" "de"
            	Option	    "XkbVariant" "nodeadkeys"
            	Option      "CoreKeyboard"
            Section "InputDevice"
            	Identifier  "Mouse1"
            	Driver      "evdev"
            	Option      "Protocol"	"event"
            	Option      "evBits" "+1-2"
            	Option      "keyBits" "~272-287"
            	Option      "relBits" "~0-2 ~6 ~8"
            Section "Monitor"
            	Identifier   "Dell2405FPW"
            	HorizSync    31.5 - 100.0
            	VertRefresh  50.0 - 120.0
            	Option	    "DPMS"
            Section "Device"
            	Identifier	"ATI Graphics Adapter"
            	Driver		"fglrx"
            	BusID		"PCI:1:00:0"
            	Screen          0
            #	Option          "XAANoOffscreenPixmaps" "true"
            #	fglrx options
            	Option          "TexturedVideo"		"off"
            	Option		"VideoOverlay"		"off"
            	Option		"OpenGLOverlay"		"off"
            Section "Screen"
            	Identifier "Screen0"
            	Device     "ATI Graphics Adapter"
            	Monitor    "Dell2405FPW"
            	DefaultDepth     24
            Section "DRI"
            # Access to OpenGL ICD is allowed for all users:
            	Mode         0666
            Section "Extensions"
            	Option "Composite" "Disable"
            #	Option "XVideo" "Enable"
            Section "ServerFlags"
            	Option "AIGLX" "off"


            • #16
              Continuing the post before...

              content of /etc/ati/amdpcsdb after step '8)':
              DALR6 DFPI 2_MaxModeInfo=R0000000080070000B0040000000000004B000000
              Output of "grep -i 'video' /var/log/Xorg.0.log" after step '8)':
                      X.Org Video Driver: 2.0
                      ABI class: X.Org Video Driver, version 2.0
              (II) Loading extension XVideo
              (II) Loading extension XVideo-MotionCompensation
                      Module class: X.Org Video Driver
              (II) AMD Video driver is running on a device belonging to a group targeted for this release
              (II) AMD Video driver is signed
                      ABI class: X.Org Video Driver, version 2.0
              (**) fglrx(0): Option "VideoOverlay" "off"
              (**) fglrx(0): Option "TexturedVideo" "off"
                      ABI class: X.Org Video Driver, version 2.0
                      ABI class: X.Org Video Driver, version 2.0
              (II) fglrx(0): ATI Video BIOS revision 9 or later detected
              (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR3
              (II) fglrx(0): Supported VESA Video Modes:
              (II) fglrx(0): Supported Future Video Modes:
              (II) fglrx(0): Supported additional Video Mode:
                      ABI class: X.Org Video Driver, version 2.0
              Do you need any additional information? Like I said, nothing of those steps made a difference regarding the problem when shutting down Xorg. My guess is that the problem is somewhere at unloading the module, so that Xorg does not quit correctly. At least there is no kernel panic, so that I can cleanly reboot via ssh or ctrl+alt+del...


              • #17
                Unfortunately this didn't do the trick for me either. I disabled OpenGLOverlay, VideoOverlay and TexturedVideo in my xorg.conf but the problem is still the same - when logging out (or when pressing Ctrl-Alt-Backspace) my system just freezes while still displaying the gnome background. In my case pressing Ctrl-Alt-Del does not work.

                I believe my Mobility X2300 is based on the RV515 chip.


                • #18
                  I have got similar issues. I just use kdm not gdm, but the problem is that the dm can't be killed completly. In the error case not even with killall -9.


                  • #19
                    I have the same problem.
                    card: ati radeon 9600
                    system: kubuntu gutsy, kernel 2.6.23-1 custom


                    • #20

                      Okay, some more work later and now it looks like it works. Here is what I did:

                      * Remove the deamon 'atieventsd'.

                      That one seems to be broken and causing the problems. That not everyone is having those probs might be related to that it is working correctly for some or that they are not having it active.
                      Part of the problem for me might be related to this (though it is just a *very* blind guess):
                      $ aticonfig --lsp
                      Error: POWERplay is not supported on your hardware.
                      Since my card is a HD3850, it should have POWERplay, maybe some problems are coming from here. At least I do know, that the problems are related to this very app. The textured video stuff and overlay itself *might* be part of it, too, not sure here at all.

                      I was now able to use my system for ~4h, did some videocutting/viewing and was able to shutdown Xorg and to restart it without any problem.