Announcement

Collapse
No announcement yet.

AMD Catalyst 8.01 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by waqar View Post
    On radeon mobility X1400, the new drivers seems to work quite well. I can even watch good video with both Xv and Opengl as my video output drivers in mplayer, vlc and xine, though xine froze my system once.

    The only error I'm observing is with fgl_glxgers, the error I get is
    X Error of failed request: GLXUnsupportedPrivateRequest
    Major opcode of failed request: 143 (GLX)
    Minor opcode of failed request: 16 (X_GLXVendorPrivate)
    Serial number of failed request: 42
    Current serial number in output stream: 43

    I can get fgl_glxgears working with the -fbo option.
    Please post your xorg.conf. X keeps crashing for me with Xv.

    Comment


    • Originally posted by maggot_brain View Post
      Please post your xorg.conf. X keeps crashing for me with Xv.
      The devices section is as follows. You might try mplayer and vlc. Xine crashed for me a couple of times.

      Section "Device"
      Identifier "ATI RADEON X1400"
      Driver "fglrx"
      BusID "PCI:1:0:0"
      Option "VideoOverlay" "on"
      Option "OpenGLOverlay" "off"
      # Option "UseFastTLS" "2"
      # Option "TexturedVideo" "on"
      EndSection

      Comment


      • Everything went smooth this time... i only have one problem: VLC crashes using openGL output giving exactly the same error message that Christian_L has... This means it's a bug Michael? I´m running Ubuntu Feisty x86 with a radeon x1300 card

        Comment


        • Nope, ChipID option does not work.

          Originally posted by Alexander Heß View Post
          Yep, it’s 0x71D4. Where am I supposed to “hack” the ID?
          I thought that maybe the ChipID option in the xorg.conf file might persuade the driver to run as an X1700 rather than a FireGL V5250, but I've just tried and it doesn't work. So it's back to 7-11 for me too.

          Comment


          • This is the balance I made for this version of the driver:

            1. XV works, although still blocky when resized (both in VLC ou MPlayer);
            2. OpenGL video playback works in MPlayer and crashes VLC;
            3. Power management works;
            4. Haven't tested suspend and resume yet, but it worked in previous releases, I guess I'm trusting ATI on this one... Not too important for me... :P
            5. When restarting X, the laptop always locks up with the background image on, as already reported...
            6. glxgears and fgl_glxgears both work with some minor improvement on the speed;
            7. Some games lockup the laptop when entering fullscreen (TORCS and Lincity-NG);
            8. I see a lot of messages like this "kernel: [fglrx:firegl_free_mutex] *ERROR* mutex id 0x0000000f not found in mutex list" in dmesg... Is this bad? Apparently this is related to opening amdcccle for example...
            9. AIGLX still slow, although acceptable. Also, when using the cube rotation efect together with wobbly windows, when a window is on the edge, if the movement is done fastly enough, parts os it are draw out of place.

            I'd really like to get solutions for 5, 7, 8 and 9. 5 and 7 are really important...

            I see the driver going the right way and ATI/AMD also going the right way... Opening up the specs was really a good sign for me. They deserve a big thanks for that. But the development of the new closed driver is going through a bumpy road... If only they would release their beta's maybe we could help more...

            Anyway... Can anyone help me with my problems? OpenGLOverlay is off and VideoOverlay is also off. TexturedVideo is on and TexturedVideoSync is on, but off has the same result for this last option...

            Comment


            • Can you try turning off Textured Video ? It shouldn't make a difference, but we have at least one report that mentioned it.

              This obviously isn't a good workaround for you, since it *will* impact your xv playback, but it would be good to know if that makes a difference with the lockup.

              Comment


              • My experience with 8.01

                I get some minor improvement in glxgears and others alike.

                No more cursor corruption

                3D apps...
                With 7.12 I got some crashes now and then when playing, with 8.01 I only get the game to crash once, and then it wont crash again. But the performance gets drasticaly reduced (Although playable). I have to restart X to play with full speed again. With 7.12 the crashes never detiorated the game performance, but they do happen sometimes. I got one thing noticed, when I restart the game after the crash I got the DMESG message (the same that appears when starting amdccle). I play WoW using Wine on kubuntu gutsy. BTW performance a little better than 7.12, noticeable in crowded areas.

                Comment


                • Some kind of apps hang directly after start of X with Xserver 1.4 like:

                  glxinfo
                  fglrxinfo
                  amdcccle
                  fgl_glxgears

                  interestingly is that glxgears works, also you can "start" the hanging app using glxgears in a 2nd terminal...

                  Comment


                  • update

                    Not sure if I posted here or Ubuntuforums before,
                    but here's my 8.01 status w/ x700 mobility 128mb.

                    At first video apps would crash immediately on launching with new driver. Switched to opengl overlay, and they work, with significant tearing. Changed my xorg.conf per suggestion here, and Xv playback works again, but it won't upscale. It just does a pixel for pixel size increase which is really ugly. Previous, I also used to be able switch which monitor opengl and xv overlays were on (important for me because my max texture size 2048, my screen resolution is 3360x1050, so one of my monitors typically will have opengl or video partially cut off. (With 7.11 driver, it didn't matter for video on xv) Previously, I would just move what display the overlay was on and be good to go, but with this driver, the only way for me to switch the overlay is to switch screens from right to left. Also, VLC won't open anymore. Mplayer spits errors every time it opens a file and it's subtitles don't work right. Xine works okay, but subtitles only seem to be working for DVD style. Pretty much this release has improved my game performance at the cost of introducing a bunch of weird glitches that are annoying to work around.

                    Comment


                    • Heck, I can't even get this driver to load.
                      I tried building packages for both Suse 10.3 and 10.2, it installed fine.
                      I tried both running sax2 and not running sax2, Writing and new xorg.conf, etc.
                      Tried uninstalling, reboot, then reinstall, just about everything I can think of.
                      Didn't matter, xorg, XGL, AIGLX no difference. However, every time I would load it would ALWAYS show the Mesa Driver in fglrxinfo.

                      fglrx is loading on boot as dmesg | grep fglrx shows the kernel module loading (although this driver was giving off some firegl errors I hadn't seen before)

                      I backed up to 8.40.4 using the same process and no issues whatsoever.
                      Current config is
                      Dell e1705
                      ATI x1400
                      openSuse 10.3

                      Here is a simple breakdown of the way I install new drivers:
                      1. BACKUP your current /etx/X11/xorg.conf
                      2. cd /usr/share/ati
                      sh ./fglrx-uninstall.sh ( This doesn't seem to exist anymore even with find | grep fglrx from / )
                      rpm -e $(rpm -qa | grep fglrx)
                      3. chmod +x ./ati-driver...
                      4. ati-driver.(fillintheblanks).run --buildpkg SuSE/SUSE103-IA32
                      5. rpm -ivh fglrx_...(hit tab again to get full name)...
                      6. ldconfig
                      7. aticonfig --initial --input=/etc/X11/xorg.conf
                      8. sax2 -r -m 0=fglrx
                      9. shutdown -h now


                      HELP!!
                      Last edited by combatdoc; 01-19-2008, 10:13 PM.

                      Comment


                      • Well, I had enough and tossed out my ATI x1650 Pro and replaced it with a brand-new Nvidia card this afternoon.

                        Worked right out of the box with the newest drivers.

                        Imagine that.

                        I felt that I had given ATI enough rope and that they had repeatedly hung me with it. I just had enough with the constant problems, black screens and other assorted garbage.

                        The Nvidia card works exactly as advertised: nice speed, AIGLX works great, 2D and 3D works fine and Compiz is nice and quick.

                        The good news is, I got $50 for my ATI card, so it's a win-win scenario.

                        I'm sorry to see the ATI card go, in a way, but I have the feeling that when I come back to this forum six, ten, twenty months from now, there will be the same problems with the same non-solutions from ATI.

                        For me, the ride ended today.

                        Comment


                        • Hardy Heron and Catalyst 8.01

                          I have not been able to run compiz with 8.01 on hardy heron. I am running fglrx, however when I try to start compiz I get:

                          Checking for Xgl: not present.
                          Detected PCI ID for VGA: 01:05.0 0300: 1002:791f (prog-if 00 [VGA controller])
                          Checking for texture_from_pixmap: not present.
                          Trying again with indirect rendering:
                          Checking for texture_from_pixmap: not present.
                          aborting and using fallback: /usr/bin/metacity

                          Is it possible to run catalyst 8.01 with xserver 1.4 AND AIGLX on hardy heron?

                          Comment


                          • Error messages?

                            Hello combatdoc,

                            Originally posted by combatdoc View Post
                            fglrx is loading on boot as dmesg | grep fglrx shows the kernel module loading (although this driver was giving off some firegl errors I hadn't seen before)
                            Could you post the error messages you are getting?

                            Code:
                            dmesg|grep fireglx
                            cat /var/log/Xorg.0.log | grep \(EE
                            Regards,
                            knutbert
                            Last edited by knutbert; 01-20-2008, 03:32 AM.

                            Comment


                            • I have to revert my praise for Textured2D a bit; I have noticed that it chokes on programs trying to update a large surface frequently, namely videos using xshm and SDL apps - every second or so, the rendering stalls for some moments, so I am switching it of again.

                              There also seems to be a lag with some XAA accelerated drawing operations independent of Textured2D, clearly noticable with some xscreensaver modules. However, this doesn't seem to have any effect on desktop performance for me.

                              Comment


                              • First of all, hello everyone. I've been reading for a long time, but this is my first post. I hope I can help, this is a great community.

                                I'm using a t60 as well with an X1400, Gutsy...
                                So far, what's been working for me is the 1650x1080. I find it appalling that I have to be happy for something so trivial, but what can I do? Like a lot of people here, I will not buy ATI again, unless their drivers become OSS.

                                Now, when I start compiz, I just get a white screen. The cube works and rotates, reflects, but it's completely white. What helps me is doing this:

                                Code:
                                sudo rmmod fglrx
                                cd /lib/modules/*/misc
                                sudo insmod fglrx.ko
                                modprobe fglrx
                                after that, compiz works, and works pretty well, except for the firefox scrolling bug, which is still here.
                                EDIT: Actually compiz lags a bit when I have more than a few windows open, especially if one of them is firefox.

                                also, as for video, xv looks horrible, and opengl cannot handle fullscreen (i get maybe 5fps). this is using vlc, but i don't think it matters which player I use.

                                Does anyone have any tips on not having to do that whole DRI enabling thingie everytime i boot? Something i can do?

                                Also, suspend/hibernate do not work for me at all, again - haven't ever worked in gutsy, to be honest

                                Another problem that I've been noticing is the very high temperature of the card - around 57C without compiz and 61-62C with compiz. Using the old fglrx drivers, I used to get 45-46 with Compiz/Xgl. This is a very serious issue for me, the fan is running at level 7 (full) all the time, and I am really not happy with that.
                                Last edited by jovanovm; 01-20-2008, 05:54 AM.

                                Comment

                                Working...
                                X