No announcement yet.

AMD Catalyst 8.01 Linux Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    8.01 first impressions

    8.01 first impressions: (Thinkpad T60, X1400, Kubuntu Gutsy)

    - installation was straightforward: --buildpkg Ubuntu/gutsy
    dpkg -i xorg-driver-fglrx_8.452.1-1_i386.deb fglrx-kernel-source_8.452.1-1_i386.deb fglrx-amdcccle_8.452.1-1_i386.deb
    restart X

    (I had all the other stuff like compiler tools and restricted modules settings already in place from previous installs)

    - everything that worked in 7.12 still works, including suspend/resume
    - the screen corruption when dragging icons around on the desktop is gone
    - the resolution issues are fixed
    - I didn't run benchmarks but my main 3D app googleearth runs about the same as before, certainly not worse
    - video playing is essentially the same as before: kind of ok with GL, some flickering with xv. With compositing enabled, video playing is not usable with either GL or xv: too much flicker
    - two out of the three issues that remained for me in 7.12 have been resolved: good going ATI!

    Overall, for me this is the best fglrx I've used to date. Now make video and compositing work together and I'll be hard pressed to find something else to ask for.

    Ah and before I forget, here's my ceterum censeo: ATI please write up a document on what options this driver takes in xorg.conf and what they mean. I know there are some documents out there on the web people put together but it would be really nice to have a complete listing of options from the authoritative source.
    Last edited by chrisg; 01-18-2008, 04:24 PM. Reason: typo, some formatting problems


    • #62
      remove, reboot, reinstall

      Originally posted by Isaac702 View Post
      Well I'm dead in the water. I have updated to 8.1 but it crashes when ever I try to configure Xorg through Yast (My old settings don't work either Xorg crashes)
      Try the three R!

      I had a similar problem, and it went away after uninstalling the 8.45 rpm, installing the 8.40 rpm, uninstalling that and installing 8.45 again, with reboots inserted in this procedure generously. Feels like windows...

      Having another terminal to ssh into the machine under surgery helps to get around all those black screens on the way. If that's not possible, be sure to boot into runlevel 3 by entering a 3 into the boot options at the prompt.

      But in the end it worked for me, and I have a widescreen with 1680x1050 and fast 3D running.

      Cheers, shamooki

      Lenovo T60
      Mobility Radeon X1300
      OpenSUSE 10.3 x84_64


      • #63
        Originally posted by jackkerouac View Post
        Well, after installing this driver, I cannot even get into the GDM login screen. I just get a blank, black screen with nothing else. ALT-CTRL-F1 or F2 doesn't work. I have to hard-reset.

        ATI X1650 Pro, Gutsy 7.10

        Here is my Xorg.0.log:

        Any ideas on why this is happening? 8.40.4 works just fine. It's what I am using now in place of any of the new drivers. Any driver after 8.40.4 gives me the same problems.

        Any help would be really appreciated.
        From what I see it tries to load an old fglrx(8.37.6). Have you blacklisted the ubuntu's fglrx? info

        Originally posted by chrisg --buildpkg Ubuntu/gutsy
        dpkg -i xorg-driver-fglrx_8.452.1-1_i386.deb fglrx-kernel-source_8.452.1-1_i386.deb fglrx-amdcccle_8.452.1-1_i386.deb
        restart X
        I think you mean --buildpkg Ubuntu/gutsy
        EDIT: You fixed it already!!!


        • #64
          any x200 experiences???


          • #65
            Any chances to have an hotfix for not working cards? It's the 3rd unusable version in a row for me (memory leak, resolution issue and now not even 3d acceleration)?


            • #66
              Originally posted by Michael View Post
              For the Fedora packaging bug, I'll push updated scripts to Phorogit for it tonight once I get back to my hotel.
              Thanks Michael, I would appreciate that. Do you know why this does not work:

              1) unpack driver into tempdir
              2) cd tempdir (and fix missing file in the spec file template)
              3) ./ --buildpkg Fedora/F8

              Step 3 always comes back with this error: Unrecognized parameter '' to

              Am I doing something wrong or is it a bug? Thanks.


              • #67
                You forget to use the "real" version as first option to That's NOT 8-01 but 8.452.1. Example from my script:

                bash $VER --buildpkg $DISTRIB_ID/$DISTRIB_CODENAME


                • #68
                  Summary for my Inspiron 6400, Radeon Mobility X1400, Ubuntu/gutsy:
                  - 1440x900 supported once more.
                  - suspend not working again (7.12 was fine).
                  - unable to end an X session; system crashes.
                  - VLC will not play videos with the OpenGL output plug-in.
                  - most things noticeably slower.

                  Too bad, really.


                  • #69
                    As there are very big compatibity issues especially with lastest Intel G33/P35 chipset (board used: Gigabyte GA-G33-DS3R) I would highly advice ATI to use this for testing, especially RV410 and those cases:

                    a) switch from ati oss to fglrx
                    b) switch from fglrx to another version
                    c) ctrl+alt+backspace - will often result in a state that kdm is still running and new x is therefore not started
                    d) oss driver with latest xorg + compiz fusion: enable water + enable snow effect + rotate cube
                    e) add a modeline

                    Many of those cases force crash the xserver or even the hole system (no ssh login possible anymore).


                    • #70
                      I haven't seen anything mentioned regarding the issue with aiglx under xserver 1.4.

                      Can anyone enlighten me on wether this is fixed? If not, I'll put upgrading on hold for a while.


                      • #71
                        Originally posted by Kano View Post
                        You forget to use the "real" version as first option to That's NOT 8-01 but 8.452.1. Example from my script:

                        bash $VER --buildpkg $DISTRIB_ID/$DISTRIB_CODENAME
                        Thanks a bunch Kano! That did the trick. Packages have been successfully generated. W00t!


                        • #72
                          Uhh it makes me wonder !!

                          When does the fglrx comedy will end, when AMD/ATI will have all the spec released ? So anyone could just play with working open-source driver ?
                          It represents such a waste of resource,

                          I am pretty sure that the driver's devs at AMD would be very pleased to work for the open-source one instead of continuing to build frustrating / unused (since it won't never be installed by default).
                          I wouldn't like to be one of them, being flamed at every released isn't motivating. I hope for them that one day they could dev on the open-source side, they would be warmly welcomed, right ?
                          It is such a pain to see how the industry has build limitations on natural progress of things.
                          I know the "we don't do what we want" blabla, I only talk about how peoples feel it. And how they can feel to be useful in their job.

                          What would it be if AMD stopped the release of fglrx for some time, to push the open-source project to the top ?
                          I guess there are far more hope from every users in the open source driver, so if anyone working on fglrx would work on radeon and radeonhd, who would complain ?
                          After that they could reuse most of the code to build the closed pieces on top of the open source part.
                          I know that there it is risky to push the driver if the spec are not out, but I am sure that M. Bridgman wouldn't refuse some help to accomplish his goals.

                          I know that my post isn't smart nor well thought maybe full of contradiction and not well written (french speaking inside), I only speak about how I feel this rahhhhh it's so egocentric, but who's not frustrated ?

                          Anyway piece everyone, I feel compassion for devs who certainly work hard but can't express themselves to their full potential.
                          Hope for better days without fglrx, good night everyone.
                          Last edited by lucky_; 01-18-2008, 07:03 PM.


                          • #73

                            My friend on a previous post here you ask a fellow which Xorg acceleration type he uses XAA or EXA.

                            Can we use EXA acceleration with fglrx?? And if yes how? Cause my xorg.0.log always reports about the classic XAA accel...
                            Should I change something at my xorg.conf?

                            Also I can confirm Suspend2RAM now works here for my 2.6.24-rc7 kernel on openSuSE 10.3 64-bit system.

                            Compared to 7.12 AIGLX behaviour is the same, 3D-2D performance the same.

                            The previous driver enabled XV and Textured features for 32-bit systems for RS690 chipset-X1250 AVIVO IGP! I can confirm that too...

                            But still no Xv and Textured stuff here for my 64-bit opensuse.. Any ideas when will this be enabled for us?? Cause I was looking forward to 8.1 expecting AVIVO Xv support for 64 bit too... But no luck again

                            Last edited by djdoo; 01-18-2008, 07:36 PM.


                            • #74
                              For me the drivers work fine..If anything I see an improvement in fps running UT2K4 over the 7.12's..with them the fps would dip into the yellow and flicker red on occasion.. Solid green with the 8.01.4's
                              averaged out a nice 92 low 45 high 178..Scrolling in FF is fine, compiz-fusion works when I enable it..

                              Only downside is using AMD's default installer..Mandriva has yet to fix their --buildpkg script.
                              Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
                              Ben Franklin 1755


                              • #75
                                Originally posted by shamooki View Post
                                Try the three R!

                                I had a similar problem, and it went away after uninstalling the 8.45 rpm, installing the 8.40 rpm, uninstalling that and installing 8.45 again, with reboots inserted in this procedure generously. Feels like windows...
                                Thanks for you help. I managed to get it to work in the end.

                                Although I still have decided to go back to radeonhd as Fglrx 8.1 still renders well anything extremely slowly since the launch of the new code base. ATI fix the regression.