Announcement

Collapse
No announcement yet.

AMD Catalyst 8.01 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by assasukasse View Post
    Hello
    i tried the new drivers on my ubuntu gutsy machine.
    I blacklisted ubuntu driver and tested..they don't work, or better DRI doesn't work with them.
    Then i completely uninstalled ubuntu restricted package, and tried again, same result
    with those drivers DRI doesn't work..
    ...well if you were wanting help...you'd have to give us a bit more than just that...like the xorg log, fglrxinfo, glxinfo output for starters...and if glxgears works, fps of glxgears, etc...

    Comment


    • hello
      now i reverted back to the drivers in ubuntu and fglrx works.
      But when i tried the new drivers:
      my glxgears worked, just showed me around 200fps
      fglrxinfo told me i was using mesa
      glxinfo told me no dri

      and here is my same xorg.conf, which works with fglrx in ubuntu

      Code:
      # xorg.conf (xorg X Window System server configuration file)
      #
      # This file was generated by dexconf, the Debian X Configuration tool, using
      # values from the debconf database.
      #
      # Edit this file with caution, and see the xorg.conf manual page.
      # (Type "man xorg.conf" at the shell prompt.)
      #
      # This file is automatically updated on xserver-xorg package upgrades *only*
      # if it has not been modified since the last upgrade of the xserver-xorg
      # package.
      #
      # If you have edited this file but would like it to be automatically updated
      # again, run the following command:
      #   sudo dpkg-reconfigure -phigh xserver-xorg
      
      Section "ServerLayout"
      	
      	# Uncomment if you have a wacom tablet
      	#	InputDevice     "stylus"	"SendCoreEvents"
      	#	InputDevice     "cursor"	"SendCoreEvents"
      	#	InputDevice     "eraser"	"SendCoreEvents"
      	Identifier	"Default Layout"
        screen 0 "aticonfig-Screen[0]" 0 0
      	Inputdevice	"Generic Keyboard"
      	Inputdevice	"Configured Mouse"
      EndSection
      
      Section "Files"
      EndSection
      
      Section "Module"
      	Load		"vnc"
      	Load		"glx"
      	Load		"dri"
      	Load		"extmod"
      	Load		"freetype"
      	Load		"ddc"
      EndSection
      
      
      Section "InputDevice"
      	Identifier	"Generic Keyboard"
      	Driver		"kbd"
      	Option		"CoreKeyboard"
      	Option		"XkbRules"	"xorg"
      	Option		"XkbModel"	"pc105"
      	Option		"XkbLayout"	"it"
      EndSection
      
      Section "InputDevice"
      	Identifier	"Configured Mouse"
      	Driver		"mouse"
      	Option		"CorePointer"
      	Option		"Device"	"/dev/input/mice"
      	Option		"Protocol"	"ImPS/2"
      	Option		"ZAxisMapping"	"4 5"
      	Option		"Emulate3Buttons"	"true"
      EndSection
      
      Section "InputDevice"
      	Identifier	"stylus"
      	Driver		"wacom"
      	Option		"Device"	"/dev/input/wacom"
      	Option		"Type"	"stylus"
      	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
      EndSection
      
      Section "InputDevice"
      	Identifier	"eraser"
      	Driver		"wacom"
      	Option		"Device"	"/dev/input/wacom"
      	Option		"Type"	"eraser"
      	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
      EndSection
      
      Section "InputDevice"
      	Identifier	"cursor"
      	Driver		"wacom"
      	Option		"Device"	"/dev/input/wacom"
      	Option		"Type"	"cursor"
      	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
      EndSection
      
      Section "Monitor"
      	Identifier	"aticonfig-Monitor[0]"
      	Option		"VendorName"	"ATI Proprietary Driver"
      	Option		"ModelName"	"Generic Autodetecting Monitor"
      	Option		"DPMS"	"true"
      EndSection
      
      Section "Device"
      	Identifier	"aticonfig-Device[0]"
      	Driver		"fglrx"
      	Option		"AccelMethod"	"XAA"
      	Option		"XAANoOffscreenPixmaps"	"true"
      	Option		"RenderAccel"	"true"
      	Option		"EnablePageFlip"	"1"
      	Option		"ColorTiling"	"1"
      	Option		"AGPMode"	"8"
      	Option		"GARTSize"	"64"
      	Option		"VideoOverlay"	"on"
      	Option		"OpenGLOverlay"	"off"
      EndSection
      
      Section "Screen"
      	Identifier	"aticonfig-Screen[0]"
      	Device		"aticonfig-Device[0]"
      	Monitor		"aticonfig-Monitor[0]"
      	Defaultdepth	24
      	SubSection "Display"
      		Viewport	0	0
      		Depth	24
      	EndSubSection
      EndSection
      
      Section "DRI"
      	Mode	0666
      EndSection
      
      Section "Extensions"
      	Option		"Composite"	"Disable"
      	Option		"Composite"	"0"
      EndSection

      Comment


      • According to Tom's link 8.02 will be out on February 13.

        Comment


        • Ignore Dupe Post
          Last edited by n3cr0; 02-07-2008, 06:24 PM.

          Comment


          • Originally posted by assasukasse View Post
            hello
            now i reverted back to the drivers in ubuntu and fglrx works.
            But when i tried the new drivers:
            my glxgears worked, just showed me around 200fps
            fglrxinfo told me i was using mesa
            glxinfo told me no dri

            and here is my same xorg.conf, which works with fglrx in ubuntu

            Code:
            # xorg.conf (xorg X Window System server configuration file)
            #
            # This file was generated by dexconf, the Debian X Configuration tool, using
            # values from the debconf database.
            #
            # Edit this file with caution, and see the xorg.conf manual page.
            # (Type "man xorg.conf" at the shell prompt.)
            #
            # This file is automatically updated on xserver-xorg package upgrades *only*
            # if it has not been modified since the last upgrade of the xserver-xorg
            # package.
            #
            # If you have edited this file but would like it to be automatically updated
            # again, run the following command:
            #   sudo dpkg-reconfigure -phigh xserver-xorg
            
            Section "ServerLayout"
            	
            	# Uncomment if you have a wacom tablet
            	#	InputDevice     "stylus"	"SendCoreEvents"
            	#	InputDevice     "cursor"	"SendCoreEvents"
            	#	InputDevice     "eraser"	"SendCoreEvents"
            	Identifier	"Default Layout"
              screen 0 "aticonfig-Screen[0]" 0 0
            	Inputdevice	"Generic Keyboard"
            	Inputdevice	"Configured Mouse"
            EndSection
            
            Section "Files"
            EndSection
            
            Section "Module"
            	Load		"vnc"
            	Load		"glx"
            	Load		"dri"
            	Load		"extmod"
            	Load		"freetype"
            	Load		"ddc"
            EndSection
            
            
            Section "InputDevice"
            	Identifier	"Generic Keyboard"
            	Driver		"kbd"
            	Option		"CoreKeyboard"
            	Option		"XkbRules"	"xorg"
            	Option		"XkbModel"	"pc105"
            	Option		"XkbLayout"	"it"
            EndSection
            
            Section "InputDevice"
            	Identifier	"Configured Mouse"
            	Driver		"mouse"
            	Option		"CorePointer"
            	Option		"Device"	"/dev/input/mice"
            	Option		"Protocol"	"ImPS/2"
            	Option		"ZAxisMapping"	"4 5"
            	Option		"Emulate3Buttons"	"true"
            EndSection
            
            Section "InputDevice"
            	Identifier	"stylus"
            	Driver		"wacom"
            	Option		"Device"	"/dev/input/wacom"
            	Option		"Type"	"stylus"
            	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
            EndSection
            
            Section "InputDevice"
            	Identifier	"eraser"
            	Driver		"wacom"
            	Option		"Device"	"/dev/input/wacom"
            	Option		"Type"	"eraser"
            	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
            EndSection
            
            Section "InputDevice"
            	Identifier	"cursor"
            	Driver		"wacom"
            	Option		"Device"	"/dev/input/wacom"
            	Option		"Type"	"cursor"
            	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
            EndSection
            
            Section "Monitor"
            	Identifier	"aticonfig-Monitor[0]"
            	Option		"VendorName"	"ATI Proprietary Driver"
            	Option		"ModelName"	"Generic Autodetecting Monitor"
            	Option		"DPMS"	"true"
            EndSection
            
            Section "Device"
            	Identifier	"aticonfig-Device[0]"
            	Driver		"fglrx"
            	Option		"AccelMethod"	"XAA"
            	Option		"XAANoOffscreenPixmaps"	"true"
            	Option		"RenderAccel"	"true"
            	Option		"EnablePageFlip"	"1"
            	Option		"ColorTiling"	"1"
            	Option		"AGPMode"	"8"
            	Option		"GARTSize"	"64"
            	Option		"VideoOverlay"	"on"
            	Option		"OpenGLOverlay"	"off"
            EndSection
            
            Section "Screen"
            	Identifier	"aticonfig-Screen[0]"
            	Device		"aticonfig-Device[0]"
            	Monitor		"aticonfig-Monitor[0]"
            	Defaultdepth	24
            	SubSection "Display"
            		Viewport	0	0
            		Depth	24
            	EndSubSection
            EndSection
            
            Section "DRI"
            	Mode	0666
            EndSection
            
            Section "Extensions"
            	Option		"Composite"	"Disable"
            	Option		"Composite"	"0"
            EndSection
            Want to throw in your xorg log and the output for glxinfo/fglrxinfo when running catalyst 8.01 too?

            ...or you could wait for 8.02 and then give that a spin and see what comes of it. (if it still doesn't work...post the above information).

            Comment

            Working...
            X