Announcement

Collapse
No announcement yet.

AMD Catalyst 8.01 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "slow 2d" is somewhat vague. Perhaps actually some tests (such as with x11perf), details of what hardware & software is running (including which version of xorg, xserver, which window manager, etc etc etc) would be helpful. I'm guessing no such issues arise on ati's test machines, and if people simply say "it's slow", they're going to completely ignore such comments because there's no basis. I'm also going to add that there's an awful lot between a video card driver, and moving a window about, and there's an awful lot where things can cause it to slow down. So at least compare quantifiable speeds with all other things equal other than video card drivers.
    Just my 2c.

    Comment


    • @Wired

      I highly doubt that. The standard oss driver works fine usually with these simple things. Also fglrx is maybe the worst driver for xv accelleration when you would own a newer gpu. Even beryl/compiz would work good with oss driver - with some special exceptions with my X700SE and Xserver 1.4 of course.

      Comment


      • driver still hangs when upon access by first 3D app. after that everything is good. but why can't they fix it.

        Comment


        • You are not the only one who asks this. Btw. if you like go back to 8.39.4 *g*

          Comment


          • Originally posted by Kano View Post
            @Wired

            I highly doubt that. The standard oss driver works fine usually with these simple things. Also fglrx is maybe the worst driver for xv accelleration when you would own a newer gpu. Even beryl/compiz would work good with oss driver - with some special exceptions with my X700SE and Xserver 1.4 of course.
            I'd doubt it too if I hadn't experienced it. Actually I am reproducing it right now... I switched to the oss driver, complete with DRI and DMAforXV enabled and the (hd) video lags and breaks like hell.

            Worked fine 10 minutes ago under fglrx...

            On the other hand, I can't get compiz to work w/ fglrx so there's no definite winner...

            Comment


            • The other day I considered mailing ATI my laptop so that they could at least test their driver on the X1400 mobility before releases. 7.11 is the last driver that works to a decent extent (minus suspending, of course). I guess I'm getting a bit desperate?

              Comment


              • Answering to mirv:
                Ignoring people is not the answer... They should dig into the problem, we are not testers nor developers, and not all the people knows how to do this tests... if people is complaining since 2005 because slow 2d rendering and decreasing performance SOMETHING must be happening, and i believe it's a duty of a serious company to give SOLUTIONS to people with problems... i have confirmed this bug with mi X200 IGP on an intel D101GGC MoBo, and with my MSI X1300 Radeon, on ubuntu Feisty AND OpenSuse 10.3 (both recently installed), with 8.01 driver...

                Comment


                • @Wired

                  are you 100% sure you cleaned fglrx? Are you sure that no fglrx module is loaded but radeon+drm?

                  Comment


                  • Hello everybody...
                    Well, don't know if things are going better or not.
                    -8.42 and 8.43: my laptop suffered the GL memory leak
                    -7.12: max resolution 1280x1024, instead of 1680x1050
                    -8.01: no memory leak, resolution 1680x1050, but... 50 FPS with glxgears and the same with fgl_glxgears!

                    As a F.C.Barcelona supporter, I felt capable to follow and test the progress of this driver, but this begins to make me so depressive...

                    Did not test suspend/hibernate, dual display... I don't feel encouraged.

                    Dell Inspiron 6400, ATI Mobility X1400, Mandriva Cooker (Xorg 1.4)
                    Last edited by Osado; 01-23-2008, 05:29 PM.

                    Comment


                    • Originally posted by Osado View Post
                      -8.01: no memory leak, resolution 1680x1050, but... 50 FPS with glxgears and the same with fgl_glxgears!

                      Dell 6400, ATI Mobility X1400, Mandriva Cooker (Xorg 1.4)
                      50 FPS sounds like disabled hardware 3D support.
                      What error messages are you getting?

                      Cheers,
                      knutbert

                      Comment

                      Working...
                      X