Announcement

Collapse
No announcement yet.

AMD Catalyst 8.01 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hardy Heron up to date - Catalyst 8.1 from repo - no Compiz yet due the Xserver 1.4 compat but:

    2D capabilities are heavily improved over 7.12 - I test this with Inkscape ( great use of Blur filter )

    Also 3D present some very good performance vs 7.12 (visible with the free look) - I tested with Quake Wars, Quake 4 and True Combat Elite.

    On Ctrl + ALt + Backspace => Blank screen + Freeze

    Comment


    • This is my experience with 8.1 on HD3850 Hardware.

      On Ubuntu 7.10 everything including Compiz works as expected. Video playback does have a lot of tearing with or without Compiz.

      I cannot use Control-Alt Backspace to restart X. It locks up every time.

      On a side note. Compiz looks much better than it did on the Nvidia 6800GS that I replaced with this card.

      Comment


      • Hi,
        I finally managed to build the rpm packages here on my Fedora 8 using modified scripts from phorogit.
        Now I've installed them, loaded the fglrx module, restarted X with the same working xorg.conf I had before and the result of $fglrxinfo is

        Code:
        display: :0.0 screen: 0
        OpenGL vendor string: Mesa project: http://www.mesa3d.org
        OpenGL renderer string: Mesa GLX Indirect
        OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
        
        Segmentation Fault
        I suspect something went wrong, but I really can't figure it out... I rebuilt-reinstalled the rpms but it didn't help.

        Comment


        • i've given up on using 8.01.... i've tried it and tried to fix the libc.so.6 error in many ways but i haven't been able to do it.... now i've switched to the radeon driver, at least for the x200m, and i'm quite happy with it. the 8.01 is really a delusion. this is the first release after 8.41 that doesn't work on the x200m....

          Comment


          • I have no problem installing this driver but it is incompatible with one of my video card.

            The HD2600 pro 512M AGP is not compatible with this driver nor is it with any other even radeonHD!! I'M stuck with vesa in Linux! I know for a fact that this driver work very well with the PCIE version of this video card.

            Description of problem.

            When X start the screen go Black and the keyboard die. Yes I really said that the keyboard die! Impossible to light on the led light for Num, Caps, or scroll. Everything is frozen.

            My best guess is that the driver configured my card has a PCIE card instead of an AGP card. I reallllly hope that ATI/AMD fix this compatibility issue fast before I give up on this card.

            Comment


            • Thanks Legume

              Thanks Legume,
              using gl as the output module for mplayer is a great workaround!


              -Sreyan

              Comment


              • My experience with the fglrx 8.45(ATI Catalyst 8.1 Proprietary Linux x86 Display Driver) on openSUSE 10.3

                1) Being a lnux noob I installed the latest driver from the ATI openSUSE repo.

                2) Tried fgl_gears after install and got segment fault error

                3) logged in as root and issued the command init 3

                4) ldconfig(I don't know if that is necessary)

                5) aticonfig --initial --input=/etc/X11/xorg.conf

                6) sax2 -r -m 0=fglrx (to configure extra settings)

                7) reboot

                Everything worked fine! Only problem I can't change the gamma directly in RTCW - Enemy Territory(had this problem since fglrx 8.41+ with 8.40 I could change the gamma in game) but only by setting gamma in ATI Catalyst Control Centre first then launching the game.

                Oh by the way I have Kernel 2.6.22.16 installed and I'm using the ATI X300 Mobility on an Inspiron 6000.

                Comment


                • ive been using 8.01 for a day now ... and to my surprise I found myself forgetting I had been trying it.

                  Id been using 8.40 still with XGL (and im not saying i wouldnt go back), but the only issues I run into with 8.45 are:

                  - kxdocker is slow as hell, but i suspect this is bad coding

                  - video playback and other opengl apps dont draw properly when using compiz, but isnt that an AIGLX/compiz thing ? i think i has nothing to do with catalyst.

                  for the rest, compiz seems more or less just as smooth, i have no scrolling problems or anyhintg like that ...

                  so if they can only fix the opengl/video compiz issues, that optimize the code so that it gets smoother and smoother, then all will be fine.

                  I have to admit however, that I am no gamer, and I havent tried anything really extensive on the driver, yet.

                  Sooner or later i guess newer releases will feature more speed and less breakage ..

                  Comment


                  • Radeon 9600 pro dualhead is broken

                    Once again I'm going to be reverting back to an old driver because the latest one is stuffed.

                    I'm running dualhead with big desktop on Ubuntu 7.10 and the second monitor on the VGA port is only showing a max resolution of 1024x768.

                    Previously it worked fine at 1280x1024, using 8.43 wtf is going on.

                    Here's my xorg.conf for those that might be able to help.

                    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
                    #
                    # This file was generated by dexconf, the Debian X Configuration tool, using
                    # values from the debconf database.
                    #
                    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
                    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
                    #
                    # This file is automatically updated on xserver-xorg package upgrades *only*
                    # if it has not been modified since the last upgrade of the xserver-xorg
                    # package.
                    #
                    # If you have edited this file but would like it to be automatically updated
                    # again, run the following command:
                    # sudo dpkg-reconfigure -phigh xserver-xorg

                    Section "ServerLayout"
                    Identifier "Default Layout"
                    Screen 0 "aticonfig-Screen[0]" 0 0
                    InputDevice "Generic Keyboard"
                    InputDevice "Configured Mouse"
                    InputDevice "stylus" "SendCoreEvents"
                    InputDevice "cursor" "SendCoreEvents"
                    InputDevice "eraser" "SendCoreEvents"
                    EndSection

                    Section "Files"

                    # path to defoma fonts
                    FontPath "/usr/share/X11/fonts/misc"
                    FontPath "/usr/share/X11/fonts/cyrillic"
                    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
                    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
                    FontPath "/usr/share/X11/fonts/Type1"
                    FontPath "/usr/share/X11/fonts/100dpi"
                    FontPath "/usr/share/X11/fonts/75dpi"
                    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
                    EndSection

                    Section "Module"
                    Load "i2c"
                    Load "bitmap"
                    Load "ddc"
                    Load "extmod"
                    Load "freetype"
                    Load "int10"
                    Load "type1"
                    Load "vbe"
                    Load "glx"
                    Load "dri"
                    Load "dbe"
                    Load "v4l"
                    EndSection

                    Section "ServerFlags"
                    Option "AIGLX" "on"
                    EndSection

                    Section "InputDevice"
                    Identifier "Generic Keyboard"
                    Driver "kbd"
                    Option "CoreKeyboard"
                    Option "XkbRules" "xorg"
                    Option "XkbModel" "pc105"
                    Option "XkbLayout" "ch"
                    Option "XkbVariant" "de"
                    EndSection

                    Section "InputDevice"
                    Identifier "Configured Mouse"
                    Driver "mouse"
                    Option "CorePointer"
                    Option "Device" "/dev/input/mice"
                    Option "Protocol" "ExplorerPS/2"
                    Option "ZAxisMapping" "4 5"
                    Option "Emulate3Buttons" "true"
                    EndSection

                    Section "InputDevice"
                    Identifier "stylus"
                    Driver "wacom"
                    Option "Device" "/dev/input/wacom"
                    Option "Type" "stylus"
                    Option "PressCurve" "50,0,100,50"
                    Option "ForceDevice" "ISDV4"
                    EndSection

                    Section "InputDevice"
                    Identifier "eraser"
                    Driver "wacom"
                    Option "Device" "/dev/input/wacom"
                    Option "Type" "eraser"
                    Option "ForceDevice" "ISDV4"
                    EndSection

                    Section "InputDevice"
                    Identifier "cursor"
                    Driver "wacom"
                    Option "Device" "/dev/input/wacom"
                    Option "Type" "cursor"
                    Option "ForceDevice" "ISDV4"
                    EndSection

                    Section "Monitor"
                    Identifier "aticonfig-Monitor[0]"
                    DisplaySize 338 270
                    Option "VendorName" "ATI Proprietary Driver"
                    Option "ModelName" "Generic Autodetecting Monitor"
                    Option "DPMS" "true"
                    Option "DPI" "96x96"
                    EndSection

                    Section "Monitor"
                    Identifier "aticonfig-Monitor[1]"
                    DisplaySize 330 270
                    Option "VendorName" "ATI Proprietary Driver"
                    Option "ModelName" "Generic Autodetecting Monitor"
                    Option "DPMS" "true"
                    Option "DPI" "96x96"
                    EndSection

                    Section "Device"
                    Identifier "aticonfig-Device[0]"
                    Driver "fglrx"
                    Option "DesktopSetup" "horizontal"
                    Option "VideoOverlay" "on"
                    Option "OpenGLOverlay" "off"
                    Option "UseFastTLS" "2"
                    Option "AGPFastWrite" "yes"
                    Option "AGPMode" "8"
                    Option "ColorTiling" "on"
                    Option "EnablePageFlip" "true"
                    Option "AccelMethod" "XAA"
                    Option "XAANoOffScreenPixMaps" "true"
                    Option "RenderAccel" "true"
                    Option "ForceMonitors" "crt1,"
                    Option "EnableMonitor" "crt2,"
                    Option "DisableGLXRootClipping" "true"
                    Option "AddARGBXVisuals" "true"
                    Option "AllowGLXWithComposite" "true"
                    Option "NoDDC"
                    # Option "TexturedVideo" "on"
                    # Option "DRI" "true"
                    Option "Mode2" "1280x1024"
                    BusID "PCI:1:0:0"
                    EndSection

                    Section "Device"

                    # Option "DRI" "true"
                    Identifier "aticonfig-Device[1]"
                    Driver "fglrx"
                    Option "VideoOverlay" "on"
                    Option "OpenGLOverlay" "off"
                    Option "UseFastTLS" "2"
                    Option "AGPFastWrite" "yes"
                    Option "AGPMode" "8"
                    Option "ColorTiling" "on"
                    Option "EnablePageFlip" "true"
                    Option "AccelMethod" "XAA"
                    Option "XAANoOffScreenPixMaps" "true"
                    Option "RenderAccel" "true"
                    Option "NoDDC"
                    Option "DisableGLXRootClipping" "true"
                    Option "AddARGBXVisuals" "true"
                    Option "AllowGLXWithComposite" "true"
                    # Option "TexturedVideo" "on"
                    BusID "PCI:1:0:0"
                    Screen 1
                    EndSection

                    Section "Screen"
                    Identifier "aticonfig-Screen[0]"
                    Device "aticonfig-Device[0]"
                    Monitor "aticonfig-Monitor[0]"
                    DefaultDepth 24
                    SubSection "Display"
                    Viewport 0 0
                    Depth 24
                    Modes "1280x1024" "1024x768"
                    EndSubSection
                    EndSection

                    Section "Screen"
                    Identifier "aticonfig-Screen[1]"
                    Device "aticonfig-Device[1]"
                    Monitor "aticonfig-Monitor[1]"
                    DefaultDepth 24
                    SubSection "Display"
                    Viewport 0 0
                    Depth 24
                    Modes "1280x1024"
                    EndSubSection
                    EndSection

                    Section "DRI"
                    Mode 0666
                    EndSection

                    Comment


                    • Radeon 9800pro

                      Hello
                      i tried the new drivers on my ubuntu gutsy machine.
                      I blacklisted ubuntu driver and tested..they don't work, or better DRI doesn't work with them.
                      Then i completely uninstalled ubuntu restricted package, and tried again, same result
                      with those drivers DRI doesn't work..

                      Comment


                      • Originally posted by assasukasse View Post
                        Hello
                        i tried the new drivers on my ubuntu gutsy machine.
                        I blacklisted ubuntu driver and tested..they don't work, or better DRI doesn't work with them.
                        Then i completely uninstalled ubuntu restricted package, and tried again, same result
                        with those drivers DRI doesn't work..
                        ...well if you were wanting help...you'd have to give us a bit more than just that...like the xorg log, fglrxinfo, glxinfo output for starters...and if glxgears works, fps of glxgears, etc...

                        Comment


                        • hello
                          now i reverted back to the drivers in ubuntu and fglrx works.
                          But when i tried the new drivers:
                          my glxgears worked, just showed me around 200fps
                          fglrxinfo told me i was using mesa
                          glxinfo told me no dri

                          and here is my same xorg.conf, which works with fglrx in ubuntu

                          Code:
                          # xorg.conf (xorg X Window System server configuration file)
                          #
                          # This file was generated by dexconf, the Debian X Configuration tool, using
                          # values from the debconf database.
                          #
                          # Edit this file with caution, and see the xorg.conf manual page.
                          # (Type "man xorg.conf" at the shell prompt.)
                          #
                          # This file is automatically updated on xserver-xorg package upgrades *only*
                          # if it has not been modified since the last upgrade of the xserver-xorg
                          # package.
                          #
                          # If you have edited this file but would like it to be automatically updated
                          # again, run the following command:
                          #   sudo dpkg-reconfigure -phigh xserver-xorg
                          
                          Section "ServerLayout"
                          	
                          	# Uncomment if you have a wacom tablet
                          	#	InputDevice     "stylus"	"SendCoreEvents"
                          	#	InputDevice     "cursor"	"SendCoreEvents"
                          	#	InputDevice     "eraser"	"SendCoreEvents"
                          	Identifier	"Default Layout"
                            screen 0 "aticonfig-Screen[0]" 0 0
                          	Inputdevice	"Generic Keyboard"
                          	Inputdevice	"Configured Mouse"
                          EndSection
                          
                          Section "Files"
                          EndSection
                          
                          Section "Module"
                          	Load		"vnc"
                          	Load		"glx"
                          	Load		"dri"
                          	Load		"extmod"
                          	Load		"freetype"
                          	Load		"ddc"
                          EndSection
                          
                          
                          Section "InputDevice"
                          	Identifier	"Generic Keyboard"
                          	Driver		"kbd"
                          	Option		"CoreKeyboard"
                          	Option		"XkbRules"	"xorg"
                          	Option		"XkbModel"	"pc105"
                          	Option		"XkbLayout"	"it"
                          EndSection
                          
                          Section "InputDevice"
                          	Identifier	"Configured Mouse"
                          	Driver		"mouse"
                          	Option		"CorePointer"
                          	Option		"Device"	"/dev/input/mice"
                          	Option		"Protocol"	"ImPS/2"
                          	Option		"ZAxisMapping"	"4 5"
                          	Option		"Emulate3Buttons"	"true"
                          EndSection
                          
                          Section "InputDevice"
                          	Identifier	"stylus"
                          	Driver		"wacom"
                          	Option		"Device"	"/dev/input/wacom"
                          	Option		"Type"	"stylus"
                          	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
                          EndSection
                          
                          Section "InputDevice"
                          	Identifier	"eraser"
                          	Driver		"wacom"
                          	Option		"Device"	"/dev/input/wacom"
                          	Option		"Type"	"eraser"
                          	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
                          EndSection
                          
                          Section "InputDevice"
                          	Identifier	"cursor"
                          	Driver		"wacom"
                          	Option		"Device"	"/dev/input/wacom"
                          	Option		"Type"	"cursor"
                          	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
                          EndSection
                          
                          Section "Monitor"
                          	Identifier	"aticonfig-Monitor[0]"
                          	Option		"VendorName"	"ATI Proprietary Driver"
                          	Option		"ModelName"	"Generic Autodetecting Monitor"
                          	Option		"DPMS"	"true"
                          EndSection
                          
                          Section "Device"
                          	Identifier	"aticonfig-Device[0]"
                          	Driver		"fglrx"
                          	Option		"AccelMethod"	"XAA"
                          	Option		"XAANoOffscreenPixmaps"	"true"
                          	Option		"RenderAccel"	"true"
                          	Option		"EnablePageFlip"	"1"
                          	Option		"ColorTiling"	"1"
                          	Option		"AGPMode"	"8"
                          	Option		"GARTSize"	"64"
                          	Option		"VideoOverlay"	"on"
                          	Option		"OpenGLOverlay"	"off"
                          EndSection
                          
                          Section "Screen"
                          	Identifier	"aticonfig-Screen[0]"
                          	Device		"aticonfig-Device[0]"
                          	Monitor		"aticonfig-Monitor[0]"
                          	Defaultdepth	24
                          	SubSection "Display"
                          		Viewport	0	0
                          		Depth	24
                          	EndSubSection
                          EndSection
                          
                          Section "DRI"
                          	Mode	0666
                          EndSection
                          
                          Section "Extensions"
                          	Option		"Composite"	"Disable"
                          	Option		"Composite"	"0"
                          EndSection

                          Comment


                          • According to Tom's link 8.02 will be out on February 13.

                            Comment


                            • Ignore Dupe Post
                              Last edited by n3cr0; 02-07-2008, 06:24 PM.

                              Comment


                              • Originally posted by assasukasse View Post
                                hello
                                now i reverted back to the drivers in ubuntu and fglrx works.
                                But when i tried the new drivers:
                                my glxgears worked, just showed me around 200fps
                                fglrxinfo told me i was using mesa
                                glxinfo told me no dri

                                and here is my same xorg.conf, which works with fglrx in ubuntu

                                Code:
                                # xorg.conf (xorg X Window System server configuration file)
                                #
                                # This file was generated by dexconf, the Debian X Configuration tool, using
                                # values from the debconf database.
                                #
                                # Edit this file with caution, and see the xorg.conf manual page.
                                # (Type "man xorg.conf" at the shell prompt.)
                                #
                                # This file is automatically updated on xserver-xorg package upgrades *only*
                                # if it has not been modified since the last upgrade of the xserver-xorg
                                # package.
                                #
                                # If you have edited this file but would like it to be automatically updated
                                # again, run the following command:
                                #   sudo dpkg-reconfigure -phigh xserver-xorg
                                
                                Section "ServerLayout"
                                	
                                	# Uncomment if you have a wacom tablet
                                	#	InputDevice     "stylus"	"SendCoreEvents"
                                	#	InputDevice     "cursor"	"SendCoreEvents"
                                	#	InputDevice     "eraser"	"SendCoreEvents"
                                	Identifier	"Default Layout"
                                  screen 0 "aticonfig-Screen[0]" 0 0
                                	Inputdevice	"Generic Keyboard"
                                	Inputdevice	"Configured Mouse"
                                EndSection
                                
                                Section "Files"
                                EndSection
                                
                                Section "Module"
                                	Load		"vnc"
                                	Load		"glx"
                                	Load		"dri"
                                	Load		"extmod"
                                	Load		"freetype"
                                	Load		"ddc"
                                EndSection
                                
                                
                                Section "InputDevice"
                                	Identifier	"Generic Keyboard"
                                	Driver		"kbd"
                                	Option		"CoreKeyboard"
                                	Option		"XkbRules"	"xorg"
                                	Option		"XkbModel"	"pc105"
                                	Option		"XkbLayout"	"it"
                                EndSection
                                
                                Section "InputDevice"
                                	Identifier	"Configured Mouse"
                                	Driver		"mouse"
                                	Option		"CorePointer"
                                	Option		"Device"	"/dev/input/mice"
                                	Option		"Protocol"	"ImPS/2"
                                	Option		"ZAxisMapping"	"4 5"
                                	Option		"Emulate3Buttons"	"true"
                                EndSection
                                
                                Section "InputDevice"
                                	Identifier	"stylus"
                                	Driver		"wacom"
                                	Option		"Device"	"/dev/input/wacom"
                                	Option		"Type"	"stylus"
                                	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
                                EndSection
                                
                                Section "InputDevice"
                                	Identifier	"eraser"
                                	Driver		"wacom"
                                	Option		"Device"	"/dev/input/wacom"
                                	Option		"Type"	"eraser"
                                	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
                                EndSection
                                
                                Section "InputDevice"
                                	Identifier	"cursor"
                                	Driver		"wacom"
                                	Option		"Device"	"/dev/input/wacom"
                                	Option		"Type"	"cursor"
                                	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
                                EndSection
                                
                                Section "Monitor"
                                	Identifier	"aticonfig-Monitor[0]"
                                	Option		"VendorName"	"ATI Proprietary Driver"
                                	Option		"ModelName"	"Generic Autodetecting Monitor"
                                	Option		"DPMS"	"true"
                                EndSection
                                
                                Section "Device"
                                	Identifier	"aticonfig-Device[0]"
                                	Driver		"fglrx"
                                	Option		"AccelMethod"	"XAA"
                                	Option		"XAANoOffscreenPixmaps"	"true"
                                	Option		"RenderAccel"	"true"
                                	Option		"EnablePageFlip"	"1"
                                	Option		"ColorTiling"	"1"
                                	Option		"AGPMode"	"8"
                                	Option		"GARTSize"	"64"
                                	Option		"VideoOverlay"	"on"
                                	Option		"OpenGLOverlay"	"off"
                                EndSection
                                
                                Section "Screen"
                                	Identifier	"aticonfig-Screen[0]"
                                	Device		"aticonfig-Device[0]"
                                	Monitor		"aticonfig-Monitor[0]"
                                	Defaultdepth	24
                                	SubSection "Display"
                                		Viewport	0	0
                                		Depth	24
                                	EndSubSection
                                EndSection
                                
                                Section "DRI"
                                	Mode	0666
                                EndSection
                                
                                Section "Extensions"
                                	Option		"Composite"	"Disable"
                                	Option		"Composite"	"0"
                                EndSection
                                Want to throw in your xorg log and the output for glxinfo/fglrxinfo when running catalyst 8.01 too?

                                ...or you could wait for 8.02 and then give that a spin and see what comes of it. (if it still doesn't work...post the above information).

                                Comment

                                Working...
                                X