Announcement

Collapse
No announcement yet.

8.44 problems in creating debs for debian unstable

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.44 problems in creating debs for debian unstable

    Hi all,
    I've just joined the forum, found while searching for posts about the new installer ati 7.12 - 8.443. I'm using Debian Sid which uses Xorg 7.3 and kernel 2.6.23. I had to upgrade the system due to problems concerning the WM. In my previous configuration, Sid was using Xorg 7.2 and kernel 2.6.22. In that system I was able to install fglrx by creating the debs packages from the installer, then installed the module and edited the xorg.conf. The installer 8.40 worked properly.

    After the upgrade I used 8.443 installer that should be working fine with X 7.3 and kernel 2.6.23 but fails in creating the debs:

    smoke@debian:/video/documents/ATI$ sudo ./ati-driver-installer-8.443.1-x86.x86_64.run --buildpkg Debian/unstable


    dh_installdeb
    LD_PRELOAD= dh_shlibdeps --exclude=emul
    dpkg-shlibdeps: warning: symbol _XFlush used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextAddDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol _XReply used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextRemoveDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libpthread.so.0 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with librt.so.1 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libdl.so.2 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libm.so.6 (it uses none of its symbols).
    dpkg-shlibdeps: warning: symbol _XFlush used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextAddDisplay used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol _XReply used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextRemoveDisplay used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/glesx.so shouldn't be linked with libdl.so.2 (it uses none of its symbols).
    dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/fglrx-driver/usr/bin/fglrx_xgamma (its RPATH is '').
    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
    dh_shlibdeps: command returned error code 512
    make: *** [binary] Error 1
    dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
    Removing temporary directory: fglrx-install.lo8585
    Has anyone experienced the same problem? Any help will be very appreciated!

    The old installer 8.40 isn't reporting this error while building the packages but as it's not compatible with 2.6.23, I cannot fulfill the installation of fglrx.

    Thanks to everyone in advance

  • #2
    try kanotix rc7, ive had success with ATI drivers using it.

    Comment


    • #3
      Isn't kanotix a different distro of Linux? In general I feel at home in Debian, more than in others deb-based distros mostly because is the one I always used. I don't absolutely want to be harsh, but you know, reinstalling Linux changing the distro even if quite similar isn't that great (I've been using ubuntu for a short time and found several differences between them). fglrx worked fine on Debian till a week ago on older packages. This thing I'm experiencing has a few matches on web but I didn't realized what exactly is the solution. The only hint was a missing dependency but sounds strange that 8.40 installer isn't reporting this problem. As a matter of fact it doesn't seem to be the answer to the problem because no one posted the solution in the forum where the matter was questioned.

      I actually have the direct rendering and OpenGL support because Xorg 7.3 has correctly detected the Video Card but the results are very poor (let's say half the stats I had on 2.6.22 with fglrx 8.40).

      Hope I've been kind and not too confused (as I'm in reality because fglrx seems to be the doom of ATI's owners even if they told things would have changed)

      Thanks anyway

      Comment


      • #4
        dist-upgrade and try again, I had the same error yesterday. For some reason it works again tho.

        Comment


        • #5
          Originally posted by damentz View Post
          dist-upgrade and try again, I had the same error yesterday. For some reason it works again tho.
          That's a great news but I hope you'll assist me: unfortunately I've just launched a dist-upgrade and found 23 packages to be upgraded, related to pango and sylpheed (no good...). After rebooting, the ati installer keeps returning that error. Do you have any idea on what kind of problem we are figuring?

          I really thank you for your help, at least I'm not alone!

          Comment


          • #6
            Put ati-installer(s) into /usr/src then you don't need to dl it again and just execute my script - presinstalled with Kanotix but should work for Debian and Ubuntu too.

            http://kanotix.com/files/install-fglrx-debian.sh

            You can go back to 7-11 using

            -v 7-11

            option. Same works for many older versions and kernel 2.6.23, for 2.6.24 only 8.39.4 and newer works [there is a check included that it will not even tried on wrong kernel].

            Comment


            • #7
              Originally posted by Kano View Post
              Put ati-installer(s) into /usr/src then you don't need to dl it again and just execute my script - presinstalled with Kanotix but should work for Debian and Ubuntu too.

              http://kanotix.com/files/install-fglrx-debian.sh

              You can go back to 7-11 using

              -v 7-11

              option. Same works for many older versions and kernel 2.6.23, for 2.6.24 only 8.39.4 and newer works [there is a check included that it will not even tried on wrong kernel].
              I want to start my reply saying that is an honor to work with a Debian Developer.
              Unfortunately lady luck seems to be against me. I've put the installer 8.443 in /usr/src. Then I launched your script. It was able to build the packages but selected Ubuntu edgy as type (is it ok?). I installed the packages anyway and the module was built but not placed in the kernel (solved by adding it in /etc/modules and rebooting just to be sure). This is the fglrx grep on the dmesg once rebooted:

              Code:
              fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
              [fglrx] Maximum main memory to use for locked dma buffers: 432 MBytes.
              [fglrx] ASYNCIO init succeed!
              [fglrx] PAT is enabled successfully!
              [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
              Your script auto-edited the xorg.conf that looked like:

              Code:
              Section "InputDevice"
              	Identifier	"Generic Keyboard"
              	Driver		"kbd"
              	Option		"XkbRules"	"xorg"
              	Option		"XkbModel"	"pc105"
              	Option		"XkbLayout"	"it"
              EndSection
              
              Section "InputDevice"
              	Identifier	"Configured Mouse"
              	Driver		"mouse"
              EndSection
              
              Section "Device"
              	Identifier	"Configured Video Device"
              	Driver      "fglrx"
              	Option      "UseInternalAGPGART" "no"
              	Option      "VideoOverlay" "on"
              	Option      "OpenGLOverlay" "off"
              	Option      "MonitorLayout" "AUTO, AUTO"
              EndSection
              
              Section "Monitor"
              	Identifier	"Configured Monitor"
              EndSection
              
              Section "Screen"
              	Identifier	"Default Screen"
              	Monitor		"Configured Monitor"
              EndSection
              Section "DRI"
              	Mode 0666
              EndSection
              
              Section "Extensions"
              	Option	"Composite"	"1"
              #	Option	"RENDER"	"1"
              EndSection
              But in the end startx doesn't work properly, X hangs while starting leading me to a black screen with no chance to return in text mode using Ctrl Alt Backspace nor Ctrl Alt F*. Ctrl Alt Del is the only accepted and once back to normal this is the Xlog:

              Code:
              (II) Setting vga for screen 0.
              (II) fglrx(0): === [atiddxPreInit] === begin, [x]
              (II) Loading sub module "vgahw"
              (II) LoadModule: "vgahw"
              (II) Loading /usr/lib/xorg/modules//libvgahw.so
              (II) Module vgahw: vendor="X.Org Foundation"
              	compiled for 1.4.0.90, module version = 0.1.0
              	ABI class: X.Org Video Driver, version 2.0
              (II) fglrx(0): PCI bus 1 card 0 func 0
              (II) fglrx(0): Creating default Display subsection in Screen section
              	"Default Screen" for depth/fbbpp 8/8
              (EE) fglrx(0): Given depth (8) is not supported by fglrx driver
              (EE) fglrx(0): PreInitVisual failed
              SetVBEMode failed
              (EE) fglrx(0): PreInit failed
              (II) fglrx(0): === [atiddxPreInit] === end
              (II) UnloadModule: "fglrx"
              (II) UnloadModule: "vgahw"
              (II) Unloading /usr/lib/xorg/modules//libvgahw.so
              (EE) Screen(s) found, but none have a usable configuration.
              
              Fatal server error:
              no screens found
              This error is the same I got when I've tried to install the fglrx-driver from the non-free packages. Any hint?

              Hope I've written what you need to figure a way out,
              Thanks a lot

              Comment


              • #8
                Originally posted by Kano View Post
                Put ati-installer(s) into /usr/src then you don't need to dl it again and just execute my script - presinstalled with Kanotix but should work for Debian and Ubuntu too.

                http://kanotix.com/files/install-fglrx-debian.sh

                You can go back to 7-11 using

                -v 7-11

                option. Same works for many older versions and kernel 2.6.23, for 2.6.24 only 8.39.4 and newer works [there is a check included that it will not even tried on wrong kernel].
                I want to start my reply saying that is an honor to interact with a Debian Developer.

                Unfortunately seems like Lady Luck is against me. I've put the ati installer in /usr/src and downloaded your script. Once executed, it was able to create debs and module but he detected an Ubuntu Edgy (is it normal?). Anyway the module was not inserted so I added fglrx in /etc/modules and rebooted just to be sure. Grepping fglrx in the dmesg returned:

                Code:
                fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
                [fglrx] Maximum main memory to use for locked dma buffers: 432 MBytes.
                [fglrx] ASYNCIO init succeed!
                [fglrx] PAT is enabled successfully!
                [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
                Your script auto-edits xorg.conf that looked like:

                Code:
                Section "InputDevice"
                	Identifier	"Generic Keyboard"
                	Driver		"kbd"
                	Option		"XkbRules"	"xorg"
                	Option		"XkbModel"	"pc105"
                	Option		"XkbLayout"	"it"
                EndSection
                
                Section "InputDevice"
                	Identifier	"Configured Mouse"
                	Driver		"mouse"
                EndSection
                
                Section "Device"
                	Identifier	"Configured Video Device"
                	Driver      "fglrx"
                	Option      "UseInternalAGPGART" "no"
                	Option      "VideoOverlay" "on"
                	Option      "OpenGLOverlay" "off"
                	Option      "MonitorLayout" "AUTO, AUTO"
                EndSection
                
                Section "Monitor"
                	Identifier	"Configured Monitor"
                EndSection
                
                Section "Screen"
                	Identifier	"Default Screen"
                	Monitor		"Configured Monitor"
                EndSection
                Section "DRI"
                	Mode 0666
                EndSection
                
                Section "Extensions"
                	Option	"Composite"	"1"
                #	Option	"RENDER"	"1"
                EndSection
                Unfortunately startx doesn't lead to a normal situation and X hangs while starting getting a black screen with no chance to return in text mode by pressing Ctrl Alt Backspace or F*. Ctrl Alt Del is the only way out and once rebooted this is the only part of the Xlog complaining errors:

                Code:
                (II) Setting vga for screen 0.
                (II) fglrx(0): === [atiddxPreInit] === begin, [x]
                (II) Loading sub module "vgahw"
                (II) LoadModule: "vgahw"
                (II) Loading /usr/lib/xorg/modules//libvgahw.so
                (II) Module vgahw: vendor="X.Org Foundation"
                	compiled for 1.4.0.90, module version = 0.1.0
                	ABI class: X.Org Video Driver, version 2.0
                (II) fglrx(0): PCI bus 1 card 0 func 0
                (II) fglrx(0): Creating default Display subsection in Screen section
                	"Default Screen" for depth/fbbpp 8/8
                (EE) fglrx(0): Given depth (8) is not supported by fglrx driver
                (EE) fglrx(0): PreInitVisual failed
                SetVBEMode failed
                (EE) fglrx(0): PreInit failed
                (II) fglrx(0): === [atiddxPreInit] === end
                (II) UnloadModule: "fglrx"
                (II) UnloadModule: "vgahw"
                (II) Unloading /usr/lib/xorg/modules//libvgahw.so
                (EE) Screen(s) found, but none have a usable configuration.
                
                Fatal server error:
                no screens found
                This error is the same I got when I've tried to install the fglrx-driver from non-free repo.

                Thanks a lot for your help, I hope to have written all the useful infos to figure a way out

                Comment


                • #9
                  I've posted the answer quoting the message from Kano but I have less than 5 posts so the answer was sent to a moderator. Sorry for this long time.

                  I want to start my reply saying that is an honor to interact with a Debian Developer. But Lady Luck seems to be against me. I've moved the ati installer in /usr/src and used the script you suggested. It was able to create the debs and build the module but detected an Ubuntu as OS (is it normal?). Anyway, I've inserted the module adding it in /etc/modules and rebooted just to be sure. Grepping fglrx on dmesg returned:

                  Code:
                  fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
                  [fglrx] Maximum main memory to use for locked dma buffers: 432 MBytes.
                  [fglrx] ASYNCIO init succeed!
                  [fglrx] PAT is enabled successfully!
                  [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
                  Your script autoedited the xorg.conf that looked like:

                  Code:
                  Section "InputDevice"
                  	Identifier	"Generic Keyboard"
                  	Driver		"kbd"
                  	Option		"XkbRules"	"xorg"
                  	Option		"XkbModel"	"pc105"
                  	Option		"XkbLayout"	"it"
                  EndSection
                  
                  Section "InputDevice"
                  	Identifier	"Configured Mouse"
                  	Driver		"mouse"
                  EndSection
                  
                  Section "Device"
                  	Identifier	"Configured Video Device"
                  	Driver      "fglrx"
                  	Option      "UseInternalAGPGART" "no"
                  	Option      "VideoOverlay" "on"
                  	Option      "OpenGLOverlay" "off"
                  	Option      "MonitorLayout" "AUTO, AUTO"
                  EndSection
                  
                  Section "Monitor"
                  	Identifier	"Configured Monitor"
                  EndSection
                  
                  Section "Screen"
                  	Identifier	"Default Screen"
                  	Monitor		"Configured Monitor"
                  EndSection
                  Section "DRI"
                  	Mode 0666
                  EndSection
                  
                  Section "Extensions"
                  	Option	"Composite"	"1"
                  #	Option	"RENDER"	"1"
                  EndSection
                  Unfortunately, X won't correctly work and hangs up while starting leading me to a black screen where only Ctrl Alt Del is allowed, not even the possibility to stop the Xsession nor moving to a terminal. This behavior is the same I got when installed fglrx-driver from non-free repo. Besides the error experienced looks the same in Xlog:

                  Code:
                  (II) Setting vga for screen 0.
                  (II) fglrx(0): === [atiddxPreInit] === begin, [x]
                  (II) Loading sub module "vgahw"
                  (II) LoadModule: "vgahw"
                  (II) Loading /usr/lib/xorg/modules//libvgahw.so
                  (II) Module vgahw: vendor="X.Org Foundation"
                  	compiled for 1.4.0.90, module version = 0.1.0
                  	ABI class: X.Org Video Driver, version 2.0
                  (II) fglrx(0): PCI bus 1 card 0 func 0
                  (II) fglrx(0): Creating default Display subsection in Screen section
                  	"Default Screen" for depth/fbbpp 8/8
                  (EE) fglrx(0): Given depth (8) is not supported by fglrx driver
                  (EE) fglrx(0): PreInitVisual failed
                  SetVBEMode failed
                  (EE) fglrx(0): PreInit failed
                  (II) fglrx(0): === [atiddxPreInit] === end
                  (II) UnloadModule: "fglrx"
                  (II) UnloadModule: "vgahw"
                  (II) Unloading /usr/lib/xorg/modules//libvgahw.so
                  (EE) Screen(s) found, but none have a usable configuration.
                  
                  Fatal server error:
                  no screens found
                  I hope I've been clear and posted all the useful infos to figure the problem out.

                  Thanks a lot for the help

                  Comment


                  • #10
                    My script modfies a "standard" xorg.conf, yours was non standard, best do this:

                    rm /etc/X11/xorg.conf /etc/X11/xorg.conf.1st

                    dpkg-reconfigure xserver-xorg

                    Then create a "standard" xorg.conf and at last run my script again to modifiy it in a correct way.
                    Last edited by Kano; 01-12-2008, 07:39 AM.

                    Comment


                    • #11
                      Originally posted by Kano View Post
                      You xorg.conf is a bit too short. You have got no entry like:

                      Section "ServerLayout"
                      ...
                      Screen 0 "Screen0" 0 0
                      EndSection


                      Section "Screen"
                      Identifier "Screen0"
                      Device "Card0"
                      Monitor "Monitor0"
                      DefaultColorDepth 24
                      SubSection "Display"
                      Depth 24
                      Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
                      EndSubSection
                      EndSection

                      You could try Kanotix Thorhammer RC7 and boot with fglrx option then copy /etc/X11/xorg.conf to your hd. Btw. your old config is /etc/X11/xorg.conf.1st (which is always used for input for my script if there).
                      This xorg.conf is the default I've found once the installation was complete and correctly working. I also thought it was a little too short and searching for answers I realized that X 7.3 wants to minimize the usage of xorg.conf. I was used to launch sudo dpkg-reconfigure xserver-xorg to set driver,monitor, depth and others... But in X 7.3 the choose affects the keyboard only. Now I'll try to complete the xorg.conf and see the result. Thanks for the help.

                      BTW How comes that Ubuntu packaging achieve the goal while Debian fails, on a Debian unstable?!

                      Comment


                      • #12
                        That has nothing to do if you use Debian or Ubuntu packages, you just have several drawbacks when you create Debian ones: These will be updated as soon as Debian has the driver itself packaged and often the Debian create scripts have been broken (I did not like to patch the Debian target for each release). Basically only the package names are different.

                        Btw. I just tested the new sid reconfigure tool, the file is really extra short... When I have a bit more time i will add a workaround, right now edit manually or use

                        aticonfig --initial

                        this even worked with an empty xorg.conf (just touch xorg.conf) when you use -f option. It has some problems to parse the standard Debian file.
                        Last edited by Kano; 01-12-2008, 08:24 AM.

                        Comment


                        • #13
                          This is the actual state of the system:

                          Thanks to Kano I was able to complete the xorg.conf so that looked more "verbose" as it was before X 7.3:

                          Code:
                          Section "InputDevice"
                          	Identifier	"Generic Keyboard"
                          	Driver		"kbd"
                          	Option		"XkbRules"	"xorg"
                          	Option		"XkbModel"	"pc105"
                          	Option		"XkbLayout"	"it"
                          EndSection
                          
                          Section "InputDevice"
                          	Identifier	"Configured Mouse"
                          	Driver		"mouse"
                          EndSection
                          
                          Section "Device"
                          	Identifier	"Configured Video Device"
                                  Driver          "radeon"
                          EndSection
                          
                          Section "Monitor"
                          	Identifier	"Configured Monitor"
                          EndSection
                          
                          Section "Screen"
                          	Identifier	"Default Screen"
                          	Monitor		"Configured Monitor"
                          EndSection
                          Section "ServerLayout"
                          	Identifier	"Default Layout"
                          	Screen	0	"Default Screen"	0	0
                          EndSection
                          
                          Section "Screen"
                          	Identifier	"Default Screen"
                          	Device		"Configured Video Device"
                          	Monitor		"Configured Monitor"
                          	DefaultColorDepth	24
                          	SubSection "Display"
                          		Depth	24
                          		Modes	"1280x1024"
                          	EndSubSection
                          EndSection
                          This xorg.conf doesn't obviously invoke fglrx as driver and returns the same behaviour of the default one but shows more infos. I have executed Kano's script and noticed something related to the module (last time screens were too fast to let me understand the whole thing). The module experiences problems while being built and I cannot install it with sudo m-a install fglrx-kernel-src. It suggests to take a look at:

                          /var/cache/modass/fglrx-kernel-src.buildlog.2.6.23-1-686.1200146510

                          Code:
                          dh_testroot
                          rm -f configure-stamp
                          rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
                          rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
                          rm -rf .tmp_versions
                          rm -rf patch
                          dh_clean
                          rm /usr/src/modules/fglrx/debian/control
                          rm /usr/src/modules/fglrx/debian/dirs
                          if [ -f /usr/src/modules/fglrx/debian/control.template ]; then \
                          		cat /usr/src/modules/fglrx/debian/control.template > /usr/src/modules/fglrx/debian/control; \
                          	fi
                          if [ -f /usr/src/modules/fglrx/debian/postinst ]; then \
                          		mv /usr/src/modules/fglrx/debian/postinst /usr/src/modules/fglrx/debian/fglrx-kernel-2.6.23-1-686.postinst; \
                          	fi
                          dh_testdir
                          touch configure-stamp
                          dh_testdir
                          /usr/bin/make -C /lib/modules/2.6.23-1-686/build SUBDIRS=/usr/src/modules/fglrx modules
                          make[1]: Entering directory `/usr/src/linux-headers-2.6.23-1-686'
                            CC [M]  /usr/src/modules/fglrx/firegl_public.o
                          /usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_check_pci’:
                          /usr/src/modules/fglrx/firegl_public.c:1953: warning: ‘pci_find_slot’ is deprecated (declared at include/linux/pci.h:481)
                          /usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_pci_find_slot’:
                          /usr/src/modules/fglrx/firegl_public.c:2842: warning: ‘pci_find_slot’ is deprecated (declared at include/linux/pci.h:481)
                            LD [M]  /usr/src/modules/fglrx/fglrx.o
                            Building modules, stage 2.
                            MODPOST 1 modules
                            CC      /usr/src/modules/fglrx/fglrx.mod.o
                            LD [M]  /usr/src/modules/fglrx/fglrx.ko
                          make[1]: Leaving directory `/usr/src/linux-headers-2.6.23-1-686'
                          dh_testdir
                          dh_testroot
                          dh_clean -k
                          rm -f /usr/src/modules/fglrx/debian/control /usr/src/modules/fglrx/debian/dirs
                          sed -e 's/#KVERS#/2.6.23-1-686/g' \
                          	    -e 's/#VERSION#/8.443.1-1/g' debian/control.template > /usr/src/modules/fglrx/debian/control
                          sed -e 's/#KVERS#/2.6.23-1-686/g' debian/dirs.template > /usr/src/modules/fglrx/debian/dirs
                          dh_installdirs
                          dh_install fglrx.ko lib/modules/2.6.23-1-686/misc
                          dh_testdir
                          dh_testroot
                          dh_installdocs
                          dh_installmodules
                          dh_link
                          dh_strip
                          dh_compress
                          dh_fixperms
                          dh_installdeb
                          dh_gencontrol -- -v8.443.1-1+2.6.23-2 -VXSERVER=xorg
                          dh_md5sums
                          dh_builddeb --destdir=/usr/src
                          dpkg-deb: costruisco il pacchetto `fglrx-kernel-2.6.23-1-686' in `/usr/src/fglrx-kernel-2.6.23-1-686_8.443.1-1+2.6.23-2_i386.deb'.
                          dh_testroot
                          rm -f configure-stamp
                          rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
                          rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
                          rm -rf .tmp_versions
                          rm -rf patch
                          dh_clean
                          rm /usr/src/modules/fglrx/debian/control
                          rm /usr/src/modules/fglrx/debian/dirs
                          Build time: 8 seconds
                          I didn't catch what's wrong in the building of the module. Any hint?

                          Thanks I owe you a lot

                          Comment


                          • #14
                            The module was build. Thats not the problem. But why do you use now the old debian packages?

                            Comment


                            • #15
                              Originally posted by Kano View Post
                              The module was build. Thats not the problem. But why do you use now the old debian packages?
                              Excuse me but I didn't understand the last suggestion. What do you mean by saying "do you use now the old Debian packages?". Am I using something old or do I have to use something older?

                              Thanks in advance, I'm not very good with this stuff!

                              Besides sudo m-a install fglrx-kernel-src returns saying the module wasn't built correctly but I also had the impression the module was built.
                              Last edited by deepsmoke; 01-12-2008, 09:42 AM.

                              Comment

                              Working...
                              X