No announcement yet.

ATI X1600 + 7.11 or 7.12 = Massive Screen Corruption

  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI X1600 + 7.11 or 7.12 = Massive Screen Corruption

    Hi there,

    My friend decided he wanted to try linux, so I did an Linux Mint Install and then used the latest ATI drivers for his X1600.

    The driver instaled fine and everything, but then the problems started.

    OpenGL apps get a massive screen corruption (I'll try to get a picture later, no way I can explain that). With both 7.11 and 7.12 (No memory leak whatsoever in 7.11 ). So I reverted to the Ubuntu repo driver.

    The most strange thing came after I tested OpenGL apps with this driver. Both 7.11 and 7.12 have the same performance than the 8.38 (I think is this one). And with any driver, changing resolution and some other graphic settings wont change the FPS. My friend with is X1600 + 7.12 is getting worse frame rate than me with a X1400Mobility + 8.38, and he is using lower settings!!! :S

    I seen lots of posts with problems with 1600, is a Card issue or something wrong with the distro I've chosen?

    Thx in advance

    PS: No screen corruption with other driver versions than 7.11 and 7.12 (Didn't test all of course)

  • #2
    for screen corruption do you mean a swap of colors from cold ones to warm ones and viceversa?


    • #3
      Its a bit more than that. I get loads of artifacts draw in a diagonal way from the upper and lower corners of the screen. Buttons and stuff get corrupted (some become blurred, some get rough edges) and all the text is lost.

      Some weird corruption, and a big messy one. Only happens with 7.11 and 7.12.

      But the thing that is getting to me is, no matter what kind of graphic definitons, resolution, etc, the performance is always the same, with every driver! (7.11 and 7.12 get better performance, but like the other versions, dont change with the settings)


      • #4
        really strange... but i don't get anything like that and performance is getting a bit better with last releases.

        i just get the issue said before when i enable composite extensions

        bye :-)