No announcement yet.

[7.12 FireGL] No composite

  • Filter
  • Time
  • Show
Clear All
new posts

  • [7.12 FireGL] No composite

    Hi there !

    There is no more Composite on my X server since catalyst 7.12. I own a FireGL V3100. Previous 7.42 or 7.43 (7.11) had to be hacked to pass hardware detection, but were fully functionnal, including Composite enabled.

    I have installed 8.44 (so 7.12) last week, but I have got a new error I never met befor (less /var/log/Xorg.0.log | grep "Comp"):

    (**) Extension "Composite" is enabled
    (II) Loading extension XVideo-MotionCompensation
    (II) fglrx(0): RENDER and Composite disabled when OpenGL Overlay enabled
    Note that my xorg.conf is correct:

    Section "Device"
    	Identifier	"ATI Technologies Inc RV370 5B64 [FireGL V3100 (PCIE)]"
    	Boardname	"ati"
    	Busid		"PCI:1:0:0"
    	Driver		"fglrx"
    	#Option		"VideoOverlay"	  	"on"
    	#Option		"OpenGLOverlay"	  	"off"
    	#Option		"MergedFB"	  	"on"
    	Option 		"TexturedXrender" 	"on"
    	Option 		"Textured2D"		"on"
    I tried all options removed, and all to off, nothing more that this no composite error message :'(

    Any idea about what is going wrong with these 8.44 and FireGL ? any known issue ?

  • #2
    Originally posted by GuiPoM View Post
    (II) fglrx(0): RENDER and Composite disabled when OpenGL Overlay enabled
    Same here with ATI Mobility FireGL V5200



    • #3
      Sounds like the driver might be forcing the OpenGL Overlay on automatically when it detects a FireGL card. That makes sense (AFAIK OpenGL Overlay is a workstation-specific feature) but if it interferes with the use of compositing desktops then being able to turn it off would be a Good Thing.

      Might be useful to try one of the pre-7.12 FireGL workarounds to make the driver think you have a consumer card, even if you don't need the workaround to have your card recognized any more.
      Last edited by bridgman; 12-26-2007, 03:26 PM.


      • #4

        I tried the old way (with patching and replacing fglrx.ko & control file) but thanks to this new dkms stuff, it seems that replacement is not taken into account

        I don't know how to procede, except rollback to 8.43 patched drivers.