Announcement

Collapse
No announcement yet.

Catalyst 7.12 - PreInitDAL failed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    what modules do you load in section modules in your xorg.conf?what modules do you load in section modules in your xorg.conf?
    http://www.phoronix.com/forums/showthread.php?t=7044
    See this Thread. The same problem occurs on Gentoo and Fedora, maybe I'll also try it on Debian but I don't think it'll be other there.

    My modules in Gentoo are glx, dri, dbe and freetype, which worked perfectly with 8.43.
    In Fedora I only load glx and dri.

    Comment


    • #32
      Originally posted by NeoBrain View Post
      http://www.phoronix.com/forums/showthread.php?t=7044
      See this Thread. The same problem occurs on Gentoo and Fedora, maybe I'll also try it on Debian but I don't think it'll be other there.

      My modules in Gentoo are glx, dri, dbe and freetype, which worked perfectly with 8.43.
      In Fedora I only load glx and dri.
      assure that you have
      Section "DRI"
      Group "video"
      Mode 0660
      EndSection
      and
      Option "no_accel" "no"
      Option "no_dri" "no"
      in your section device.
      this should do

      Comment


      • #33
        ...Did that, but first have to reinstall 8.44

        EDIT: nope, doesn't work, same errors.
        Last edited by NeoBrain; 12-23-2007, 10:29 AM.

        Comment


        • #34
          Originally posted by NeoBrain View Post
          ...Did that, but first have to reinstall 8.44

          EDIT: nope, doesn't work, same errors.
          the last thing you could try is removing the kernel agpgart and set useinternalagpgart to yes. here http://debian.wgdd.de/temp/fglrx_man/fglrx.4x.html
          you can have more info about ati agp setting in xorg.conf. maybe the problem is related to the wrong agpgart use.

          Comment


          • #35
            I have have tried that to before, but it neither worked..
            I'll play around with the AGP options a bit when I have some free time again.

            Comment


            • #36
              I'll play around with the AGP options a bit when I have some free time again.
              remember that you'll have to remove the kernel agpgart before using the internal one. else it will not work.

              Comment


              • #37
                Originally posted by givemesugarr View Post
                remember that you'll have to remove the kernel agpgart before using the internal one. else it will not work.
                My genkernel test was a disaster, X crashes on startup no matter what version of fglrx I used.

                Comment


                • #38
                  Oh well, that's nice to see... fglrx doesn't accept using it's own agpgart anymore...
                  My Xorg.log says that the Option "useInternalAGPGART" is set to "yes" but later it says that it doesn't use the build-in one...

                  Comment


                  • #39
                    My genkernel test was a disaster, X crashes on startup no matter what version of fglrx I used.
                    genkernel should never be used. it's the worst configurator that i've seen... it's really awful...

                    My Xorg.log says that the Option "useInternalAGPGART" is set to "yes" but later it says that it doesn't use the build-in one...
                    you have to force if the things are as this.

                    try setting these after you're sure to have removed the agpgart module and the modules that need it from the kernel:

                    Option "BusType" "AGP" #set this only if you're sure to have an agp card, otherwise might happen hw problems.
                    Option "ForceGenericCPU" "no" #we try to tell the driver to use its gpu
                    Option "KernelModuleParm" "agpgart=0" # we tell the driver to use its internal agpgart
                    Option "KernelModuleParm" "agp_try_unsupported=1" #we use this later to try fixing the agpgart stuff not loading by setting the try unsupported chipsets.

                    with these it should work.

                    Comment


                    • #40
                      Well, I have completely removed the agpgart module and now fglrx says it can't find the agpgart module.
                      xorg.log:
                      (**) fglrx(0): using built in AGPGART module: no
                      (**) fglrx(0): KernelModuleParm: "agp_try_unsupported=1"
                      (**) fglrx(0): ATI GART size: 256 MB
                      (II) fglrx(0): [pci] find AGP GART
                      (EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
                      (EE) fglrx(0): cannot init AGP
                      My Device section in xorg.conf so far is:
                      Section "Device"

                      # Driver "radeonhd"
                      Identifier "aticonfig-Device[0]"
                      Driver "fglrx"
                      Option "MaxGARTSize" "256"
                      Option "UseInternalAGPGART" "yes"
                      Option "TexturedVideo" "true"
                      Option "Textured2D" "true"
                      Option "AGPMode" "8"
                      Option "UseFastTLS" "2"
                      Option "no_accel" "no"
                      Option "no_dri" "no"
                      Option "KernelModuleParm" "agpgart=0"
                      Option "KernelModuleParm" "agp_try_unsupported=1"
                      Option "BusType" "AGP"
                      Option "ForceGenericCPU" "no"
                      EndSection

                      Comment


                      • #41
                        Originally posted by NeoBrain View Post
                        Well, I have completely removed the agpgart module and now fglrx says it can't find the agpgart module.
                        xorg.log:


                        My Device section in xorg.conf so far is:
                        are you sure that you have an agp card? it should definitively work.
                        from what you say it seems that the driver doesn't compile the internal agpgart module. so try first rebuilding the driver manually (use the .run to install for your specific system or the scripts from phorogit) and then retry.
                        if you still cannot find the agpgart, then first try removing the bus type option and if that doesn't work set this
                        Option "KernelModuleParm" "agpgart=2"
                        and recompile the agpgart.

                        Comment


                        • #42
                          My motherboard doesn't even support PCI-E
                          Anyways, I have a Sapphire X1600 Pro with 512 MB.
                          My Gart size is 256, which seems to be my BIOS's maximum.
                          One other thing I noticed was that fglrx shows that I only have 256 MB video RAM...
                          Oh, and the ATI installer doesn't provide packages for Gentoo, so I can't do anything other than reinstalling via portage.
                          However, I'll give what you said a try.
                          And by the way thanks for trying to help me

                          Comment


                          • #43
                            Originally posted by NeoBrain View Post
                            My motherboard doesn't even support PCI-E
                            Anyways, I have a Sapphire X1600 Pro with 512 MB.
                            My Gart size is 256, which seems to be my BIOS's maximum.
                            One other thing I noticed was that fglrx shows that I only have 256 MB video RAM...
                            Oh, and the ATI installer doesn't provide packages for Gentoo, so I can't do anything other than reinstalling via portage.
                            However, I'll give what you said a try.
                            And by the way thanks for trying to help me
                            well, on gentoo it should compile the driver automatically. try posting the emerge log for the driver. maybe it has missed something when emerging the driver.

                            Comment


                            • #44
                              Well, the emerge process looks ok to me:
                              Calculating dependencies .... ... done!
                              >>> Verifying ebuild Manifests...

                              >>> Emerging (1 of 1) x11-drivers/ati-drivers-8.443.1 to /
                              * ati-driver-installer-8.443.1-x86.x86_64.run RMD160 SHA1 SHA256 size ;-) ... [ ok ]
                              * checking ebuild checksums ;-) ... [ ok ]
                              * checking auxfile checksums ;-) ... [ ok ]
                              * checking miscfile checksums ;-) ... [ ok ]
                              * checking ati-driver-installer-8.443.1-x86.x86_64.run ;-) ... [ ok ]
                              * Determining the location of the kernel source code
                              * Found kernel source directory:
                              * /usr/src/linux
                              * Found kernel object directory:
                              * /lib/modules/2.6.22-gentoo-r8/build
                              * Found sources for kernel version:
                              * 2.6.22-gentoo-r8
                              >>> Unpacking source...
                              * Applying ati-powermode-opt-path-1.patch ...
                              [ ok ]
                              * Converting 2.6.x/Makefile to use M= instead of SUBDIRS= ...
                              [ ok ]
                              >>> Unpacking ./../common/usr/src/ati/fglrx_sample_source.tgz to /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/extra
                              >>> Source unpacked.
                              >>> Compiling source in /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work ...
                              * Preparing fglrx module
                              make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/common/lib/modules/fglrx/build_mod/2.6.x modules
                              make[1]: Entering directory `/usr/src/linux-2.6.22-gentoo-r8'
                              CC [M] /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
                              /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function »__ke_request_irq«:
                              /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2947: Warning: »deprecated_irq_flag« is deprecated
                              LD [M] /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
                              Building modules, stage 2.
                              MODPOST 1 modules
                              CC /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
                              LD [M] /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
                              make[1]: Leaving directory `/usr/src/linux-2.6.22-gentoo-r8'
                              * Building fgl_glxgears
                              * Building fglrx_gamma lib
                              * Building fglrx_gamma util
                              >>> Source compiled.
                              >>> Test phase [not enabled]: x11-drivers/ati-drivers-8.443.1

                              >>> Install ati-drivers-8.443.1 into /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/image/ category x11-drivers
                              * Installing fglrx module
                              * ati tree 'lib' -> 'lib' on system
                              >>> Completed installing ati-drivers-8.443.1 into /var/tmp/portage/x11-drivers/ati-drivers-8.443.1/image/
                              [etc, merging all files now...]

                              Comment


                              • #45
                                Okay, seems like fglrx didn't let me change any options which I had specified once again, so I removed /etc/ati and reinstalled the driver. Now it uses the built in agpgart, but I get the same error...
                                Maybe I'm better of with waiting for 8.45

                                Comment

                                Working...
                                X