Announcement

Collapse
No announcement yet.

Catalyst 7.12 - PreInitDAL failed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi! Well as I promised... Here is the output of /var/log/Xorg.0.log.

    Xorg.0.log

    I'm not using 1680x1050 resolution, my display is working at 1152x864.

    Comment


    • #17
      Hmm I also have encountered this problem with 7.12. Thought it was the dvi but I tried vga also and it still didn't work. Hopefully someone has a solution to this soon.

      Comment


      • #18
        An ebuild for 7.12 has appeared in the untested tree of Gentoo's portage, I tried it but have the same error.
        the ebuild works fine for me on 4 different ati powered pcs.
        the problem of the initdal failed on gentoo is fixed with:

        eselect opengl set ati
        dispatch-conf
        with updating every new file to the last. (use etc-update or whatever you prefer instead of dispatch-conf if you want).

        i've had the same issue, but after that it's fixed.
        if it still isn't fixed try removing all the vesafb and vga options passed to the kernel in the /boot/grub/menu.lst and the fbsplash.

        for the resolution issue try the following:
        add the proper modes (like these

        Depth 24
        Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
        )
        and then add a virtual desktop with this:
        ViewPort 0 0
        Virtual 1600 1200
        this would put a virtual desktop of 1600x1200 on the display 0:0 which normally is used for xorg. the possible result would be 2:
        1. the driver reads the mode for 1600x1200 and puts the virtual display and everything goes fine
        2. the driver doesn't read the mode for 1600x1200 and puts the virtual for 1600x1200 isntead.
        if your case is the second then we have to think of something else.
        ps.@rainbyte as i've seen from your log you could try setting one mode for all the 3 bits 24, 15, 8 to
        1280x960 @70hz
        that's what your manufacturer has set for your monitor and what the driver finds out from its edid.

        I've got no framebuffer support in kernel, so I assume this is yet another side effect of the somehow broken EDID data handling that also makes it impossible to use 1680x1050 with 7.12 on my hardware.

        Anyways, previous driver versions seemed to support 1680x1050 only because this resolution was explicitly reported by EDID. I was never able to get any other widescreen resolution like 1440x900 with fglrx.
        try setting 1440x900 as the greatest resolution in your modes and the driver should use that. for what i know it should use the most advanced specified into the modes lines.

        Comment


        • #19
          Originally posted by givemesugarr View Post
          the ebuild works fine for me on 4 different ati powered pcs.
          the problem of the initdal failed on gentoo is fixed with:

          eselect opengl set ati
          dispatch-conf
          This does not fix the problem for me. I do the following:

          1) Downgrade to 8.433
          2) eselect opengl set ati
          3) etc-update to update all the files back to 8.433 versions.
          4) Upgrade back to 8.443.1
          5) eselect opengl set ati
          6) etc-update to update all the files to 8.443.1 versions

          Comment


          • #20
            Originally posted by Crunchy View Post
            This does not fix the problem for me. I do the following:

            1) Downgrade to 8.433
            2) eselect opengl set ati
            3) etc-update to update all the files back to 8.433 versions.
            4) Upgrade back to 8.443.1
            5) eselect opengl set ati
            6) etc-update to update all the files to 8.443.1 versions
            try downgrade to 8.433. etc-update, revdep-rebuild, etc-update if you have rebuilded something, upgrade 8.433.1, etc-update and chose -3 option, eselect opengl show and if its opengl not on ati set it to ati. see if you have the libGL.so.1 in /usr/lib and if the files of qlist ati-drivers are there. (it will take some minutes to verify all them and doing it with ls -lR /directory >> list.txt would help it. just do a qlist ati-drivers >> qlist.txt and open the 2 files in text editor to see if there are problems).
            if everything is ok, then comment everything in your section device, with th exception of the capabilities lines and of the opengloverlay and videooverlay and kernelparam. try starting xorg with /etc/init.d/xdm start.
            if it gives you the same error, remove the lines of the framebuffer splash in /boot/grub/menu.lst or /boot/grub/grub.conf (is one or the other not both).
            the options to remove are:
            all options with vga and vesaxxx inside.
            then init 6 and go in interactive mode, skip xdm and then start it manually. at that time it should definitively work.

            Comment


            • #21
              Originally posted by givemesugarr View Post
              try downgrade to 8.433. etc-update, revdep-rebuild, etc-update if you have rebuilded something, upgrade 8.433.1, etc-update and chose -3 option, eselect opengl show and if its opengl not on ati set it to ati. see if you have the libGL.so.1 in /usr/lib and if the files of qlist ati-drivers are there. (it will take some minutes to verify all them and doing it with ls -lR /directory >> list.txt would help it. just do a qlist ati-drivers >> qlist.txt and open the 2 files in text editor to see if there are problems).
              if everything is ok, then comment everything in your section device, with th exception of the capabilities lines and of the opengloverlay and videooverlay and kernelparam. try starting xorg with /etc/init.d/xdm start.
              if it gives you the same error, remove the lines of the framebuffer splash in /boot/grub/menu.lst or /boot/grub/grub.conf (is one or the other not both).
              the options to remove are:
              all options with vga and vesaxxx inside.
              then init 6 and go in interactive mode, skip xdm and then start it manually. at that time it should definitively work.
              I don't understand to your explanation. I try all solution. but, my machine is still error.
              Code:
              .
              .
              .
              (EE) fglrx(0): PreInitDAL failed
              I build 8.433 and 8.443.1 with same condition. And 8.433 driver is working fine. So, I downgrade to 8.433 until fixed driver or next driver release.

              Comment


              • #22
                Originally posted by hoenny View Post
                I don't understand to your explanation. I try all solution. but, my machine is still error.
                Code:
                .
                .
                .
                (EE) fglrx(0): PreInitDAL failed
                I build 8.433 and 8.443.1 with same condition. And 8.433 driver is working fine. So, I downgrade to 8.433 until fixed driver or next driver release.
                1. downgrade and do the canonical etc-update
                2. run revdep-rebuild which fixes wrongs linkages and broken dependencies and run etc-update if necessary.
                3. upgrade to the new version run etc-update and remove vga and vesa options from your boot as well as the options for the splash;
                4. reboot with interactive mode and skip the xdm service.
                5. do a qlist ati-drivers > qlist.txt and a ls -Rl >> list.txt on the directories indicated by qlist
                6. do an eselect opengl show and see if it gives ati. if it gives xorg-x11 or other then do eselect opengl set ati and verify again with eselect opengl show. now it should give ati.
                7. try starting xorg with /etc/init.d/xdm start.
                8. hopefully everything went well and you're now able to use the new driver.

                9. if you encounter problems do a ctrl+alt+canc and continue to do that until the pc reboots. for some reason the vts are not ok, and the monitor won't start but the keyboard still works.
                10. reboot without starting xdm and verify /var/log/Xorg.0.log if you still have the same preinitdal problem.
                11. verify that the files set by qlist are the ones in the directories given from the ls (using txt files is easier and faster to verify). if there are more files, it doesn't matter, but if something is missing you have to manually fix the files symlinking to the one in the /usr/lib/opengl/ati/ dir and subdir. (to symlink something you must do ln -s origin_file dest_file; use full symlink by specifying the full path, since it's safer).
                12. see step 7. if you still get the same error with preinitdal then there's something else that is not ok, probably due to some kernel configuration issues.

                Comment


                • #23
                  Originally posted by givemesugarr View Post
                  1. downgrade and do the canonical etc-update
                  2. run revdep-rebuild which fixes wrongs linkages and broken dependencies and run etc-update if necessary.
                  3. upgrade to the new version run etc-update and remove vga and vesa options from your boot as well as the options for the splash;
                  4. reboot with interactive mode and skip the xdm service.
                  5. do a qlist ati-drivers > qlist.txt and a ls -Rl >> list.txt on the directories indicated by qlist
                  6. do an eselect opengl show and see if it gives ati. if it gives xorg-x11 or other then do eselect opengl set ati and verify again with eselect opengl show. now it should give ati.
                  7. try starting xorg with /etc/init.d/xdm start.
                  8. hopefully everything went well and you're now able to use the new driver.

                  9. if you encounter problems do a ctrl+alt+canc and continue to do that until the pc reboots. for some reason the vts are not ok, and the monitor won't start but the keyboard still works.
                  10. reboot without starting xdm and verify /var/log/Xorg.0.log if you still have the same preinitdal problem.
                  11. verify that the files set by qlist are the ones in the directories given from the ls (using txt files is easier and faster to verify). if there are more files, it doesn't matter, but if something is missing you have to manually fix the files symlinking to the one in the /usr/lib/opengl/ati/ dir and subdir. (to symlink something you must do ln -s origin_file dest_file; use full symlink by specifying the full path, since it's safer).
                  12. see step 7. if you still get the same error with preinitdal then there's something else that is not ok, probably due to some kernel configuration issues.
                  I followed all this and still get the same error. I make sure I do:

                  modprobe -r fglrx

                  Before starting X to make sure the right module was loaded, I also rebooted to double check.

                  I don't use any framebuffer/splash in the grub.conf or kernel. I even turned off the Grub splash in grub.conf. I don't use XDM etc so I just type startx.

                  I don't have to use Ctrl-Alt-Del to reboot after starting X. I just have to Ctrl-Alt-F1 to get back to the console. I noticed the following error on the X VT (Ctrl-Alt-F7):

                  Code:
                  *** glibc detected *** X: double free or corruption (fasttop): 0x0821e9f8 ***
                  Every time I type startx it has the same error and the PreInitDAL failed error in the log.

                  I'll try genkernel to see if that fixes it, it'll be a much more generic kernel config.

                  Comment


                  • #24
                    Originally posted by Crunchy View Post
                    I followed all this and still get the same error. I make sure I do:

                    modprobe -r fglrx

                    Before starting X to make sure the right module was loaded, I also rebooted to double check.

                    I don't use any framebuffer/splash in the grub.conf or kernel. I even turned off the Grub splash in grub.conf. I don't use XDM etc so I just type startx.

                    I don't have to use Ctrl-Alt-Del to reboot after starting X. I just have to Ctrl-Alt-F1 to get back to the console. I noticed the following error on the X VT (Ctrl-Alt-F7):

                    Code:
                    *** glibc detected *** X: double free or corruption (fasttop): 0x0821e9f8 ***
                    Every time I type startx it has the same error and the PreInitDAL failed error in the log.

                    I'll try genkernel to see if that fixes it, it'll be a much more generic kernel config.

                    I can get rid of the glibc error with:

                    Code:
                    export MALLOC_CHECK_=2
                    startx
                    I still get the PreInitDAL failed error.

                    Comment


                    • #25
                      Hi at all,

                      this is really strange since I use Gentoo too and for me there's no problem... X1600 Pro AGP, Kernel 2.6.23-gentoo-r3, Xorg 1.3, framebuffer for console activated...

                      I just ran the downloaded .run file and everything works...

                      Comment


                      • #26
                        Originally posted by Crunchy View Post
                        I followed all this and still get the same error. I make sure I do:

                        modprobe -r fglrx

                        Before starting X to make sure the right module was loaded, I also rebooted to double check.

                        I don't use any framebuffer/splash in the grub.conf or kernel. I even turned off the Grub splash in grub.conf. I don't use XDM etc so I just type startx.

                        I don't have to use Ctrl-Alt-Del to reboot after starting X. I just have to Ctrl-Alt-F1 to get back to the console. I noticed the following error on the X VT (Ctrl-Alt-F7):

                        Code:
                        *** glibc detected *** X: double free or corruption (fasttop): 0x0821e9f8 ***
                        Every time I type startx it has the same error and the PreInitDAL failed error in the log.

                        I'll try genkernel to see if that fixes it, it'll be a much more generic kernel config.
                        then your is not the classical preinitdal failed stuff. it's generated by other stuff...
                        i've found out this:
                        I'm getting this error at runtime:

                        *** glibc detected *** double free or corruption (fasttop): 0x0804a008 ***
                        Aborted

                        This happens when an instance of one class encapsulates and assigns an instance of another class.

                        I tried to narrow down the problem using a debugger, and it seems the error is produced because somehow I call delete[] on an already deleted pointer in the class destructor.
                        and this bug https://bugs.freedesktop.org/show_bug.cgi?id=8137 seem to be the one most similar to yours. it happened with the old radeon driver and had something to do with preinit of the radeon boards.
                        well, my advice now is the following:
                        1. use the following packages for xorg:
                        =x11-base/xorg-x11-7.2
                        =x11-base/xorg-server-1.3.0.0-r2
                        the second with videocards: radeon, fglrx, vesa and vga and use flag nptl xorg xprint
                        after that do a revdep-rebuild and try out the new driver. the rebuilding of this modules should push in also the radeon and fglrx rebuild.
                        if you already have this xorg then the problem is somewhere in the system config, i think....

                        Comment


                        • #27
                          In my case (Mobility FireGL V5200 on Fedora 8 64bit), I got the PreInitDAL error when using the rpms built by the ati-installer program. But when I installed it directly from the graphical interface, apparently whatever file where the problem was gets overwritten, and the PreInitDAL problem disappears. However, I still had to build and install the rpms, since the graphical installer was failing to make the kernel module (see http://phoronix.com/forums/showpost....51&postcount=8)

                          Comment


                          • #28
                            OK, It's working in my Fedora 8 x86_64 machine. Maybe, ATI-fglrx.spec-tmpl and ati-packager.sh are have some bug in Fedora 8 x86_64. So, I install livna rpms. It's good working. Just do that.

                            Code:
                            yum install kmod-fglrx xorg-x11-drv-fglrx-libs-32bit

                            Comment


                            • #29
                              Yeah, on my Fedora 8 (x86) the PreInitDAL problem was also fixed after I used the livna packages.
                              The only problem is that I still don't have 3D accel

                              Comment


                              • #30
                                Originally posted by pfpenteado View Post
                                In my case (Mobility FireGL V5200 on Fedora 8 64bit), I got the PreInitDAL error when using the rpms built by the ati-installer program. But when I installed it directly from the graphical interface, apparently whatever file where the problem was gets overwritten, and the PreInitDAL problem disappears. However, I still had to build and install the rpms, since the graphical installer was failing to make the kernel module (see http://phoronix.com/forums/showpost....51&postcount=8)
                                gentoo always builds packages from source so also fglrx is compiled with the kernel sources.

                                The only problem is that I still don't have 3D accel
                                what modules do you load in section modules in your xorg.conf?

                                Comment

                                Working...
                                X