Announcement

Collapse
No announcement yet.

AMD Catalyst 7.12 Linux Driver -- The Baby's In Surgery

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by givemesugarr View Post
    it's useless to reemerge xorg-server. i can assure you that the driver works fine on gentoo. i've installed and run it. you just have to remember to do an etc-update or dispatch-config after emerging it and an eselect opengl set ati and it should work. also you should do a ls -Rl on the /usr/lib/opengl/ati/ there you should see the various files needed for fglrx to run. you may also do a revdep-rebuilt just in case you have some broken linkage on your system, but reemerging xorg-server is useless.
    Worked for me. I also had to reemerge mesa when I uninstalled the drivers and I had eselected xorg-x11.
    Please note that i didn't install or uninstall the drivers with portage. I don't get these problems if I use portage instead.

    Originally posted by benneque View Post
    i reemerged xorg-server , and then all those xf86-drivers and of course the ati-drivers and everything works now!!


    EDIT: is it possible tu run compiz with xorg 1.4 ??
    Glad to hear it worked!
    AFAIK you still have to use 1.3 to get compiz to run.

    Comment


    • ok,.... then i'll reemerge xorg 1.3 .. boring life :P

      Comment


      • Originally posted by Michael View Post
        AMD is aware of the wide screen bug and others in this thread, I just sent off an email to make sure.
        As mentioned by ltmon, do you know if ATI will possibly issue a hotfix for the wide screen bug? Having to wait another month on a fix for this regression won't make people happy at all (including me).

        Comment


        • Originally posted by benneque View Post
          i reemerged xorg-server , and then all those xf86-drivers and of course the ati-drivers and everything works now!!


          EDIT: is it possible tu run compiz with xorg 1.4 ??
          the problems was in reemerging the ati-drivers. after that they worked.
          with 1.4 you may encounter a lot of problems with compiz. give it a try and see how it works.
          remember that you'll have to do some stuff with firefox:
          1. click on install gtk-scrollbar fix if using kde from kcontrol gtk styles and fonts
          2. remove use smooth scrolling and autoscrolling from firefox preferences.
          this should fix the firefox low scroll issue when running compiz.
          also you may have to whitelist some stuff (see the 8.42 thread for that) and try to force the rendering from texture from pixmap to force copy. also add this section if you don't have it:

          Section "Extensions"
          Option "DAMAGE" "true"
          Option "RENDER" "true"
          Option "Composite" "Enable"
          EndSection

          if it doesn't work well try it on xorg-7.2 and xorg-server-1.3 and if that also doesn't work then your board cannot run it well.
          if it works you may experience some flickering sometimes when using compiz. don't bother, that's a known stuff and even if it's really annoying it's the price to run compiz with actual fglrx.

          Comment


          • That does it! I'm so moving to radeonhd on my NEXT FRESH install!

            Comment


            • Originally posted by loloemr View Post
              A good point for this driver :

              suspend and hibernation (on Ubuntu gutsy) are back with the SLUB support integrated in the release. And this is far more important than Compiz ...
              That has already been fixed in 7.11.
              I did about 30 hibernate/resume and/or suspend/resume cycles in the last month. Not one failed.
              (And yes, with SLUB, but not *ubuntu)

              Comment


              • Originally posted by sundown View Post
                That does it! I'm so moving to radeonhd on my NEXT FRESH install!
                I've been using radeonhd for a month now from git. With composite enabled, it is still faster than fglrx even with no 2d accel.

                Comment


                • Originally posted by Berniyh View Post
                  That has already been fixed in 7.11.
                  I did about 30 hibernate/resume and/or suspend/resume cycles in the last month. Not one failed.
                  (And yes, with SLUB, but not *ubuntu)
                  Suspend works but resume does not work for me with 7.11 on Fedora 8 i386 and an Acer TM6465 laptop with an X1300. On resume I just get a black screen and the laptop hangs. Needs a power cycle to restart. Afaik the Fedora 8 kernels use SLUB so why would it work for you and not for me?

                  Comment


                  • Originally posted by lowlands View Post
                    Suspend works but resume does not work for me with 7.11 on Fedora 8 i386 and an Acer TM6465 laptop with an X1300. On resume I just get a black screen and the laptop hangs. Needs a power cycle to restart. Afaik the Fedora 8 kernels use SLUB so why would it work for you and not for me?
                    That is not the SLUB problem I guess.

                    Comment


                    • I've gone back to a hacked 8.42.3 since I didn't spend $3k on a 14.1" 4:3 sxga+ notebook to have to look at blurry 1024x768.

                      All I wanted from 7.12 was FireGL-support and suspend/resume...

                      Looks like I have to wait another month. :-(

                      Comment


                      • Still no Xvideo for avivo chipsets

                        This driver still does not support Xvideo for avivo based chipsets.
                        F$%^%g morons.

                        Comment


                        • Okay tested the driver with a HD2600XT a little bit.

                          - glxgears FPS increased from ~6700 to ~8300
                          - fgl_glxgears FPS increased from ~1600 to ~1900
                          - A green line, which appeared sometimes when playing a video with xv, is gone. With compiz running it's still there.
                          - Compiz performance seems to be better, but still not usable.
                          - With compiz there are sometimes small artifacts visible after an animation.
                          - All compiz window switchers are unusable because of black textures or very low FPS.
                          - Quake 4 is still only playable with crappy textures
                          - No visible performance improvements in UT2004, still very low FPS compared to windows.
                          - GtkPerf "GtkDrawingArea - Circles" test takes still about 1 minute to complete

                          Comment


                          • I'm getting the same

                            Originally posted by ltmon View Post
                            First the good:
                            - Installed easily
                            - Memory leak does indeed seem to be gone
                            - dkms is good - the installation has one less step. Hint for Ubuntu users: sudo apt-get install dkms before attempting the install, and then just don't worry about any of the module-assistant stuff that you normally do
                            - xrandr seems to work better (was intermitently failing to change resolution for me previously)
                            - Setting screen gamma outside of amdcccle works now, so having gamma set up inside games will work
                            - Ubuntu packaging script updates the compiz whitelist upon install

                            Now the bad:
                            - My dual head 1680x1050 is down to 1280x1024 (as per the release notes). Is this just a detection problem??? Can I fix it?? Because otherwise I have to downgrade and lose the above goodness

                            FYI, the relase notes say:


                            Cheers,

                            L.
                            I had the same problem and my refresh rate was haywire.. totally being ignored and all I got were crazy lines across my monitors.

                            Comment


                            • Originally posted by bradrm View Post
                              I had the same problem and my refresh rate was haywire.. totally being ignored and all I got were crazy lines across my monitors.
                              adjust the monitor refresh. you should have some option in its menu that autoadjusts the refresh rate. i had the same problem when the refresh of the monitor was different from the one in the output of the board. obviously this is valid for lcd monitors only.

                              Comment


                              • Refresh prob

                                Originally posted by givemesugarr View Post
                                adjust the monitor refresh. you should have some option in its menu that autoadjusts the refresh rate. i had the same problem when the refresh of the monitor was different from the one in the output of the board. obviously this is valid for lcd monitors only.
                                Right! It's weird because I have it set properly and this was the same xorg.conf I used w/ the previous driver (which set the freq. properly) but the new driver doesn't. I rebooted after installing and saw nothing but a crazy refresh.. I suppose I can try playing around w/ the refresh rates to see if the driver actually takes what I set in xorg.conf but so far it doesn't seem to be.

                                Comment

                                Working...
                                X