Announcement

Collapse
No announcement yet.

AMD Catalyst 7.12 Linux Driver -- The Baby's In Surgery

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by TrinitronX View Post
    Can't get the 7.12 driver working with 1440x900 widescreen resolution. Even with modelines, my monitor refuses to display it, saying that the signal is out of range. The specs on my monitor state that it supports 1440x900@60Hz, but modelines output from this don't work:
    Code:
    gtf 1440 900 60
    THE FOLLOWING MIGHT BROKE YOUR MONITOR. I'M NOT TO BE CONSIDERED RESPONSIBLE IF YOU USE WHAT I'M ABOUT TO SAY AND THIS WOULD BREAK YOUR HW. USE IT AT YOUR RISK.

    well, your xorg.conf has to support that modeline. this is the modeline to use for 1440x900@60hz with dot clock freq 108.4 mhz:

    Code:
    Modeline "1440x900@60" 108.84 1440 1472 1880 1912 900 918 927 946
    and has a real refresh of 56,92 hz.

    now to use this modeline your monitor edid or you monitor section must allow it's use.
    something similar to the following options have to be present in your section monitor:
    Code:
    	HorizSync    xx - xx
    	VertRefresh  xx - xx
    now, the vertrefresh is the one in hz, which in our case could be 50-60 for example. while the horizsync has to allow the use of 56,92 so it has to be something like 35-57.

    here is the link for an xfree86 modeline generator, that should be ok also for xorg.
    http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
    for the resolution issue that some have had i think that this error in the reading of the vertrefresh may lead to fglrx not enabling the modeline.
    if anyone has problems you could try out setting the vertrefresh max to allow the use of the resolution according to one generated by the modeline generator, but remember that IF YOU USE IT AND THIS BREAKS YOUR MONITOR I'M NOT TO BE CONSIDERED RESPONSIBLE. all i do is trying to help out with resolving the problem, but if you fell like not doing it just don't do it. wait for some user that has similar problems and is willing to try it out and see if it works.
    Last edited by givemesugarr; 01-04-2008, 06:38 AM.

    Comment


    • Originally posted by mancunian View Post
      My monitor is a 15" Packard Bell TFT LCD and its capabilities are:

      Code:
      DisplaySize  304 x 228 mm
        HorizSync    31-60
        VertRefresh  50-75
        Contrast 350:1
        Colors 16.7 Mio sim. 
        Response 30 ms
      you could add the following to your Section "Monitor":

      Code:
        DisplaySize  304 228
        HorizSync    31-60
        VertRefresh  50-75
      after setting this your modes would run as your monitor would be capable of running them and you'll not risk burning it down. having this set wrong could block some modelines.

      Comment


      • Originally posted by givemesugarr View Post
        you could add the following to your Section "Monitor":

        Code:
          DisplaySize  304 228
          HorizSync    31-60
          VertRefresh  50-75
        after setting this your modes would run as your monitor would be capable of running them and you'll not risk burning it down. having this set wrong could block some modelines.
        I have modified the Section "Monitor" accordingly, but the problem remains the same. Although the installation of 7.12 went seemingly fine, it still is incredibly slow, and that does not only concern the results delivered by glxgears, but also the response time of some programs such as scrolling in Firefox or the Gimp.

        Comment


        • Originally posted by mancunian View Post
          I have modified the Section "Monitor" accordingly, but the problem remains the same. Although the installation of 7.12 went seemingly fine, it still is incredibly slow, and that does not only concern the results delivered by glxgears, but also the response time of some programs such as scrolling in Firefox or the Gimp.
          coudl you post your xorg log and eventually the xorf.conf in another new thread? i don't remember if you've done it in some posts before, but i cannot find it. so opening a new thread might be good.

          Comment


          • Wide screen resolution seems to be somewhat of a bug with how the driver detects things, but you could always force it by modifying the screen section... try this section out to see if it fixes the ability to set the resolution to 1680x1050.
            Code:
            Section "Screen"
              DefaultDepth 24
              SubSection "Display"
                Depth      15
                Modes      "1680x1050" "1024x768" "800x600" 
              EndSubSection
              SubSection "Display"
                Depth      16
                Modes      "1680x1050" "1024x768" "800x600" 
              EndSubSection
              SubSection "Display"
                Depth      24
                Modes      "1680x1050" "1024x768" "800x600" 
              EndSubSection
              SubSection "Display"
                Depth      8
                Modes      "1680x1050" "1024x768" "800x600" 
              EndSubSection
              Device       "Device[0]"
              Identifier   "Screen[0]"
              Monitor      "Monitor[0]"
            EndSection

            Comment


            • Originally posted by givemesugarr View Post
              coudl you post your xorg log and eventually the xorf.conf in another new thread? i don't remember if you've done it in some posts before, but i cannot find it. so opening a new thread might be good.
              okay, I'll do so.You'll find the new thread here: http://www.phoronix.com/forums/showthread.php?t=7224
              Last edited by mancunian; 01-04-2008, 10:47 AM.

              Comment


              • Givemesugar Your idea also did not work for me. Its a problem with the driver.
                Btw in case it could help here is my xorg.0.log as well. http://www.pastebin.ca/841732
                Last edited by Compxpert; 01-04-2008, 04:38 PM.

                Comment


                • Originally posted by Compxpert View Post
                  Givemesugar Your idea also did not work for me. Its a problem with the driver.
                  Btw in case it could help here is my xorg.0.log as well. http://www.pastebin.ca/841732
                  what idea?! i don't seem to see nothing wrong in your xorg log with the exception of the resolution issue. if it's that one that you reffer to then mine was another tentative to try helping out the people who had problems with it. i never have said that it would work and i've said that messing out with imposed settings could be dangerous for the hw.
                  i'll try tomorrow to figure out a 1680x1050 modeline from your xorg log and post it if you'd like to try. if you want to do it yourself you could try searching in google how modelines work and how to create a modeline from the log. there are documents and forums that explain how to do it. remember that you have to insert the mode into modes section give it an identifier and then recall the modes from your monitor; then add

                  Code:
                  Option "PreferredMode"  "Mode[0]"
                  or the usemodes "mode[0]" option or both. this should make fglrx load and test the preferred mode first of the others and should make it work. but as you know this is a known issue with 7.12 and is also mentioned in the release notes.

                  ps. i see from your xorg log that you have your ago board recognized and working well. it's the first time i see an agp board being recognized as it is with 7.12.

                  Comment


                  • Originally posted by givemesugarr View Post
                    what idea?! i don't seem to see nothing wrong in your xorg log with the exception of the resolution issue. if it's that one that you reffer to then mine was another tentative to try helping out the people who had problems with it. i never have said that it would work and i've said that messing out with imposed settings could be dangerous for the hw.
                    i'll try tomorrow to figure out a 1680x1050 modeline from your xorg log and post it if you'd like to try. if you want to do it yourself you could try searching in google how modelines work and how to create a modeline from the log. there are documents and forums that explain how to do it. remember that you have to insert the mode into modes section give it an identifier and then recall the modes from your monitor; then add

                    Code:
                    Option "PreferredMode"  "Mode[0]"
                    or the usemodes "mode[0]" option or both. this should make fglrx load and test the preferred mode first of the others and should make it work. but as you know this is a known issue with 7.12 and is also mentioned in the release notes.

                    ps. i see from your xorg log that you have your ago board recognized and working well. it's the first time i see an agp board being recognized as it is with 7.12.
                    Wow that really worked. Didn't have everything setup properly the first time so it didn't work. There was a nice guide on what to do too. Works great.

                    Comment


                    • stop trying to figure out about resolution bugs, let's wait patiently three weeks for another _crappy_ _ati_ release solving this but breaking something else.

                      aren't we used to it?

                      Comment

                      Working...
                      X