Announcement

Collapse
No announcement yet.

AMD Catalyst 7.12 Linux Driver -- The Baby's In Surgery

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maybe best not to bother?

    Originally posted by klaus View Post
    I'm having the same problem as above, and yet livna has not build a rpm for fglrx 7.12
    Anybody can help?
    I just tried hacking the .spec file template to include the missing file, and then installed and rebooted, but X totally failed to initialise. All I got was a blank screen on my laptop, and I was forced to use Atl-SysRq-{S,U,B} to reboot. This is as far as Xorg managed to get:
    Code:
    (==) fglrx(0): HPV inactive
    (==) fglrx(0): NoDRI = NO
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Reloading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) fglrx(0): Depth moves disabled by default
    (==) fglrx(0): Capabilities: 0x00000000
    (==) fglrx(0): CapabilitiesEx: 0x00000000
    (==) fglrx(0): cpuFlags: 0x8000001d
    (==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
    (**) fglrx(0): ATI GART size: 256 MB
    And yes, I was apparently going to be stuck at 1280x1024 resolution as well, which is utterly unacceptable on a laptop with a native 1680x1050 panel.

    Comment


    • The amdpcsdb.default was missing from the SPEC file for Fedora, but if you check out the packaging script from http://www.phorogit.com/ it is updated.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • Funny, I thought you have been beta tester and Fedora maintainer the same time

        Comment


        • The RHEL packages fail even worse than this! Can someone tell me wha is supposed to happen to this unpackaged file, please?
          Had the same problem on Fedora 8, quick Google gave a solution:

          echo "%_unpackaged_files_terminate_build 0" >> ~/.rpmmacros

          And it works


          Anyways, I couldn't get the driver to work on Fedora (the PreInitDAL thing) after package installation and in Gentoo I don't have 3D acceleration
          By the way, did you notice that the RadeonHD driver is even faster than fglrx in 2D things, even though it doesn't provide 2D accel? I just noticed that the KDE menu has a fading-in effect if you have a working driver

          Comment


          • Thanks, but...

            Originally posted by Michael View Post
            The amdpcsdb.default was missing from the SPEC file for Fedora, but if you check out the packaging script from http://www.phorogit.com/ it is updated.
            I managed to build the packages after all, but X failed to initialise when I rebooted. See one of my earlier posts for the details. I am currently back to the 7-11 version. (I have a FireGL V5250 in a Thinkpad T60p, BTW.)

            Comment


            • Originally posted by executor View Post
              hello

              i tride ati 7.11 and 7.12 driver, the instal from the .run fil works, but direct redering thos not work.

              i have to go back to the defulte ubuntu 7.10 driver then fglrx works
              You need to disable the blacklisting of the kernel module under /etc/modprobe.d/blacklist-restricted

              Comment


              • Anyone has any idea why livna has not published fglrx for catalyst 7.11 & 7.12?

                Comment


                • A strange thing.

                  The Catalyst Control Center signal me on the OpenGL version: 1.2 (Mesa), whereas fglrxinfo signal correctly the 2.1.7170 Ati release...and also other tools (ex. Armagetron ).

                  fglrxinfo output:
                  OpenGL vendor string: ATI Technologies Inc.
                  OpenGL renderer string: ATI Mobility Radeon X1400
                  OpenGL version string: 2.1.7170 Release

                  Catalyst Control Center:
                  OpenGL vendor string: ATI Technologies Inc.
                  OpenGL renderer string: ATI Mobility Radeon X1400
                  OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

                  Is that a problem? Anyone with the same issue?
                  Last edited by subvertigo; 12-22-2007, 10:16 AM.

                  Comment


                  • Yes subvertigo....i have the same issue

                    Comment


                    • Just to say the driver installed flawlessy! Just sudo ./atibalhablahblah, no more modprobes, insmod etc etc
                      Driver load perfectely.

                      Got the performance from the last drivers and no signs of memory leak.

                      Thanks for the christmas gift ATI!!

                      PS: WoW is perfect!

                      (X1400 Mobility, KUBUNTU 7.10)

                      Comment


                      • I can't enable desktop effects under Ubuntu with 7.12

                        It was working great under 7.11 .......

                        Compositing and AIGLX are still set to on in the xorg.conf and in compiz fglrx is still whitelisted and the blacklist is set to ""

                        Did they break something with dual screens? Or do the almighty ATI gods hate me?

                        Any ideas?

                        Comment


                        • Well this new driver is running right now on my mandriva free 2008.

                          Here are the few improvement I have notice:

                          No more blinking when I run an OpenGl game with compiz-fusion. = better performance.

                          Once I had figure that I had different version of the kernel-devel package. I was able to install this driver.

                          This is my xorg.conf file. This file was not alter in anyway by me it was created when the driver was installed. I didn't tweaked or anything. I hope this could be useful to someone who is having problem getting this driver to work.



                          # File generated by XFdrake (rev 230776)
                          # ************************************************** ********************
                          # Refer to the xorg.conf man page for details about the format of
                          # this file.
                          # ************************************************** ********************

                          Section "ServerLayout"
                          Identifier "layout1"
                          Screen 0 "aticonfig-Screen[0]" 0 0
                          InputDevice "Keyboard1" "CoreKeyboard"
                          InputDevice "Mouse1" "CorePointer"
                          EndSection

                          Section "Files"
                          EndSection

                          Section "Module"
                          Load "dbe" # Double-Buffering Extension
                          Load "v4l" # Video for Linux
                          Load "extmod"
                          Load "type1"
                          Load "freetype"
                          Load "glx" # 3D layer
                          Load "dri" # direct rendering
                          EndSection

                          Section "ServerFlags"

                          #DontZap # disable <Ctrl><Alt><BS> (server abort)
                          #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
                          # allows the server to start up even if the mouse does not work
                          Option "allowmouseopenfail"
                          EndSection

                          Section "InputDevice"
                          Identifier "Keyboard1"
                          Driver "kbd"
                          Option "XkbModel" "pc105"
                          Option "XkbLayout" "ca"
                          Option "XkbOptions" "compose:rwin"
                          EndSection

                          Section "InputDevice"
                          Identifier "Mouse1"
                          Driver "mouse"
                          Option "Protocol" "ExplorerPS/2"
                          Option "Device" "/dev/mouse"
                          EndSection

                          Section "Monitor"

                          # TV fullscreen mode or DVD fullscreen output.
                          # 768x576 @ 79 Hz, 50 kHz hsync
                          Identifier "monitor1"
                          VendorName "Plug'n Play"
                          ModelName "IBM G97"
                          HorizSync 30.0 - 96.0
                          VertRefresh 50.0 - 160.0
                          ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
                          ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
                          EndSection

                          Section "Monitor"
                          Identifier "aticonfig-Monitor[0]"
                          Option "VendorName" "ATI Proprietary Driver"
                          Option "ModelName" "Generic Autodetecting Monitor"
                          Option "DPMS" "true"
                          EndSection

                          Section "Device"
                          Identifier "device1"
                          Driver "ati"
                          VendorName "ATI Technologies Inc"
                          BoardName "ATI Radeon 9500 - X850"
                          Option "DPMS"
                          Option "XaaNoOffscreenPixmaps" "1"
                          EndSection

                          Section "Device"
                          Identifier "aticonfig-Device[0]"
                          Driver "fglrx"
                          EndSection

                          Section "Screen"
                          Identifier "screen1"
                          Device "device1"
                          Monitor "monitor1"
                          DefaultDepth 24
                          SubSection "Display"
                          Depth 8
                          Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
                          EndSubSection
                          SubSection "Display"
                          Depth 15
                          Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
                          EndSubSection
                          SubSection "Display"
                          Depth 16
                          Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
                          EndSubSection
                          SubSection "Display"
                          Depth 24
                          Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
                          EndSubSection
                          EndSection

                          Section "Screen"
                          Identifier "aticonfig-Screen[0]"
                          Device "aticonfig-Device[0]"
                          Monitor "aticonfig-Monitor[0]"
                          DefaultDepth 24
                          SubSection "Display"
                          Viewport 0 0
                          Depth 24
                          EndSubSection
                          EndSection

                          Section "Extensions"
                          Option "Composite"
                          EndSection
                          This is the install log:

                          [Message] Kernel Module : Trying to install a precompiled kernel module.
                          [Message] Kernel Module : Precompiled kernel module version mismatched.
                          [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
                          ATI module generator V 2.0
                          ==========================
                          initializing...
                          cleaning...
                          patching 'highmem.h'...
                          assuming new VMA API since we do have kernel 2.6.x...
                          Assuming default VMAP API
                          Assuming default munmap API
                          doing Makefile based build for kernel 2.6.x and higher
                          make -C /lib/modules/2.6.22.12-desktop-1mdv/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
                          make[1]: entrant dans le répertoire « /usr/src/linux-2.6.22.12-desktop-1mdv »
                          CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
                          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_request_irq’:
                          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2947: attention : ‘deprecated_irq_flag’ is deprecated (declared at include/linux/interrupt.h:66)
                          LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
                          Building modules, stage 2.
                          MODPOST 1 modules
                          CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
                          LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
                          make[1]: quittant le répertoire « /usr/src/linux-2.6.22.12-desktop-1mdv »
                          build succeeded with return value 0
                          duplicating results into driver repository...
                          done.
                          ==============================
                          - recreating module dependency list
                          - trying a sample load of the kernel modules
                          failed.
                          [Error] Kernel Module : Failed to install compiled kernel module - please consult readme.

                          Comment


                          • [Error] Kernel Module : Failed to install compiled kernel module - please consult readme.
                            are you really sure to have installed the driver?! from this error to me it seems that the module wasn't installed...

                            Comment


                            • Yes it is working

                              glxinfo is OK
                              the ati catalyst control center is OK
                              Doom3 , glxgears, fgl_glxgears compiz-fusion all work very well.

                              I know that the error message is troubling but I assure you that it is install and working.

                              Comment


                              • Maybe my problem was envy?

                                I found the solution on the ubuntu forums for those who are interested... it might even be earlier in this thread I didn't read the whole thing, 19 pages is a lot.

                                http://www.google.com/url?sa=t&ct=re..._1c4maXU6Iet8A

                                Comment

                                Working...
                                X