Announcement

Collapse
No announcement yet.

AMD Catalyst 7.12 Linux Driver -- The Baby's In Surgery

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I don't blame your developers. I blame your management. A soldier can only be as good as his orders.

    My next computer will have integrated Intel graphics, which means it will have an Intel processor. Sorry nvidia & AMD/ATI. If you ever get your acts together I'll buy another graphics card.

    I'd just rather not have to worry about whether my computer will be functional next week, or if, instead, some manager is too busy staring at his secretary's thighs and thinking about his holiday bonus check to make sure his customers get quality drivers.

    Comment


    • sounds like ati is making fun of developers too

      their releasing cycle, their random version numbers

      so, it's more than just making fun of users

      Originally posted by Kano View Post
      That driver has beta status when you call it friendly. None of the bugs I found have been fixed, so for me it is no bugfix release. The release notes are even missleading, not 1680x1050 is not supported the driver has problems with non-vesa modes. Sometimes EDID info could be used as Michael mentions for his display, but there must be a huge bug in the EDID use in this driver. Now the xmas break will come and I guess nobody will work on it till next year. So maybe I even switch back to 7-11 as default driver (and 8.39.4 for firegl), not sure about that now. Or maybe ATI could prepare a bugfix for the bugfix release and call it even 7-12 My script is prepared for any nameing scheme now *g*

      Comment


      • 1680x1050 ????

        Looks like I'm going to be reverting to last version of fglrx... WTF WITH NO WIDESCREEN SUPPORT?????

        Comment


        • ati should just release the specs and give it up. get their devs to help with radeonhd instead.

          why embarass yourself further with such awful drivers. this is seriously getting beyond unreal. even crappies chinese/taiwanese vendors write better drivers for their hardware.

          Comment




          • this is seriously retarded..

            I dare one ati dev to come up and explain how this 1680x1050 even occured in just a month. This just doesnt make any sense. Whatever code you guys are working with must be horribly written.

            I was gonna try 7.12 but I'm not even gonna risk getting it even close to my box. No way..

            AMD hello?....

            (oh and this is really starting to weigh down on Phoronix & Michael's credibility ... remember that Gamespot story from a couple weeks back? Read the articles about new driver releases and you'll see what I'm talking about.....)
            Last edited by pedepy; 12-22-2007, 03:04 AM.

            Comment


            • hmm. very very strange ...
              now i TRY to run compiz on xorg-1.3 .. ok , i have to admit: it does run! .. but it's f*****g unusable! i thought version 7.11 was a bit slow in compiz, but now it's really like you turn on slow motion when slow motion is already turned on!!

              The only possibility:
              Are there some options for xorg.conf that do improve the 3d-speed ? or: are there some options that do slow everything down ?

              please tell me .. else i have to buy a nvidia in 2 weeks


              EDIT: now i saw that X uses the WHOLE cpu-power when compiz is running! so i think it's no problem with the driver ?!
              when compiz isn't running X takes 6-9% cpu load
              any suggestions / hints ?

              EDIT2: when i don't run compiz and my 3D-screensaver is starting it's veeeerrry slow. i think every 3D app is slow.. glxgears only has HALF fps as before
              Last edited by benneque; 12-22-2007, 04:09 AM.

              Comment


              • Hmm, I don't seem to have much of the problems what you guys are having. On my Ubuntu 7.10 (Gutsy), all I had to to was just install dkms (apt-get install dkms), then double-click on the .run file and "Run in Terminal". Everything works for the installation part.

                I'm using ATI Mobility Radeon X1400 with 1280x800 resolution (widescreen), Acer Aspire 5560, and everything worked perfectly (yep, even projector plugging etc.)

                The dkms magic worked perfectly, and I was having Compiz Fusion on the re-start. Performance for me was on par with 7.11/7.10, except for scrolling lags in Firefox. Frame rates in ET:QW didn't drop or increase (or maybe it was unnoticable).

                Suspend and hibernate worked perfectly with the modified acpi-support. No XVideo issues were observed too, except for some minor flicker when GTK windows are placed above the video window.

                Comment


                • OK, so basically, they fixed one memory leak and added support for FireGL? No real accelerated Compiz? No video playback?

                  Come on, they aren't poor open-source guys trying to do their job in free time. They are paid developers who suck at their work. No excuses.

                  Comment


                  • Now installed the driver, here some impressions:

                    1. +100 fps in fgl_glxgears on a Radeon 9550 (~612fps)
                    2. Vlc with OpenGL output works fine (i could post my xorg.conf if anyone needs)
                    3. Xvideo doesn't crashes xorg anymore, so i can play my favourite video in Vlc or Mplayer with Xvideo output

                    4. I use an Ati's BigDesktop configuration with an LCD monitor at 1280x1024 and a Tv Color at 1024x768. Since 7.11 release i can't use this configuration because the LCD goes to 1024x768 as TV

                    Comment


                    • People you do realise that the resolution issue was mentioned in the release notes as a known issue riht?

                      Comment


                      • Originally posted by Raven3x7 View Post
                        People you do realise that the resolution issue was mentioned in the release notes as a known issue riht?
                        1. As far as I know release notes do not mention any problems with my resolution (1440x900).
                        2. Even if they did, I would still complain because I do not feel that I should remain silent when drivers keep getting worse with every release. If 8.1 had some ridiculous known issues (lets say: '8.1 changes display to 256 colours') would you stay quiet only because they do know about this problem? I doubt it.
                        Cheers,

                        Wojtek

                        Comment


                        • People you do realise that the resolution issue was mentioned in the release notes as a known issue riht?
                          i think that this resolution issue is due to some non standard edid in the monitors. i've tried my lg and it works in 1440x900, my laptop samsung works at 1280x800. so, after reading some xorg logs around it seems that non standard edid have problems to be read. i'll try also the hdmi through dvi-hdmi converter on my lcd tv and see what happens. i'll let you know if this functions.

                          Comment


                          • Fedora packages are failing to build for me.

                            Code:
                            Checking for unpackaged file(s): /usr/lib/rpm/check-files /tmp/ATI-fglrx-8.443.1-1-20858-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root
                            error: Installed (but unpackaged) file(s) found:
                               /etc/ati/amdpcsdb.default
                            
                            
                            RPM build errors:
                                Installed (but unpackaged) file(s) found:
                               /etc/ati/amdpcsdb.default
                            Removing temporary directory: fglrx-install.P20779
                            The RHEL packages fail even worse than this! Can someone tell me wha is supposed to happen to this unpackaged file, please?

                            Comment


                            • I'm having the same problem as above, and yet livna has not build a rpm for fglrx 7.12
                              Anybody can help?

                              Comment


                              • I'm having the same problem, and yet livna has not published catalyst 7.12
                                Anybody can help?

                                Comment

                                Working...
                                X