Announcement

Collapse
No announcement yet.

Is tv overscan possible in dual head configuration??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is tv overscan possible in dual head configuration??

    Hello all,

    I am running the latest proprietary ATI linux drivers(8.31.5) on ubuntu edgy.
    I have set up in dual head mode so i can put videos on the TV for my G/F while still using the computer for my important stuff.

    This setup is working fine except that i can't seem to enable overscan on the tv-out in dual head mode. i can do it in clone and big desktop!

    here is a snippet of my xorg.conf

    Code:
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "KernelModuleParm" "agplock=0"
    	Option	    "ForceMonitors" "tdms1,tv"
    	Option	    "TVHPosAdj" "0"
    	Option	    "TVVPosAdj" "0"
    	Option	    "TVHSizeAdj" "100"
    	Option	    "TVVSizeAdj" "100"
    	Option	    "TVFormat" "PAL-I"
    	Option	    "TVStandard" "SCART"
    	Option	    "OverlayOnCRTC2" "0"
    	BusID       "PCI:5:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[1]"
    	Driver      "fglrx"
    	BusID       "PCI:5:0:0"
    	Screen      1
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device     "Generic Video Card"
    	Monitor    "PLE430/431"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     1
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     4
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     8
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     15
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     16
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     24
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[1]"
    	Device     "aticonfig-Device[1]"
    	Monitor    "aticonfig-Monitor[1]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "640x480"
    	EndSubSection
    EndSection
    When i do
    aticonfig --tv-info

    i get
    The TV is not connected
    The TV geometry is "100x100+0+0"
    The horizontal position limits are [0, 146571128]
    The vertical position limits are [147396624, 146486216]
    TV overscan mode is enabled

    But the tv is definitly connected(eg. i have an instance of x running on it and i can see it!) and the overscan is definitly not enabled!!!!!

    Any gurus out there know if this is possible/how to do it???

    Cheers

    Dave

  • #2
    Does overscan work if you enable the second display dynamically with aticonfig using the DDM options?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Thanks for the help,

      Tried that, got this
      Code:
      root@edgy-eft:/home/dave# aticonfig --enable-monitor=tmds1,tv
      ati_dm: FGLRX_EnableDisplays failed when try to enable display: c.
      Using /etc/X11/xorg.conf
      Saved back-up to /etc/X11/xorg.conf.fglrx-24
      root@edgy-eft:/home/dave# aticonfig aticonfig --query-monitor
        Connected monitors: tv, tmds1
        Enabled monitors: tv, tmds1
      Warning : Option 'QueryMonitor' is exclusive, other options will be ignored.
      root@edgy-eft:/home/dave#
      It didn't seem to work but i can't mess with it at the moment as my g/f is home and is watching tv

      I'll try some more experimentation tomorrow.

      Dave

      Comment


      • #4
        Had you tried using the dynamic options when using a "simple" configuration (e.g. aticonfig --initial and then enabling overscan)?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          I'll give that a go tomorrow, stay tuned for more updates

          Comment


          • #6
            My conf. works ok. (overscan included) http://www.phoronix.net/forums/showp...21&postcount=7
            after initial configuration, you enable overscan. With edgy and 8.31.5 it works better if you
            sudo -i and then
            cd /etc/X11/
            aticonfig [options] instead of
            sudo aticonfig [options] from your current directory.

            Why would you want overscan on dual-head since you wouldn't see the panels to control the second monitor?
            Last edited by giorgosts; 12-04-2006, 04:31 PM.

            Comment


            • #7
              Thanks for the replies guys, I'll probably have to try these on the weekend now as my g/f's work schedule means that she'll be monopolising said television until the weekend

              Thanks

              Dave

              Comment

              Working...
              X