Announcement

Collapse
No announcement yet.

XGL/ Beryl/ compiz/ and 3D stuff

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XGL/ Beryl/ compiz/ and 3D stuff

    Hi!~
    im new here, and i installed my ati radeon 9550 using the official phoronix tuto; i passed lots of time before post reading, but i dont found a way to install beryl(or simpli atctive the "Desktop Effects"). so, wat how to, tutorial, i should use to active beryl?

    (ah, i installed it(only essentials) and i get this running:

    $ beryl
    Xlib: extension "XVideo" missing on display ":0.0".
    xvinfo: No X-Video Extension on :0.0
    XGL Absent, checking for NVIDIA
    Nvidia Absent, assuming AIGLX
    beryl: No composite extension
    )'s

    before ask, im friend of google XD
    and i spend lots of time trying to search anythink;

    thx alot!!!

  • #2
    gearsolid,

    At this time the official ATI/AMD drivers (fglrx) do not support GLX_ext_texture_from_pixmap or AIGLX. The fglrx drivers also do not support the X Composite extension. If you wish to use the FC6 Desktop Effects, you will need to switch to the open-source Radeon drivers. You have an ATI Radeon 9550 so the open-source drivers should work great with them, but if you're into gaming these drivers will perform slower.

    The ATI Radeon drivers are built into X11R71, so actually when you had installed Fedora Core 6 you were already to go However, to switch back you can remove the fglrx drivers and then revert your xorg.conf back to your original config or just change it over to use radeon instead of fglrx.

    After that you should be able to use Fedora's desktop effects as well as Beryl or whatever you are interested in. If you have additional questions just post.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      intresting

      ok, no more composite extensions, so go to KDE !!! \o/
      but before, one question... i finish now the fedora update(around 1gb >_>") and now my fglrx driver broken donw, wat i should do? remake the tutorial?

      in the update, the new kernel versions setup:
      $ uname -a
      Linux localhost.localdomain 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:36:14 EST 2006 i686 athlon i386 GNU/Linux

      my ati control painel:
      http://img373.imageshack.us/img373/63/testhh0.jpg

      $ fglrxinfo
      display: :0.0 screen: 0
      OpenGL vendor string: Mesa project: www.mesa3d.org
      OpenGL renderer string: Mesa GLX Indirect
      OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
      my xorg:
      Section "Monitor"
      Identifier "aticonfig-Monitor[0]"
      Option "VendorName" "ATI Proprietary Driver"
      Option "ModelName" "Generic Autodetecting Monitor"
      Option "DPMS" "true"
      EndSection

      Section "Device"
      Identifier "Videocard0"
      Driver "radeon"
      EndSection

      Section "Device"
      Identifier "aticonfig-Device[0]"
      Driver "fglrx"
      EndSection

      Section "Screen"
      Identifier "Screen0"
      Device "Videocard0"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      Modes "1280x1024" "1280x960" "1280x960" "1280x800" "1280x800" "1152x864" "1152x864" "1152x768" "1152x768" "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
      EndSubSection
      EndSection

      Section "Screen"
      Identifier "aticonfig-Screen[0]"
      Device "aticonfig-Device[0]"
      Monitor "aticonfig-Monitor[0]"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      EndSubSection
      EndSection

      Section "Extensions"
      Option "Composite" "Disable"
      EndSection
      thx!

      Comment


      • #4
        You need to reinstall the drivers (well, the kernel module). Every time the kernel is updated the drivers need to be reinstalled (for closed-source drivers).

        However, if you want the 3D stuff you can just use the Radeon driver and not fglrx.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment

        Working...
        X