Announcement

Collapse
No announcement yet.

ATI fglrx 8.31.5 - error while building RPMs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    See www.livna.org for fglrx driver RPMs, though those aren't built using the included packaging scripts.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #12
      Originally posted by Michael View Post
      See www.livna.org for fglrx driver RPMs, though those aren't built using the included packaging scripts.
      Realise that this thread is a bit old now, and since i don't even use fedora anymore (due to the problems with the ATI drivers) it might be a bit irrelevent, but i solved the -lqt dependency problem when building the fireglpanel from source. I simply invoked
      ln -s /usr/lib/qt3/lib/libqt-mt.so /usr/lib/libqt.so
      as root

      Sorts it out on mandriva anyway. Hope this might help someone in the future.

      Comment


      • #13
        Michael, sorry for not replying for so long (illness prevented me from doing this). I have installed the drivers from livna.org. It seems to me that video has improved, but I haven't 3D accelleration. I suppose that something should be written in xorg.conf, but what? (These options change from version to version.)

        lebabyg, perhaps you are right. I'll try your method, when I have time.

        P.S. Merry Cristmas to all Phoronix Forums Members!

        Comment


        • #14
          fixed for me

          yum install libXext-devel libXmu-devel libSM-devel libXxf86vm-devel compat-libstdc++-33 qt-devel
          ln -s /usr/lib64/qt-3.3/lib/libqt-mt.so /usr/lib/libqt-mt.so
          ln -s /usr/lib/qt-3.3/lib64 /usr/lib/qt-3.3/lib


          then it builds for me


          What utter crap that ATI can't at least tell you what fscking requisites are needed.

          Comment


          • #15
            Problem Solved

            Hey, I've finally managed to install ATi fglrx drivers correctly and get 3D acceleration. The solution was quite simple: I'd installed both Gnome & KDE (without installing additional libraries, as I did last time).

            I don't know what was the real cause of my problem, but it is solved for the time being. Thanks to all, who took part in helping me!!!

            Comment

            Working...
            X