Announcement

Collapse
No announcement yet.

OpenSUSE 10.3 + 7.11/8.43.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OpenSUSE 10.3 + 7.11/8.43.1

    Well This time i don`t get black screen when i boot my pc.
    In konqueror there reads as i should be on id on driver-card.
    But fglrxinfo says:

    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

    Not as it should.

    I haven`t further tested how this driver works, but i would like hear other people opinion and experience on openSUSE 10.3 and this latest 7.11/8.43.1 or with some other distro also.

    Ps. Sorry my rusty english

  • #2
    The 8.43.3 driver works fine here under opensuse 10.3 How did you install it? I recommend using the one-click method:

    http://opensuse-community.org/ati.ymp

    Comment


    • #3
      I installed the kernel and that other package by using Yast, and then in console sax2 -r -m 0=fglrx , the computer regonize the card but not 100% sense fglrxinfo= was what iposted earlier.
      Well i try that method and come back tell what did happen after that.

      Comment


      • #4
        Well i installed the latest driver by one-click-installer, but first mouse didn`t work, i got fixed that and now it works, in konqueror there reads what it should read by meaning the card.
        But fglrxinfo says:

        display: :0.0 screen: 0
        OpenGL vendor string: Mesa project: www.mesa3d.org
        OpenGL renderer string: Mesa GLX Indirect
        OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

        And xorg.xonf is:

        Version: 8.1
        # Contact: Marcus Schaefer <sax@suse.de>, 2005
        # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
        #
        # Automatically generated by [SaX2] (8.1)
        # PLEASE DO NOT EDIT THIS FILE!
        #

        Section "Files"
        FontPath "/usr/share/fonts/misc:unscaled"
        FontPath "/usr/share/fonts/local"
        FontPath "/usr/share/fonts/75dpi:unscaled"
        FontPath "/usr/share/fonts/100dpi:unscaled"
        FontPath "/usr/share/fonts/Type1"
        FontPath "/usr/share/fonts/URW"
        FontPath "/usr/share/fonts/Speedo"
        FontPath "/usr/share/fonts/PEX"
        FontPath "/usr/share/fonts/cyrillic"
        FontPath "/usr/share/fonts/latin2/misc:unscaled"
        FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath "/usr/share/fonts/latin2/Type1"
        FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath "/usr/share/fonts/baekmuk:unscaled"
        FontPath "/usr/share/fonts/japanese:unscaled"
        FontPath "/usr/share/fonts/kwintv"
        FontPath "/usr/share/fonts/truetype"
        FontPath "/usr/share/fonts/uni:unscaled"
        FontPath "/usr/share/fonts/CID"
        FontPath "/usr/share/fonts/ucs/misc:unscaled"
        FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath "/usr/share/fonts/hellas/misc:unscaled"
        FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath "/usr/share/fonts/hellas/Type1"
        FontPath "/usr/share/fonts/misc/sgi:unscaled"
        FontPath "/usr/share/fonts/xtest"
        FontPath "/opt/kde3/share/fonts"
        InputDevices "/dev/gpmdata"
        InputDevices "/dev/input/mice"
        EndSection

        Section "Module"
        Load "dbe"
        Load "type1"
        Load "freetype"
        Load "extmod"
        Load "glx"
        EndSection

        Section "ServerFlags"
        Option "AllowMouseOpenFail" "on"
        EndSection

        Section "InputDevice"
        Driver "kbd"
        Identifier "Keyboard[0]"
        Option "Protocol" "Standard"
        Option "XkbLayout" "fi"
        Option "XkbModel" "pc102"
        Option "XkbRules" "xfree86"
        EndSection

        Section "InputDevice"
        Driver "evdev"
        Identifier "Mouse[1]"
        Option "Buttons" "10"
        Option "InputFashion" "Mouse"
        Option "Name" "Logitech USB R*"
        Option "Protocol" "event"
        Option "SendCoreEvents" "on"
        Option "Vendor" "Sysp"
        Option "ZaxisMapping" "4 5"
        EndSection


        Section "Monitor"
        Option "CalcAlgorithm" "XServerPool"
        HorizSync 31-64
        Identifier "Monitor[0]"
        ModelName "1280X1024@60HZ"
        Option "DPMS"
        VendorName "--> VESA"
        VertRefresh 50-60
        UseModes "Modes[0]"
        EndSection


        Section "Modes"
        Identifier "Modes[0]"
        EndSection


        Section "Device"
        BoardName "Framebuffer Graphics"
        Driver "fbdev"
        Identifier "Device[0]"
        VendorName "VESA"
        EndSection


        Section "Screen"
        SubSection "Display"
        Depth 15
        Modes "default"
        EndSubSection
        SubSection "Display"
        Depth 16
        Modes "default"
        EndSubSection
        SubSection "Display"
        Depth 24
        Modes "default"
        EndSubSection
        SubSection "Display"
        Depth 8
        Modes "default"
        EndSubSection
        Device "Device[0]"
        Identifier "Screen[0]"
        Monitor "Monitor[0]"
        EndSection


        Section "ServerLayout"
        Identifier "Layout[all]"
        InputDevice "Keyboard[0]" "CoreKeyboard"
        InputDevice "Mouse[1]" "CorePointer"
        Screen "Screen[0]"
        EndSection


        Section "DRI"
        Group "video"
        Mode 0660
        EndSection

        So as you can see the driver doesn`t work on me, by the way adamk would you show your xorg.conf
        Does anybody have any good tip, thanks for answer already

        Ps. and sorry my rusty english

        Comment

        Working...
        X