Announcement

Collapse
No announcement yet.

AGP PCI-E Issues (Rialto chip) No Interupt (IRQ) assigned, Poor performance.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    BUMP
    BUMP
    BUMP
    Need to keep this topic alive, this is a serious issue!

    How long till the new driver?

    Has anyone reported this error to ATI or do they read though phoronix on lunch breaks or something? :P

    Moe

    P.S. I believe its "Rialto" not Realto, might be helpful to change the topic title. (oliver?)
    Last edited by nonamo; 12-20-2007, 01:28 PM.

    Comment


    • #52
      ATI is aware of AGP issues and they will be resolved in the very near future.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #53
        Originally posted by Michael View Post
        ATI is aware of AGP issues and they will be resolved in the very near future.
        That sounds like music to my ears

        I was hoping for 7.12 before x-mas hollidays ... guess it'll be next week, oh well Happy Holidays to you all!

        Comment


        • #54
          Originally posted by oliver View Post
          guess it'll be next week, oh well

          ...Says who?
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #55
            Originally posted by Michael View Post
            ...Says who?
            stop gettin' me excited!

            Ok you got me excitred! 7.12 is out!!

            SO .. anybody tried it yet? it's 6am here so i gotta catch a few hours of sleep, lemme know what's up
            Last edited by oliver; 12-21-2007, 12:01 AM.

            Comment


            • #56
              Well I can't see if this is fixed because of an entirely seperate PreInitDAL failed error:

              http://www.phoronix.com/forums/showthread.php?t=7015

              Anyone with an AGP card got 7.12 working? It would be nice to know if Rialto cards now work!

              Comment


              • #57
                I'm off for hollidays, so I won't be able to test it till 28 or 29th of december.

                Comment


                • #58
                  i'm excited ;-)

                  my tests will start if i'm done with work, i think in one to two hours.

                  Comment


                  • #59
                    Looks like the interrupt issue in 7.12 is fixed! No more interrupt errors, and X doesn't lock-up when I logout or ctrl-alt-bkspc

                    fglrxinfo:
                    display: :0.0 screen: 0
                    OpenGL vendor string: ATI Technologies Inc.
                    OpenGL renderer string: Radeon X1950 Series
                    OpenGL version string: 2.1.7170 Release

                    xorg.0.log:
                    (II) fglrx(0): Interrupt handler installed at IRQ 20.

                    dmesg:
                    [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
                    ACPI: PCI Interrupt Link [APC5] enabled at IRQ 16
                    ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [APC5] -> GSI 16 (level, low) -> IRQ 20

                    But I still can't get compiz-fusion working.

                    Comment


                    • #60
                      The interrupt issues are gone...yippiiee :-)
                      But now, i'm sitting here without 3d acceleration, cause of 'Failed to remmap MC AGP aperture base!'

                      further testing will be slightly delayed ;-)


                      Edit: fixed the aperture base error by setting agp aperture size from 512MB to 256MB
                      Last edited by uzi-; 12-22-2007, 10:57 AM.

                      Comment

                      Working...
                      X