Announcement

Collapse
No announcement yet.

AGP PCI-E Issues (Rialto chip) No Interupt (IRQ) assigned, Poor performance.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by NIKE View Post
    Code:
    Option "TexturedVideo" "ON"
    Option "AGPMask" "0x00000210"
    
    Option "AGPv3Mask" "0x00000002"
    #Option "KernelModuleParm" "agplock=3"
    Option "BusType" "AGP"
    Option "KernelModuleParm" "agpgart=2"
    Option "KernelModuleParm" "agp_try_unsupported=1" 
    Option "KernelModuleParm" "debug=1"
    Option "KernelModuleParm" "maxlockedmem=512"
    Option "Stereo" "off"
    # not used Option "EnableLogo" "true"
    # not used Option "FSAAEnable" "1"
    Option "UseInternalAGPGart" "no"
    Option "MaxGARTSize" "512"
    Option "mtrr" "0"
    # not used Option "PBuffer" "0"
    Option "UseFastTLS" "2"
    it's my option and no error!!
    Code:
    (II) [drm] DRM interface version 1.0
    (II) [drm] DRM open master succeeded.
    (II) fglrx(0): [drm] Using the DRM lock SAREA also for drawables.
    (II) fglrx(0): [drm] framebuffer handle = 0x39d000
    (II) fglrx(0): [drm] added 1 reserved context for kernel
    (II) fglrx(0): X context handle = 0x1
    (II) fglrx(0): [drm] installed DRM signal handler
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0):     Name: fglrx
    (II) fglrx(0):     Version: 8.43.2
    (II) fglrx(0):     Date: Nov  9 2007
    (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
    (II) fglrx(0): Kernel Module version matches driver.
    (II) fglrx(0): Kernel Module Build Time Information:
    (II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.22-gentoo-r8
    (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
    (II) fglrx(0):     Build-Kernel __SMP__:            yes
    (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
    (II) fglrx(0): [drm] register handle = 0x0039f000
    (II) fglrx(0): [pci] find AGP GART
    (II) fglrx(0): [agp] Mode=0x1f004a1b bridge: 0x8086/0x2570
    (II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000210
    (II) fglrx(0): [agp] AGP v3 disable mask   0x00000002
    (II) fglrx(0): [agp] enabling AGP with mode=0x1f004b19
    (II) fglrx(0): [agp] Remapping MC AGP space (new MCAGPBase = 0xe0000000)
    (II) fglrx(0): [agp] AGP protocol is enabled for graphics board. (cmd=0x1f004311)
    (II) fglrx(0): [agp] graphics chipset has AGP v3.0 (native mode)
    (II) fglrx(0): DRI initialization successfull!
    (II) fglrx(0): front overlay:  0xc1001400
    (II) fglrx(0): back overlay:   0xc11b0000
    (II) fglrx(0): video overlay:  0xc135ec00
    (II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x01001400
    (II) fglrx(0): FBMM initialized for area (0,0)-(1728,2428)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1728,1050) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 1728 x 1378
    (==) fglrx(0): Backing store disabled
    old
    Code:
    Nov 30 16:08:35 localhost [fglrx] Maximum main memory to use for locked dma buffers: 1899 MBytes.
    Nov 30 16:08:35 localhost [fglrx] IRQ_MGR is disabled untill GART_CACHABLE memory will be implemented<6>[fglrx] AGP detected, AgpState   = 0x1f004a1b (hardware caps of chipset)
    Nov 30 16:08:35 localhost agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
    Nov 30 16:08:35 localhost agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
    Nov 30 16:08:35 localhost agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
    Nov 30 16:08:35 localhost [fglrx] AGP enabled,  AgpCommand = 0x1f004311 (selected caps)
    new
    Code:
    Nov 30 16:09:50 localhost [fglrx] Maximum main memory to use for locked dma buffers: 1899 MBytes.
    Nov 30 16:09:50 localhost [fglrx] AGP detected, AgpState   = 0x1f004a1b (hardware caps of chipset)
    Nov 30 16:09:50 localhost agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
    Nov 30 16:09:50 localhost agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
    Nov 30 16:09:50 localhost agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
    Nov 30 16:09:50 localhost [fglrx] AGP enabled,  AgpCommand = 0x1f004311 (selected caps)
    but this not fix slow speed and buggy graphics

    ps
    video x1950gt 512mb agp
    So maybe that options hides the interupt error? Worth a try, but I don't have any hopes at this point anymore.

    Comment


    • #47
      I had pulled my FX5900 and installed my AGP X1600 Pro back when Phoronix was pushing the new ATi drivers as the next coming. I tried a lot of stuff, and don't recall ever even getting the IRQ errors, but performance was still horrible.

      I'm back to my FX5900 now and am about to build a new system with an 8800 GT.

      Comment


      • #48
        Originally posted by psycho_driver View Post
        I had pulled my FX5900 and installed my AGP X1600 Pro back when Phoronix was pushing the new ATi drivers as the next coming. I tried a lot of stuff, and don't recall ever even getting the IRQ errors, but performance was still horrible.

        I'm back to my FX5900 now and am about to build a new system with an 8800 GT.
        It appears that maybe this option may hide the error?

        Performance was ... weird for me with the error. It was fast, n slow, sluggish, short spikes of performance, then, just slow. 8 more days! (i hope)

        Comment


        • #49
          Originally posted by NIKE View Post
          Code:
          Option "TexturedVideo" "ON"
          Option "AGPMask" "0x00000210"
          
          Option "AGPv3Mask" "0x00000002"
          <snip>
          Option "UseFastTLS" "2"
          but this not fix slow speed and buggy graphics

          ps
          video x1950gt 512mb agp
          I've tried it, and it doesn't even stop my interrupt error on my geforce k8ns ultra939 board.

          Where do you get a listing of all those parameters that explains them???

          Not that I would waste any more time trying. My respect for Radeon is done till they produce a documented driver that works right.

          Comment


          • #50
            Originally posted by IrradeoActive View Post
            I've tried it, and it doesn't even stop my interrupt error on my geforce k8ns ultra939 board.

            Where do you get a listing of all those parameters that explains them???

            Not that I would waste any more time trying. My respect for Radeon is done till they produce a documented driver that works right.
            Which may be tomorrow! or wednesday, this week anyway

            Comment


            • #51
              BUMP
              BUMP
              BUMP
              Need to keep this topic alive, this is a serious issue!

              How long till the new driver?

              Has anyone reported this error to ATI or do they read though phoronix on lunch breaks or something? :P

              Moe

              P.S. I believe its "Rialto" not Realto, might be helpful to change the topic title. (oliver?)
              Last edited by nonamo; 12-20-2007, 01:28 PM.

              Comment


              • #52
                ATI is aware of AGP issues and they will be resolved in the very near future.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #53
                  Originally posted by Michael View Post
                  ATI is aware of AGP issues and they will be resolved in the very near future.
                  That sounds like music to my ears

                  I was hoping for 7.12 before x-mas hollidays ... guess it'll be next week, oh well Happy Holidays to you all!

                  Comment


                  • #54
                    Originally posted by oliver View Post
                    guess it'll be next week, oh well

                    ...Says who?
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #55
                      Originally posted by Michael View Post
                      ...Says who?
                      stop gettin' me excited!

                      Ok you got me excitred! 7.12 is out!!

                      SO .. anybody tried it yet? it's 6am here so i gotta catch a few hours of sleep, lemme know what's up
                      Last edited by oliver; 12-21-2007, 12:01 AM.

                      Comment


                      • #56
                        Well I can't see if this is fixed because of an entirely seperate PreInitDAL failed error:

                        http://www.phoronix.com/forums/showthread.php?t=7015

                        Anyone with an AGP card got 7.12 working? It would be nice to know if Rialto cards now work!

                        Comment


                        • #57
                          I'm off for hollidays, so I won't be able to test it till 28 or 29th of december.

                          Comment


                          • #58
                            i'm excited ;-)

                            my tests will start if i'm done with work, i think in one to two hours.

                            Comment


                            • #59
                              Looks like the interrupt issue in 7.12 is fixed! No more interrupt errors, and X doesn't lock-up when I logout or ctrl-alt-bkspc

                              fglrxinfo:
                              display: :0.0 screen: 0
                              OpenGL vendor string: ATI Technologies Inc.
                              OpenGL renderer string: Radeon X1950 Series
                              OpenGL version string: 2.1.7170 Release

                              xorg.0.log:
                              (II) fglrx(0): Interrupt handler installed at IRQ 20.

                              dmesg:
                              [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
                              ACPI: PCI Interrupt Link [APC5] enabled at IRQ 16
                              ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [APC5] -> GSI 16 (level, low) -> IRQ 20

                              But I still can't get compiz-fusion working.

                              Comment


                              • #60
                                The interrupt issues are gone...yippiiee :-)
                                But now, i'm sitting here without 3d acceleration, cause of 'Failed to remmap MC AGP aperture base!'

                                further testing will be slightly delayed ;-)


                                Edit: fixed the aperture base error by setting agp aperture size from 512MB to 256MB
                                Last edited by uzi-; 12-22-2007, 10:57 AM.

                                Comment

                                Working...
                                X