Announcement

Collapse
No announcement yet.

"Ask ATI" dev thread

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Heh, don't get too down bridgman, I like your answers too

    Seems my situation is weird; I have 3d with open drivers, I want decent 2d. Before you forget about the question four pages back
    There is no support for a1 surfaces in the open drivers & EXA, and seemingly won't be for months. Does frglx support it?

    Comment


    • I think I managed to pinpoint the problem with fglrx and ubuntu 8.10. I think it has to do with mesa. Mesa 7.2 doesn't seem to work with fglrx while on my other laptop, Mesa 7.3 does work with fglrx (Fedora 10).

      Comment


      • Originally posted by bridgman View Post
        I actually like the "glass" part of the Vista UI, but haven't had time to see if there is an equivalent effect I can get on Linux.
        If you're too busy to install KDE 4.2.0, here's the "Aero" equivalent on KDE 4. This is NOT Compiz. This is just vanilla KDE 4.2 on Ubuntu 8.10:

        http://www.youtube.com/watch?v=Zg2TuYq7Oz0&fmt=18

        I upgraded to it just two days ago. The result was me going on a flame fest against fglrx. The stuff you see on the video needs NVidia drivers; fglrx craps out. Any plans to actually make Catalyst useful for compositing some day? I mean, KDE 4.2.0 has nothing to hide from Vista/Windows 7 or OS X. Right now, it's ATI's drivers that spoil the fun. And they spoil it big time.
        Last edited by RealNC; 01-31-2009, 03:10 PM.

        Comment


        • Originally posted by bridgman View Post
          Nobody ever likes my answers
          'Dear bridgman i know you are a opensource driver dev,,,but i will give you my status of the fglrx...

          kanos install skript 9.1 failt=blackscreen

          debians files 8.12 fglrx-driver-fglrx-modules-2.6.26-1-686-bigmem on the 2,6,26 kernel fails = black screen....

          9,2beta 8.58 = blackscreen

          8.581rc1 = blackscreen

          Sidux smxi install skript for the 9.1 makes a litle diverend think on the first install --> first looks good 1-2 sec and then frozen Wite mouse on black strange screen next restart its also hase a black screen...

          only 8.11 works sometimes and radeon 6.10 works and vesa works..

          Kubuntu 8.10 live cd = blackscreen (vesa works)

          Kubuntu 9.04 =works but no catalyst

          and a frend have same sidux system and the 9.1 and 8,581rc works well on sidux with the 2,6,26 debian kernel and the 2,6,28 kano kernel..

          why only 4350 users have blackscreen ???? ?

          Comment


          • Btw. as long as you xserver is old enough you can try older drivers as well. Maybe combine it with the -z option, that will not kill x immediately but will require a reboot.

            sh install-fglrx-debian.sh -zv 8-7

            but not all drivers are patched for 2.6.27+ completely, for 32 bit since 8-7, for 64 bit drivers since 8-9 could be used.

            Comment


            • Originally posted by Kano View Post
              Btw. as long as you xserver is old enough you can try older drivers as well. Maybe combine it with the -z option, that will not kill x immediately but will require a reboot.

              sh install-fglrx-debian.sh -zv 8-7

              but not all drivers are patched for 2.6.27+ completely, for 32 bit since 8-7, for 64 bit drivers since 8-9 could be used.
              the 4350 was first supportet offizialy on 8.11 in windows and 8.10 first time in linux but 8.11 regulary .

              so i can't use older catalyst than 8.10 becourse the cart is so new!

              Comment


              • Give it a try. Maybe you get an unsupported message but that would be not critical.

                Comment


                • Originally posted by Kano View Post
                  Give it a try. Maybe you get an unsupported message but that would be not critical.
                  8.7 with your metod = NO BLACKSCREEN but landing in the rootshel

                  8.8 with your metod = black screen

                  8.10 with your metod = works...

                  i think 8.11 was the first time with blackscreen boot failure sometimes 8.11 boots,..
                  8.12 = blackscreen
                  9.1 blackscreen..

                  Comment


                  • What about 8-9?

                    Comment


                    • Originally posted by Kano View Post
                      What about 8-9?
                      i dont test 8.9 becourse i think the 8.10 was the release driver for the 4350.

                      but if this will help i test 8.9 to...

                      Comment

                      Working...
                      X