Announcement

Collapse
No announcement yet.

"Ask ATI" dev thread

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by bridgman View Post
    AFAIK the Win7 driver API (WDDM 1.1) is for 6xx-and-up products only since it requires DX10 support.
    Hm, I don't think so:

    Comment


    • That slide says that the DX10 API can be used on DX9 hardware, which is true. I believe there are actually 5 levels of support within DX10, 3 for DX9 hardware and 2 for DX10 hardware.

      AFAIK the Vista-level Aero interface uses DX10L9 when running Win7 on DX9 hardware (and you can do that with a Vista driver).

      The full slide set gives some more context :

      http://download.microsoft.com/downlo...T515_WH08.pptx
      Last edited by bridgman; 03-18-2009, 05:26 PM.

      Comment


      • Sorry to make a question not 'compatible' with the above discussion but can someone tell me why i can use resolution '1440x900' at vista at 75Hz refresh rate and at Linux only at 60Hz??

        Details: I connect my Syncmaster T190 monitor via DVI at an HD 3450 card, Linux openSUSE 11.1, Xserver 1.5.2, Catalyst 9.2 installed.

        The strange fact is that amdcccle reports 75Hz as maximum refresh rate but at monitor preferences where you set resolution and refresh rate it only lets me choose 60Hz...

        Any ideas or knowledge on this??

        Comment


        • Also another one:
          Does anyone of you guys managed to set up Hybrid Crossfire at an Xorg 7.4 environment?? (always speaking for xserver 1.5.x)

          Cause at opensuse 11 with Xorg 7.3 i set up things at once but now at opensuse 11.1 which uses xserver 1.5.2 and Xorg 7.4 whenever I enable the crossfire chain my PC stops booting when loading X. Doesn't freeze, just stops booting procedure and screen remains black when it supposed to show mouse X cursor you know...

          Comment


          • And a comment for the previous discussion...

            Aero just doesn't diserve to be regarded or called a 3D compositing window manager...

            Anyone who have seen or used Compiz, KDE 4's 3D effects or even the good old Beryl understands what I mean...

            Just ignore it and use Virtualbox inside a Linux system to install win XP, if you obligatoraly need a windoze environment, and then spin it with Compiz!...
            Last edited by djdoo; 03-19-2009, 10:42 PM.

            Comment


            • Hey anyone for me guys??

              Comment


              • hybrid graphics laptops?

                Does anybody know what are the current laptops with ati powerxpress?

                The ones I've found so far are in this blog:

                http://linux-hybrid-graphics.blogspot.com/

                Lenovo ThinkPad T500 (ati)
                Lenovo ThinkPad T400 (ati)
                ASUS M51Ta (ati)
                Fujitsu-Siemens Amilo Sa 3650 (ati)
                MSI PX211 12'' (ati)
                HP Pavilion tx2500 (ati)

                Anyone?

                Comment


                • Originally posted by bridgman View Post
                  Can you post your log please ?
                  Here is the Xorg.log with latest drivers (9.3 x86_64). http://pastebin.com/f1a072609

                  Same deal, just a blank screen when you try and start X. None of the catalyst drivers have ever worked. Tried both Ubuntu and Fedora. Distro builds or from the ati-installer.

                  XP/Vista catalyst works, and so does the open source drivers, so the card should be OK.

                  AMD 4200+, Asus A8N-Sli, Visiontek HD4870, 2Gb ram, FC10 x86_64

                  Comment


                  • When UVD for Linux is gonna work?

                    And is it gonna work whenever at all?

                    Comment


                    • Help with fglrx

                      Hello all, i am new in the forum
                      i am having the following: (the screen became black)
                      "[fglrx] It's not necessary to adjust system aperture on this ASIC" each time the ac-power fail. i have to do Alt+Ctrl+F2 and Alt+F1 to get back my X-session.
                      Also if i try to log-off the laptop hangup
                      if i try to switch-user the laptop hangup

                      This is my fglrxinfo output:

                      display: :0.0 screen: 0
                      OpenGL vendor string: ATI Technologies Inc.
                      OpenGL renderer string: ATI Radeon X1200 Series
                      OpenGL version string: 2.1.8543 Release


                      this is my dmesg output:

                      fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
                      [fglrx] Maximum main memory to use for locked dma buffers: 800 MBytes.
                      [fglrx] vendor: 1002 device: 791f count: 1
                      [fglrx] ioport: bar 4, base 0x9000, size: 0x100
                      [fglrx] Kernel PAT support detected, disabling driver built-in PAT support
                      [fglrx] module loaded - fglrx 8.59.2 [Mar 13 2009] with 1 minors
                      [fglrx] GART Table is not in FRAME_BUFFER range
                      [fglrx] Firegl kernel thread PID: 3477
                      [fglrx] Gart cacheable size:436 M.
                      [fglrx] Reserved FB block: Shared offset:0, size:1000000
                      [fglrx] Reserved FB block: Unshared offset:7ffc000, size:4000
                      [fglrx] It's not necessary to adjust system aperture on this ASIC
                      [fglrx] It's not necessary to adjust system aperture on this ASIC
                      [fglrx] It's not necessary to adjust system aperture on this ASIC
                      [fglrx] It's not necessary to adjust system aperture on this ASIC


                      this is my lspci output:

                      00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
                      00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
                      00:04.0 PCI bridge: ATI Technologies Inc Device 7914
                      00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
                      00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
                      00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
                      00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
                      00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
                      00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
                      00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
                      00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
                      00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
                      00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
                      00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
                      00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
                      00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
                      00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
                      00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
                      00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
                      00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
                      00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
                      01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
                      08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
                      14:06.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
                      14:06.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
                      14:06.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
                      14:06.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)


                      if i remove the fglrx drivers i do not receive the message and everything work properly (except for the video, of course).

                      Please help!!!!.

                      Comment


                      • Now I just installed Catalyst 9.4 at my system openSUSE 11.1, Xorg 7.4, xserver 1.6.1, Radeon HD 3450, Radeon HD 3200...

                        Yep indeed xserver 1.6 works now as long as Randr 1.2 with or without Texturedxrender option load but the previous problems remain unchanged here...

                        I stil cannot enable the damn Crossfire chain to make Hybrid Crossfire work!!
                        For one more time the X freezes upon load...
                        And Xorg.0.log stops at this line:
                        CF Ribbon Cable not connect trying SW Crossfire
                        And the PC freezes for good...

                        I could enable Hybrid Crossfire with Xorg 7.3 straight away!
                        Please guys do something for that!
                        I mean is it so difficult to port Hybrid Crossfire usage for Xorg 7.4??
                        Xorg 7.3 works fine why not 7.4??

                        After being tired of PC freezes I tried enabling HD 3200 chip via the command:
                        aticonfig --adapter=all --initial
                        Then desktop really came for the first time and when you gave:
                        aticonfig --lsch
                        Showed the chain enabled and working...
                        But I was sure something wasn't correct here. I typed:
                        aticonfig --lscc
                        And it showed me that I had 2 primary adapters which is very wrong... And of course no sign of the word crossfire at Xorg.0.log file.

                        If any friend has any ideas or knowledge on this I will be glad to hear anything!
                        Last edited by djdoo; 04-18-2009, 10:46 PM.

                        Comment


                        • Oh and something else... I am trying to help people back in Compiz forum to understand the way fglrx now works and communicates with amdpcsdb via aticonfig tool and how to make a better setup for their composited environments...
                          I just do my best there informing our users by watching the news at Phoronix and from my experience with the various driver versions also.

                          That's the thread's link http://forum.compiz-fusion.org/showthread.php?t=6794 and it has become way more popular than I expected it would be in the first place when I created it and a little bit of more official help would be very apreciatted by all of us Compiz community
                          I cannot answer everything only with my experience...
                          If there is any interest from AMD for these stuff just PM me or post here.

                          Best Regards
                          Jim
                          Last edited by djdoo; 04-18-2009, 11:07 PM.

                          Comment


                          • Only 76 pages...

                            Comment


                            • Is there any use in reporting bugs here http://ati.cchtml.com/show_bug.cgi?id=733

                              Comment


                              • Hello there !

                                I am total noob and extremly exited about Ubuntu. I have very powerfull card installed on my system 4870x2 and looks like I am having problems with it.

                                After installation on Ubuntu I got informed that proprietary drivers are available for my ATI video card and I clicked okay for download and install. After restart right on moment when I would see desktop I see messed up screen and looks like system, freeze too. After that I format hard drive and install Ubuntu again and decided to download drivers from AMD web site. ati-driver-installer-9-4-x86.x86_64.run Installed it via very nice GUI and after reboot EXACTLY same thing happened. I mean even screen looked exactly messed up like before, you know sometimes it get messed up totally randomly ? No this one is same as before. Guys please help me out here I don't know what to do, I also tried to download 9.2 drivers but on install it saying that this version on Ubuntu not supported by 9.2 (something like that)

                                Here is my system specs I hope you can help out. Right now I am in Ubuntu with no ATI stuff installed I did reformat hdd again cause I could not login again because of messed up screen.


                                Mobo: Asus P6T Deluxe
                                CPU: i7 920
                                RAM: GSkill 1333 3x2gb sticks 6gb total
                                Video: Asus 4870x2 TRI_FAN design
                                Monitor: 24' ASUS 1920x1080
                                PSU: Antex-1000 w1000

                                I really down know what else to mention all I know is I think If I can remember at some point of time I had Ubuntu few versions before and it worked fine with my card. Again I "THINK". I hope guys you can help.

                                Thank you very much in advanced !

                                Comment

                                Working...
                                X