Announcement

Collapse
No announcement yet.

"Ask ATI" dev thread

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Shockwave Flash

    File name: npwrapper.libflashplayer.so
    Shockwave Flash 9.0 r124

    MIME Type Description Suffixes Enabled
    application/x-shockwave-flash Shockwave Flash swf Yes
    application/futuresplash FutureSplash Player spl Yes

    EVERYTHING IS BY DEFAULT. The problem persists in openSuSE, Mandriva, Fedora, Ubuntu, Mint... I've tried them all. One by One.

    Comment


    • There is a lot of flickering, while i'm playing video files (in all players - VLC, Xine, MPlayer) or flash clips in firefox (YouTube - Broadcast Yourself, for example).
      It makes no difference, if i'm using the opensource ATI driver - radeonhd or the propriety driver - fglrx (i've tested the whole version tree from 8.33 to 8.542).

      Compiz Fusion Manager is disabled.

      This is my original 'xorg.conf' file (openSuSE 11.0):
      .................................................. ..............

      Section "Files"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
      FontPath "/usr/share/fonts/misc:unscaled"
      FontPath "/usr/share/fonts/75dpi:unscaled"
      FontPath "/usr/share/fonts/100dpi:unscaled"
      FontPath "/usr/share/fonts/Type1"
      FontPath "/usr/share/fonts/URW"
      FontPath "/usr/share/fonts/Speedo"
      FontPath "/usr/share/fonts/cyrillic"
      FontPath "/usr/share/fonts/truetype"
      FontPath "/opt/kde3/share/fonts"
      FontPath "/usr/local/share/fonts"
      EndSection

      Section "ServerFlags"
      Option "AllowMouseOpenFail" "on"
      Option "ZapWarning" "on"
      EndSection

      Section "Module"
      Load "dbe"
      Load "type1"
      Load "freetype"
      Load "extmod"
      Load "glx"
      EndSection

      Section "InputDevice"
      Driver "kbd"
      Identifier "Keyboard[0]"
      Option "Protocol" "Standard"
      Option "XkbLayout" "us"
      Option "XkbModel" "microsoftpro"
      Option "XkbRules" "xfree86"
      EndSection


      Section "InputDevice"
      Driver "mouse"
      Identifier "Mouse[1]"
      Option "Buttons" "12"
      Option "Device" "/dev/input/mice"
      Option "Name" "Logitech USB Optical Mouse"
      Option "Protocol" "explorerps/2"
      Option "Vendor" "Sysp"
      Option "ZAxisMapping" "4 5"
      EndSection

      Section "InputDevice"
      Driver "synaptics"
      Identifier "Mouse[3]"
      Option "Buttons" "5"
      Option "Device" "/dev/input/mice"
      Option "Emulate3Buttons" "on"
      Option "HorizScrollDelta" "0"
      Option "InputFashion" "Mouse"
      Option "Name" "Synaptics;Touchpad"
      Option "Protocol" "explorerps/2"
      Option "SHMConfig" "on"
      Option "Vendor" "Sysp"
      Option "ZAxisMapping" "4 5"
      EndSection


      Section "Monitor"
      DisplaySize 367 230
      HorizSync 30-82
      Identifier "Monitor[0]"
      ModelName "LGPHILIPSLCD LCD MONITOR"
      Option "DPMS"
      Option "PreferredMode" "1680x1050"
      VendorName "LPL"
      VertRefresh 43-60
      UseModes "Modes[0]"
      EndSection


      Section "Modes"
      Identifier "Modes[0]"
      Modeline "1680x1050" 147.14 1680 1784 1968 2256 1050 1051 1054 1087
      Modeline "1680x1050" 117.00 1680 1728 1760 1840 1050 1053 1059 1080 +HSync -Vsync
      EndSection


      Section "Screen"
      DefaultDepth 24
      SubSection "Display"
      Depth 15
      Modes "1680x1050"
      EndSubSection
      SubSection "Display"
      Depth 16
      Modes "1680x1050"
      EndSubSection
      SubSection "Display"
      Depth 24
      Modes "1680x1050"
      EndSubSection
      SubSection "Display"
      Depth 8
      Modes "1680x1050"
      EndSubSection
      Device "Device[0]"
      Identifier "Screen[0]"
      Monitor "Monitor[0]"
      EndSection


      Section "Device"
      BoardName "Mobility Radeon X1600"
      BusID "1:0:0"
      Driver "radeonhd"
      Identifier "Device[0]"
      Option "monitor-PANEL" "Monitor[0]"
      VendorName "ATI"
      EndSection



      Section "ServerLayout"
      Identifier "Layout[all]"
      InputDevice "Keyboard[0]" "CoreKeyboard"
      InputDevice "Mouse[1]" "CorePointer"
      InputDevice "Mouse[3]" "SendCoreEvents"
      Option "Clone" "off"
      Option "Xinerama" "off"
      Screen "Screen[0]"
      EndSection


      Section "DRI"
      Group "video"
      Mode 0660
      EndSection

      Section "Extensions"
      EndSection
      .................................................. ..............



      I've also tried some tweaking in the 'xorg.file' (when ATI FGLRX driver is enabled) like:
      Option "TexturedVideo" "off"
      Option "VideoOverlay" "on/off"
      Option "OpenGLOverlay" "off"
      Option "XvmcUsesTextures" "True"
      Section "Device"
      Identifier "Device[0]"
      Driver "radeon"
      BusID "PCI:1:0:0"
      Option "XAANoOffscreenPixmaps" "True"
      Option "AGPMode" "8"
      Option "AccelMethod" "XAA"
      Option "ColorTiling" "On"
      # Option "AccelDFS" "True"
      # This can speed up movie playback but can in rare cases case instability
      # Option "DMAForXv" "True"
      # Option "GARTSize" "512"
      Option "RenderAccel" "True"
      Option "VGAAccess" "True"
      Option "BusType" "AGP"
      EndSection

      Section "Device"
      Identifier "Device[1]"
      Driver "fglrx"
      BusID "PCI:1:0:0"
      Option "UseFastTLS" "2"
      EndSection

      Section "Extensions"
      Option "Composite" "Disable"
      EndSection
      ...
      ........
      No difference !

      Any suggestions !?!
      Or it's an ATI driver issue.
      Last edited by Xtigyro; 11-10-2008, 06:57 AM.

      Comment


      • Originally posted by Xtigyro View Post
        Shockwave Flash

        File name: npwrapper.libflashplayer.so
        Shockwave Flash 9.0 r124

        MIME Type Description Suffixes Enabled
        application/x-shockwave-flash Shockwave Flash swf Yes
        application/futuresplash FutureSplash Player spl Yes

        EVERYTHING IS BY DEFAULT. The problem persists in openSuSE, Mandriva, Fedora, Ubuntu, Mint... I've tried them all. One by One.
        * net-www/netscape-flash
        Latest version available: 10.0.12.36-r1
        Latest version installed: 10.0.12.36-r1

        and I don't see flickering on youtube. I do see flickering with tvtime (which needs xv) and xine (but flickering is gone when I use xshm instead of xv).

        Comment


        • Yes, XV, yes. You say "XV Enabled" and now "flickering is gone when use xshm instead of xv". COOL.

          I wanna ask you, DO YOU NOTICE ANY DIFFERENCE IN QUALITY (the poor quality) when playing video files with xshm driver output enabled (even if there isn't really so much flickering, I ADMIT) ?

          Comment


          • ok, slow:
            with desktop effects enabled:
            flash is perfectly fine
            xine and tvtime using xv are flickering
            xine using xshm is fine.

            with desktop effects disabled:
            flash is perfectly fine
            xine and tvtime using xv are flicker free
            xine using xshm is fine.

            If there are differences in the quality they are small enough that I don't recognize them.
            With kde 4.X it is easy, just a single click to turn effects on/off. So most of the time I have effects on, and only if I want watching tv with tvtime I turn them off. I watch tv once a week .... I watch youtube every day - and no flickering there.

            Comment


            • With so much self-confidence and no real questions and answers... The fglrx driver (AMD.ATI DRIVER) ISSUES are going to last for a very very long time.
              Look at these snapshots. Relax. And take your time. I know there is no problem. Just be positive and everything gonna be alright.

              http://i264.photobucket.com/albums/i...yro/xshm-1.png
              http://i264.photobucket.com/albums/i...Igyro/xv-1.png
              http://i264.photobucket.com/albums/i...ro/xshm1-1.png
              http://i264.photobucket.com/albums/i...gyro/xv1-1.png

              All snapshots were taken "with desktop effects disabled".
              Last edited by Xtigyro; 11-10-2008, 09:34 AM.

              Comment


              • and of course you compare the exact same frame, do you?
                in everyday video watching, the differences are small enough, not to bother me. And flash simply works perfectly. Just upgrade to a non-broken version.

                Comment


                • No, it's not the exact same frame... +/- 0.100 sec.
                  And even with xshm driver output, there is still flickering (not so much, but it's there).

                  The difference in picture quality is absolutely obvious. And there are 41 pages with other users, which are capable of seeing it.
                  Last edited by Xtigyro; 11-10-2008, 09:57 AM.

                  Comment


                  • it might be obvious when you put them next to each other or comparing screen shots, but in normal usage?

                    and hey, is it really so bad to turn of effects while watching a video? If you are watching so closely that shm's degradion becomes prominent, desktop effects are either not needed or just very disturbing.

                    Comment


                    • As I said... With so much self-confidence and no real questions and answers... Just "(re)read" post #406 TO THE END, pls.

                      No more off-topic posts.

                      Comment

                      Working...
                      X