Announcement

Collapse
No announcement yet.

AMD Catalyst 7.11 Linux Driver

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by Kano View Post
    @sabriah

    The script does more than you might have thought, you do not need single user mode, it kills kdm/gdm or whatever, uninstalls previous driver, installs new one and patches xorg.conf. After that X is started again. The commands I told you are just to delete the driver if you do not want to use fglrx at all.
    Possibly, but I couldn't install it from a Gnome-Terminal. There was a complaint that X interfered, or something, so I rebooted.

    Comment


    • #92
      I'm a FireGL v5200 card owner

      and I am _very_ disappointed with this release.

      I'll have to wait for the December release but I'm afraid ATI/AMD will continue to ignore the FireGL userbase...

      Comment


      • #93
        It suggests to press ctrl+alt+f1, if that does not work:

        chvt 1

        as root.

        Comment


        • #94
          Originally posted by Kano View Post
          It suggests to press ctrl+alt+f1, if that does not work:

          chvt 1

          as root.
          True, but I didn't get to chvt 1 step. I'm not sure what might be wrong with my setup, I often get messages about "hdb" and "hdc" are not ready yet (yes I do know two of my cdroms are broken, but...). Still, that stalled the installation, so I rebooted.

          I run XFS, which might be extra sensitive to faulty hw?

          Comment


          • #95
            Only had a few mins to try, but with the pci_id hack, the 7.11 driver appears to work under RHEL5.1.
            with a FireGL V5250

            No Beryl/AIGLX tried yet, but suspend/resume works -- an improvement on 8.42. GLXgears looks ok.

            Did have to add a DRI section with 0666 permissions into xorg.conf

            Lost hotkeys.. but they were redhat specific.

            Will try using "as normal" tomorrow to see if stable enough for the day job before experimenting with 3D etc.

            Comment


            • #96
              Hmm my Xorg Server still hard freezes / crashes (same with 8.42.3) upon resuming from suspend. I have a FireGL V5200, so I don't think there's a big difference.

              All I really want is working suspend and resume! Arggg

              Comment


              • #97
                My first Post

                The main two questions I have are.

                1. Are they even aware of the bugs that exist in their drivers?
                2. Can they make a special release to address bug fixes that doesn't require the two month additional testing?

                Is AMD a good company to work for?, I would like to apply for a job and help develop their fglrx drivers.

                Comment


                • #98
                  Hi,

                  Have anyone noticed that when TV-out is enabled the refresh rate goes down to 60HZ only with this new driver or it's just happening with me?


                  Thanks,
                  Trek1701

                  Comment


                  • #99
                    does this fix the slow scrolling in firefox issue?

                    Comment


                    • Why Phoronix is all the time advertising these drivers with such emphasis? All the time I read words such as "great" "the drivers had a long run" etc etc followed by hate comments.

                      A bit comical, isn't it?

                      I decided to change my ATI-based laptop a few weeks ago with an X3100 based one. True, bugs are there due also to the newness of the 965G chipset, but at least I can pull out new releases from git almost every week seeing that bugs reported to freedesktop.org get *really* fixed.

                      There's no reason to keep an AMD/ATI card. One of the biggest hardware companies is behaving like they don't have enough money to spend on decent developers.. hard to believe but true.
                      Last edited by lionheart; 11-23-2007, 03:33 AM.

                      Comment


                      • Originally posted by planetf1 View Post
                        Only had a few mins to try, but with the pci_id hack, the 7.11 driver appears to work under RHEL5.1.
                        with a FireGL V5250
                        In an hour or so I've decided this driver is not good.

                        I am unable to drive a secondary screen at the correct resolution with this driver - worked fine under 8.35 which I've reverted to & is still the best (for me)

                        Disappointing, yet another month. Next time I think I'll look for an nvidia laptop ..

                        Comment


                        • Hi,
                          I've got a mainboard with 690G/SB600. With all the drivers from ATI following is not working:
                          - XV (tvtime does not start).
                          - When I start xawtv the screen turns black. Changing to console and back to X "resolves" this issue.
                          - AIGLX is turned on (Xorg.0.log), but compiz doesn't recognize the GLEXT_texture_from_pixmap.

                          Does anybody know if XV and maybe compiz will work in the next (7.12?) release?
                          Especially missing XV is a crap.

                          Comment


                          • So... fglrx still officially sucks!

                            Message from a "proud"?! ATi customer

                            Oh, btw, what is this release name? "cat *.h | sed s/8.42/8.43" would be great }:>

                            Comment


                            • Originally posted by mrb74 View Post
                              Does anybody know if XV and maybe compiz will work in the next (7.12?) release?
                              if u get a nividia card it will work even with one recently released

                              Comment


                              • i don't understand why to me this driver doesn't give problems....
                                i have an x200m which works better and better with every release, a radeon 9550 256 which works flawlessly, a x1000 which works without problems and a hd2600pro which works out of the box.
                                all of them work without problems and i really can't understand why the people aren't able to use the drivers and always go blaming on the driver.
                                this things should have happened to me too.... but i don't have really relevant problems with gentoo and opensuse 10.3 when installing and using them.
                                i can also compile and use suspend with both slub and slab and with 2.6.24-r releases (but it works only once refusing to go on suspend/hibernate the second time that you chose the same option).
                                on this forum the people just complains about various problems but i don't really experience them and that makes me wonder this question:
                                are you really sure that these issues are driver dependent and not distro dependent?!

                                Comment

                                Working...
                                X