Announcement

Collapse
No announcement yet.

AMD Catalyst 7.11 Linux Driver

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Given all the fuss about the new drivers totally sucking, I thought it'd be nice to contribute with my (positive) experience.
    Yesterday I installed version 7.11 (up from 8.37.6) on an old rig with a Radeon 9600SE, and everything went just fine. 3D performance is up a notch, AIGLX works (albeit slowly) and Xvideo performance is on par with that of the open "radeon" driver from Xorg. I haven't noticed any obvious leaks at all; memory usage is steady even when running intensive 3D apps.
    It may have something to do with this card being just an old r300, but at least it seems to work fine on it, and in my experience this is ATI's best driver to date. I guess my only real complaint is subpar performance with AIGLX and Compiz, but I can wait a bit more
    I should probably test the driver with my X850 as well, things might be different with it, but my hopes are high

    Comment


    • Originally posted by Pseus View Post
      I should probably test the driver with my X850 as well, things might be different with it, but my hopes are high
      I would love you to let me know the results. Anf I would also love to have a look at your xorg.conf since x800 and x850 are same generation cards.

      Comment


      • Memory Leaks are only present with a certain family of cards. My X1400M are one of them

        Comment


        • My X1950XTX (R580+) is another

          Comment


          • Works for me.

            I'd also like to add my own positive 2 cents. I have a Gigabyte GA-MA69GM-S2H with integrated RS690 X1250 graphics. The 8.42.3 driver wouldn't do TV out, but the 7.11 driver does. Essential for an HTPC.

            Comment


            • Well I finally installed the driver, I didn't install it before because I wasn't very impressed with those release notes, but everything works. Besides some slowdowns in 3d applications in certain situations for odd reasons. This also existed in the previous driver. But besides that, the driver works well for me.

              I just hope the 7.12 driver is the real deal. This driver will hold me over until then.

              Comment


              • Originally posted by Nevohteeb View Post
                I would love you to let me know the results. Anf I would also love to have a look at your xorg.conf since x800 and x850 are same generation cards.
                Sure. Here are my premature test results:

                AIGLX is usable. You won't be able to watch videos with Compiz running as there's a lot of flickering either with XVideo or TexturedVideo. OTOH, OpenGLOverlay causes serious corruption when launching 3D apps, so it's out of question too.
                To watch videos the best option right now is to temporarily disable Compiz and keep VideoOverlay on while disabling both OpenGLOverlay AND TexturedVideo.

                Compiz performance is acceptable, but not entirely smooth (big animations tend to choke a bit depending on the underlying CPU load), but seems close to the "radeon" driver. Scrolling is acceptable.

                Also, with Compiz enabled, some 3D apps seem to flicker, so it's probably wise to temporarily disable it before launching them as well.

                One positive thing I've noticed is that it is now possible to kill the X server and relaunch it without completely locking up the machine (might be alone on that one, but it's always been a problem on this rig). It's easier now to try new settings

                Last but not least, it seems the fan is always running at top speed, so it gets a bit noisier.

                As requested. this is my xorg.conf for the X850 running on Gutsy x86_64. In fact, as I'm a bit lazy, it is the one generated by the Envy install script, which is what I'm using:

                Code:
                # xorg.conf (xorg X Window System server configuration file)
                #
                # This file was generated by dexconf, the Debian X Configuration tool, using
                # values from the debconf database.
                #
                # Edit this file with caution, and see the xorg.conf manual page.
                # (Type "man xorg.conf" at the shell prompt.)
                #
                # This file is automatically updated on xserver-xorg package upgrades *only*
                # if it has not been modified since the last upgrade of the xserver-xorg
                # package.
                #
                # If you have edited this file but would like it to be automatically updated
                # again, run the following command:
                #   sudo dpkg-reconfigure -phigh xserver-xorg
                
                Section "Files"
                EndSection
                
                Section "InputDevice"
                	Identifier	"Generic Keyboard"
                	Driver		"kbd"
                	Option		"CoreKeyboard"
                	Option		"XkbRules"	"xorg"
                	Option		"XkbModel"	"pc105"
                	Option		"XkbLayout"	"es"
                	Option		"XkbOptions"	"lv3:ralt_switch"
                EndSection
                
                Section "InputDevice"
                	Identifier	"Configured Mouse"
                	Driver		"mouse"
                	Option		"CorePointer"
                	Option		"Device"		"/dev/input/mice"
                	Option		"Protocol"		"ImPS/2"
                	Option		"ZAxisMapping"		"4 5"
                	Option		"Emulate3Buttons"	"true"
                EndSection
                
                Section "InputDevice"
                	Driver		"wacom"
                	Identifier	"stylus"
                	Option		"Device"	"/dev/input/wacom"
                	Option		"Type"		"stylus"
                	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
                EndSection
                
                Section "InputDevice"
                	Driver		"wacom"
                	Identifier	"eraser"
                	Option		"Device"	"/dev/input/wacom"
                	Option		"Type"		"eraser"
                	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
                EndSection
                
                Section "InputDevice"
                	Driver		"wacom"
                	Identifier	"cursor"
                	Option		"Device"	"/dev/input/wacom"
                	Option		"Type"		"cursor"
                	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
                EndSection
                
                Section "Device"
                	Identifier	"ATI Technologies Inc R480 [Radeon X850Pro]"
                	Driver		"fglrx"
                	BusID		"PCI:1:0:0"
                	Option		"VideoOverlay"	"on"
                	Option		"OpenGLOverlay"	"off"
                #	Option		"TexturedVideo" "on"
                EndSection
                
                Section "Monitor"
                	Identifier	"Generic Monitor"
                	Option		"DPMS"
                	HorizSync	28-64
                	VertRefresh	43-60
                EndSection
                
                Section "Screen"
                	Identifier	"Default Screen"
                	Device		"ATI Technologies Inc R480 [Radeon X850Pro]"
                	Monitor		"Generic Monitor"
                	DefaultDepth	24
                	SubSection "Display"
                		Modes		"1280x1024"
                	EndSubSection
                EndSection
                
                Section "ServerLayout"
                	Identifier	"Default Layout"
                	Screen		"Default Screen"
                	InputDevice	"Generic Keyboard"
                	InputDevice	"Configured Mouse"
                
                # Uncomment if you have a wacom tablet
                #	InputDevice     "stylus"	"SendCoreEvents"
                #	InputDevice     "cursor"	"SendCoreEvents"
                #	InputDevice     "eraser"	"SendCoreEvents"
                EndSection
                
                Section "Extensions"
                	Option		"Composite"	"Enable"
                EndSection

                Other than the stuff noted above, everything runs fine. I have not tested VIVO at all. Ah, no leaks at all.
                Last edited by Pseus; 12-02-2007, 06:25 PM. Reason: Make stuff clearer + AH!

                Comment


                • it's worth choosing the right distro for this...

                  A few weeks ago I kicked fedora7 x86_64 out from my nx6325 lappy, and installed debian x86_64(I really-really should've done this earlier), and tried this version of the driver on it. Well, mixed results:

                  Things that started to work out-of-the-box (and they didn't work on fedora):
                  - suspend: finally, it works. And it works nice, altough once I had a weird issue after resuming, the swap space was consumed very-very fast, swapoff did reverse the effect, but even after that the kswapd was trying really hard to do that nothing that it did, in the end I had to reboot the whole thing. Since I never had such thing happen while using the xorg driver, I'm assuming it was the fglrx that did it, but I can't know for sure.
                  - switching back and forth from/to console and X: doesn't crash the system
                  - packaging to deb: works. 8.42.3 couldn't create the rpms for 64bit fedora...

                  And now the things that still need fixing:
                  - memleak: 2 days up, and about 1GB of memory misteriously gets lost...
                  - some artifacts in the lower right corner start to appear after a while, switching back to console, and then back to X solves it for a while.
                  - some 3d applications throw segfaults
                  - the brighness hotkeys still don't work (although it can be fixed with switching to console, adjusting there, and then back to X, but still)
                  - mplayer with x11 output can't resize the playback (something that works with the plain-old xorg driver, and it works nicely).
                  - mplayer with gl output sortof fixes the resizing problem, but has performance issues with dvds for example.
                  - flickering of terminal windows when I resize them.

                  So in the end if one wants to get this driver to work out of the box, one needs to pick the distro carefully. After using fedora/redhat for more then 7 years, a quick peek into debian made me realize: fedora is a toy, and it's not worth the pain.

                  And for a couple of days I actually thought that this version of fglrx can be used for everyday use. The most important things for me were working, but then I noticed the memleak... So I ended up switching back to the xorg driver for everyday use. Fglrx still needs a lot of improvements and fixes.

                  Comment


                  • excuse me, does anybody know what should I write in xorg.conf to make my mobility radeon x2300 on laptop use 256 mb of memory in place of 128 mb.

                    And wich options should I set to enable/disable doublebuffering/tripplebuffering.

                    It would be great if somebody will help...

                    Comment


                    • For all the friends out there having troubles with AIGLX performance and Video performance under Compiz-Fusion with Catalyst 7.11 or 8.42

                      Under your "Device" Section at your xorg.conf add the following 2 options:

                      Option "BackingStore" "True"
                      Option "XAANoOffscreenPixmaps" "True"

                      And you will feel the difference!

                      About video now and 3D games I can only help you when you go fullscreen.
                      At CCSM->General options-> enable the option that sais Unredirect Fullscreen Windows.
                      And you will see no video flickering anymore and 3D perf will be back to normal rates. ONLY WATCH OUT with that option cause in some 3D games mouse pointer will be NOT usable anymore!! RACER works fine though...

                      Hope I helped a bit...

                      PS: Scrolling will be still slow but everything else will be really smooth.
                      Last edited by djdoo; 12-04-2007, 09:01 PM.

                      Comment


                      • Hello everyone,

                        Catalyst 7.11 entered the Debien Testing repo today so I installed them with the debian way (apt-get and module -assistant).

                        First issue : command fgl_glxgears gives the following error :
                        Code:
                        Using GLX_SGIX_pbuffer
                        X Error of failed request:  GLXUnsupportedPrivateRequest
                          Major opcode of failed request:  143 (GLX)
                          Minor opcode of failed request:  16 (X_GLXVendorPrivate)
                          Serial number of failed request:  41
                          Current serial number in output stream:  42
                        Command glxgears gives no error tho, but performances are same than before (drivers 8.40)

                        Moreover I'm unable to launch World of Warcraft. It gives me the following message :
                        Code:
                        Your 3D accelerator card is not supported by WoW. Please install a 3D accelerator with dual-TMU support
                        After some google search about that message, it seems that WoW thinks my card is too old for that game. The weird part is that I had no problem with the previous drivers, weak performances excepted of course

                        Moreover, grep WW /var/log/xorg.0.log gives the following warnings :
                        Code:
                        (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
                        (WW) fglrx(0): Only one display is connnected,so single mode is enabled
                        (WW) AIGLX: 3D driver claims to not support visual 0x23
                        (WW) AIGLX: 3D driver claims to not support visual 0x24
                        (WW) AIGLX: 3D driver claims to not support visual 0x25
                        (WW) AIGLX: 3D driver claims to not support visual 0x26
                        (WW) AIGLX: 3D driver claims to not support visual 0x27
                        (WW) AIGLX: 3D driver claims to not support visual 0x28
                        (WW) AIGLX: 3D driver claims to not support visual 0x29
                        (WW) AIGLX: 3D driver claims to not support visual 0x2a
                        (WW) AIGLX: 3D driver claims to not support visual 0x2b
                        (WW) AIGLX: 3D driver claims to not support visual 0x2c
                        (WW) AIGLX: 3D driver claims to not support visual 0x2d
                        (WW) AIGLX: 3D driver claims to not support visual 0x2e
                        (WW) AIGLX: 3D driver claims to not support visual 0x2f
                        (WW) AIGLX: 3D driver claims to not support visual 0x30
                        (WW) AIGLX: 3D driver claims to not support visual 0x31
                        (WW) AIGLX: 3D driver claims to not support visual 0x32
                        (WW) AIGLX: 3D driver claims to not support visual 0x33
                        (WW) AIGLX: 3D driver claims to not support visual 0x34
                        (WW) AIGLX: 3D driver claims to not support visual 0x35
                        (WW) AIGLX: 3D driver claims to not support visual 0x36
                        (WW) AIGLX: 3D driver claims to not support visual 0x37
                        (WW) AIGLX: 3D driver claims to not support visual 0x38
                        (WW) AIGLX: 3D driver claims to not support visual 0x39
                        (WW) AIGLX: 3D driver claims to not support visual 0x3a
                        (WW) AIGLX: 3D driver claims to not support visual 0x3b
                        (WW) AIGLX: 3D driver claims to not support visual 0x3c
                        (WW) AIGLX: 3D driver claims to not support visual 0x3d
                        (WW) AIGLX: 3D driver claims to not support visual 0x3e
                        (WW) AIGLX: 3D driver claims to not support visual 0x3f
                        (WW) AIGLX: 3D driver claims to not support visual 0x40
                        (WW) AIGLX: 3D driver claims to not support visual 0x41
                        (WW) AIGLX: 3D driver claims to not support visual 0x42
                        (WW) AIGLX: 3D driver claims to not support visual 0x43
                        (WW) AIGLX: 3D driver claims to not support visual 0x44
                        (WW) AIGLX: 3D driver claims to not support visual 0x45
                        (WW) AIGLX: 3D driver claims to not support visual 0x46
                        (WW) AIGLX: 3D driver claims to not support visual 0x47
                        (WW) AIGLX: 3D driver claims to not support visual 0x48
                        (WW) AIGLX: 3D driver claims to not support visual 0x49
                        (WW) AIGLX: 3D driver claims to not support visual 0x4a
                        (WW) AIGLX: 3D driver claims to not support visual 0x4b
                        (WW) AIGLX: 3D driver claims to not support visual 0x4c
                        (WW) AIGLX: 3D driver claims to not support visual 0x4d
                        (WW) AIGLX: 3D driver claims to not support visual 0x4e
                        (WW) AIGLX: 3D driver claims to not support visual 0x4f
                        (WW) AIGLX: 3D driver claims to not support visual 0x50
                        (WW) AIGLX: 3D driver claims to not support visual 0x51
                        (WW) AIGLX: 3D driver claims to not support visual 0x52
                        (WW) AIGLX: 3D driver claims to not support visual 0x53
                        (WW) AIGLX: 3D driver claims to not support visual 0x54
                        (WW) AIGLX: 3D driver claims to not support visual 0x55
                        (WW) AIGLX: 3D driver claims to not support visual 0x56
                        (WW) AIGLX: 3D driver claims to not support visual 0x57
                        (WW) AIGLX: 3D driver claims to not support visual 0x58
                        (WW) AIGLX: 3D driver claims to not support visual 0x59
                        (WW) AIGLX: 3D driver claims to not support visual 0x5a
                        (WW) AIGLX: 3D driver claims to not support visual 0x5b
                        (WW) AIGLX: 3D driver claims to not support visual 0x5c
                        (WW) AIGLX: 3D driver claims to not support visual 0x5d
                        (WW) AIGLX: 3D driver claims to not support visual 0x5e
                        (WW) AIGLX: 3D driver claims to not support visual 0x5f
                        (WW) AIGLX: 3D driver claims to not support visual 0x60
                        (WW) AIGLX: 3D driver claims to not support visual 0x61
                        (WW) AIGLX: 3D driver claims to not support visual 0x62
                        (WW) AIGLX: 3D driver claims to not support visual 0x63
                        (WW) AIGLX: 3D driver claims to not support visual 0x64
                        (WW) AIGLX: 3D driver claims to not support visual 0x65
                        (WW) AIGLX: 3D driver claims to not support visual 0x66
                        (WW) AIGLX: 3D driver claims to not support visual 0x67
                        (WW) AIGLX: 3D driver claims to not support visual 0x68
                        (WW) AIGLX: 3D driver claims to not support visual 0x69
                        (WW) AIGLX: 3D driver claims to not support visual 0x6a
                        (WW) AIGLX: 3D driver claims to not support visual 0x6b
                        (WW) AIGLX: 3D driver claims to not support visual 0x6c
                        (WW) AIGLX: 3D driver claims to not support visual 0x6d
                        (WW) AIGLX: 3D driver claims to not support visual 0x6e
                        (WW) AIGLX: 3D driver claims to not support visual 0x6f
                        (WW) AIGLX: 3D driver claims to not support visual 0x70
                        (WW) AIGLX: 3D driver claims to not support visual 0x71
                        (WW) AIGLX: 3D driver claims to not support visual 0x72
                        Here's my xorg.conf that I generated with dpkg-reconfigure xserver-xorg :
                        Code:
                        # xorg.conf (xorg X Window System server configuration file)
                        #
                        # This file was generated by dexconf, the Debian X Configuration tool, using
                        # values from the debconf database.
                        #
                        # Edit this file with caution, and see the xorg.conf manual page.
                        # (Type "man xorg.conf" at the shell prompt.)
                        #
                        # This file is automatically updated on xserver-xorg package upgrades *only*
                        # if it has not been modified since the last upgrade of the xserver-xorg
                        # package.
                        #
                        # If you have edited this file but would like it to be automatically updated
                        # again, run the following command:
                        #   sudo dpkg-reconfigure -phigh xserver-xorg
                        
                        Section "Files"
                        EndSection
                        
                        Section "Module"
                        	Load "dbe"
                        EndSection
                        
                        Section "InputDevice"
                        	Identifier	"Generic Keyboard"
                        	Driver		"kbd"
                        	Option		"CoreKeyboard"
                        	Option		"XkbRules"	"xorg"
                        	Option		"XkbModel"	"pc105"
                        	Option		"XkbLayout"	"fr"
                        	Option		"XkbVariant"	"latin9"
                        EndSection
                        
                        Section "InputDevice"
                        	Identifier	"Configured Mouse"
                        	Driver		"mouse"
                        	Option		"CorePointer"
                        	Option		"Device"		"/dev/input/mice"
                        	Option		"Protocol"		"ImPS/2"
                        EndSection
                        
                        Section "Device"
                        	Identifier	"ATI RADEON X800pro"
                        	Driver		"fglrx"
                        	BusID		"PCI:1:0:0"
                        	Option   "XAANoOffscreenPixmaps"   "true"
                        EndSection
                        
                        Section "Monitor"
                        	Identifier	"Samsung 913N"
                        	Option		"DPMS"
                        	HorizSync	30-81
                        	VertRefresh	56-75
                        EndSection
                        
                        Section "Screen"
                        	Identifier	"Default Screen"
                        	Device		"ATI RADEON X800pro"
                        	Monitor		"Samsung 913N"
                        	DefaultDepth	24
                        	SubSection "Display"
                        		Modes		"1280x1024" "1024x768"
                        	EndSubSection
                        EndSection
                        
                        Section "ServerLayout"
                        	Identifier	"Default Layout"
                        	Screen		"Default Screen"
                        	InputDevice	"Generic Keyboard"
                        	InputDevice	"Configured Mouse"
                        EndSection
                        
                        Section "Extensions"
                        	Option		"Composite"	"Enable"
                        EndSection
                        I actually don't see what's wrong in it. Does someone see?
                        Last edited by Nevohteeb; 12-04-2007, 11:37 AM.

                        Comment


                        • Moreover, grep WW /var/log/xorg.0.log gives the following warnings
                          Those warnings seem normal under fglrx. The first warning (Device section missing for PCI:X:X:X) is related to the second. It's just there to tell you the "Device" section for a secondary display is missing. It's harmless. The AIGLX warnings seem usual with ATI cards as well. I think I've seen them with the open driver as well, but I don't exactly remember right now.

                          First issue : command fgl_glxgears gives the following error
                          I'm not able to reproduce this error on Gutsy. It might be related to a new version of the X server or some kind of misconfiguration. I do remember those kind of warnings where typical under Kubuntu Feisty (though the opcodes where different).

                          djdoo, I'll try your suggestions and report back. They seem promising

                          Comment


                          • @Nevohteeb:

                            Under your "Modules" Section at your xorg.conf add these 2:

                            Load "dri"
                            Load "glx"

                            Also Make a "DRI" Section like this:

                            Section "DRI"
                            Group "video"
                            Mode 0666
                            EndSection

                            Then restart X server->Ctrl+Alt+Backspace

                            Comment


                            • djdoo, I had the lines you mentioned, but I still have the same warnings in /var/log/Xorg.0.log. But like Pseus said, they are kinda usual warnings with those drivers.

                              On the other hand, fgl_glxgears still crashes with same error message. It seems to be a diversion pb linked to the LibGL library. It seems that the diversion of that library hasn"t been properly done when I installed the fglrx-driver package.

                              Comment


                              • OK then do this:

                                As root type in a terminal /usr/share/ati/fglrx-uninstall.sh

                                And after that just reinstall the driver. Then reboot and tell us what happened...
                                Don't forget to re-edit your xorg.conf after that... Or save your old one and replace the new autogenerated.

                                Comment

                                Working...
                                X