No announcement yet.

Radeon 9600 performance, driver issue?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon 9600 performance, driver issue?


    I'm pretty new to Linux, so sorry if this is a stupid question, but...
    I'm running Fedora 6.

    After going through alot of what was written here on the forums to finally be able to run the "" file and create rpm's, I succeded with that and thought it would be downhill from there... guess not.

    It made me 3 rpm's:

    Installed those 3 with "rpm -i etc.." and rebooted.

    My resolution changed after reboot, so it definetely did something, but if I run "glxgears" my framerate is around 270 fps, which seems way to slow. I tested the "Euphoria (GL)" screensaver, and it was like it was on pause, stepping frame by frame forward. Not nice.

    Running "aticonfig --initial" says:
    Found fglrx primary device section.
    Nothing to do, terminating.
    Did it again, but I added "-f", then it seemed to do something with "xorg.conf". Reboot again. No difference.

    I saw a screenshot on the ATI Control Panel, at the bottom of which it says:
    Mesa GLX Indirect
    Shouldn't it say something about ATI?

    Any ideas that can help me? Have I missed something vital?

    // Stefan

  • #2
    It should have created a fourth RPM starting with kernel-module for the fglrx drivers. If you install that, the fglrx drivers should then work.

    In regards to aticonfig --initial, since it's already configured there is nothing to do, so that portion is all set.
    Michael Larabel


    • #3
      Missed the 4th one, "kernel-module-ATI-fglrx-2.6.18-1.2798.fc6-8.31.5-1.fc6.i386.rpm".
      I installed it. Reboot. No difference. Even run aticonfig again.
      Removed all rpm's (rpm -e), and installed again. No difference.

      Any tips?

      // Stefan


      • #4
        What does your Xorg.0.log show when attempting to use fglrx?
        Michael Larabel


        • #5
          Sorry, I'm not very good at Linux, so I'm sure what part of it you're asking about, and it's a quite long file

          Here's a part of it mentioning LoadModule "fglrx":
          (II) LoadModule: "fglrx"
          (II) Loading /usr/lib/xorg/modules/drivers/
          (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
          	compiled for 7.1.0, module version = 8.31.5
          	Module class: X.Org Video Driver
          	ABI class: X.Org Video Driver, version 1.0
          Ang some later in the file:
          (II) Primary Device is: PCI 01:00:0
          (II) ATI Proprietary Linux Driver Version Identifier:8.31.5
          (II) ATI Proprietary Linux Driver Release Identifier: LGDr8.31g1                           
          (II) ATI Proprietary Linux Driver Build Date: Nov  9 2006 18:43:06
          (II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-
          (--) Assigning device section with no busID to primary device
          (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
          (--) Chipset RADEON 9600 SE (RV350 4151) found
          (II) resource ranges after xf86ClaimFixedResources() call:
          	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
          	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
          And alot of more addresses follwing the above..

          And somre more stuff later:
          (II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
          	Screen to screen bit blits
          	Solid filled rectangles
          	Solid Horizontal and Vertical Lines
          	Offscreen Pixmaps
          	Setting up tile and stipple cache:
          		32 128x128 slots
          		32 256x256 slots
          		16 512x512 slots
          (II) fglrx(0): Acceleration enabled
          (II) fglrx(0): Direct rendering disabled
          (==) fglrx(0): Using hardware cursor
          (II) fglrx(0): Largest offscreen area available: 1600 x 6988
          (II) Loading extension FGLRXEXTENSION
          (II) Loading extension ATITVOUT
          (==) RandR enabled
          (II) Initializing built-in extension MIT-SHM
          (II) Initializing built-in extension XEVIE
          (EE) AIGLX: Screen 0 is not DRI capable
          (II) Loading local sub module "GLcore"
          (II) LoadModule: "GLcore"
          (II) Loading /usr/lib/xorg/modules/extensions/
          (II) Module GLcore: vendor="X.Org Foundation"
          	compiled for 7.1.1, module version = 1.0.0
          	ABI class: X.Org Server Extension, version 0.3
          (II) GLX: Initialized MESA-PROXY GL provider for screen 0
          Sorry, but I hope some of this is relevant?

          // Stefan


          • #6
            Can you post your xorg.conf? In your xorg.0.log were there any errors (noted by EE) other than what was posted above?
            Michael Larabel


            • #7
              No, the only EE was the one above.

              Here's the xorg.conf:

              # Xorg configuration created by system-config-display
              Section "ServerLayout"
              	Identifier     "single head configuration"
              	Screen      0  "aticonfig-Screen[0]" 0 0
              	InputDevice    "Keyboard0" "CoreKeyboard"
              Section "Files"
              Section "Module"
              	Load  "dri"
              	Load  "glx"
              Section "InputDevice"
              	Identifier  "Keyboard0"
              	Driver      "kbd"
              	Option	    "XkbModel" "pc105"
              	Option	    "XkbLayout" "se"
              Section "Monitor"
              	Identifier   "aticonfig-Monitor[0]"
              	Option	    "VendorName" "ATI Proprietary Driver"
              	Option	    "ModelName" "Generic Autodetecting Monitor"
              	Option	    "DPMS" "true"
              Section "Device"
              	Identifier  "aticonfig-Device[0]"
              	Driver      "fglrx"
              Section "Screen"
              	Identifier "aticonfig-Screen[0]"
              	Device     "aticonfig-Device[0]"
              	Monitor    "aticonfig-Monitor[0]"
              	DefaultDepth     24
              	SubSection "Display"
              		Viewport   0 0
              		Depth     24
              Last edited by stefans; 11-29-2006, 01:12 PM.


              • #8
       See there, you need to disable Composite.
                Michael Larabel


                • #9
                  Thanks for the help with that, it feels like I got another step closer to success, hopefully Now when I check the ATI Control Panel, OpenGL Renderer says: "Radeon 9600SE Generic", and not some Mesa..

                  Though, strangely enough, I seem to get even worse fps. A check again in the Xorg.0.log shows 2 errors:
                  (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/ undefined symbol: __driCreateNewScreen_20050727)
                  (EE) AIGLX: reverting to software rendering
                  It seems to go to software rendering, probably why it's slow?
                  I just checked the GL screensavers, and before it was only "Euphoria" that stepped forward frame by frame, now it's everyone of them...


                  • #10

                    Whoa.. A little more messing around with the xorg.conf seems to have done it! A added 2 lines for refreshrate, and got my monitor up from 60 to 85 Hz, and now the GL screensavers are smooth.
                    Ok, just to point out, I know the screensavers aren't the most importat, but it's all I sofar have installed to test with and get a feeling for the performance. "glxgears" gives only about 125 fps, so accourding to that it's not that good, but that doesn't seem like a good performance tool obviously.

                    The 2 errors with AIGLX are still there, but doesn't seem to matter as far as I get it.

                    Anyway, it's working! Thanks alot for the help, Michael!

                    // Stefan