Announcement

Collapse
No announcement yet.

Problems of ATI driver 8.31.5 from livna repo

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems of ATI driver 8.31.5 from livna repo

    Hi,

    Is there anyone had the same porblem with me?
    When I updated the fglrx from 8.29.6-livna to 8.31.5-livna today, the OpenGL vendor became Mesa again. The vendor was ATI before.

    Then, I removed all the fglrx packages, and reinstall them. The same.

    These are the packages I installed.
    kmod-fglrx.i686 8.31.5-1.2.6.18_1.2849 installed
    xorg-x11-drv-fglrx.i386 8.31.5-1.lvn6 installed
    xorg-x11-drv-fglrx-devel.i386 8.31.5-1.lvn6 installed

    I had extension section in my xorg.conf,
    ------
    # tail -4 /etc/X11/xorg.conf
    Section "Extensions"
    Option "Composite" "Disable"
    EndSection
    ------

    And I still got the following warnings,
    ------
    # grep WW /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) No FontPath specified. Using compiled-in default.
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) fglrx(0): Kernel Module version does *not* match driver.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    (WW) fglrx(0): Failed to set up write-combining range (0xc7000000,0xfe0000)
    (WW) fglrx(0): Failed to set up write-combining range (0xc6000000,0x1fe0000)
    (WW) fglrx(0): Failed to set up write-combining range (0xc4000000,0x3fe0000)
    (WW) fglrx(0): Failed to set up write-combining range (0xc0000000,0x7fe0000)
    (WW) fglrx(0): Textured Video not supported without DRI enabled.
    (WW) <default pointer>: No Device specified, looking for one...
    ------
    # grep EE /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
    (EE) AIGLX: Screen 0 is not DRI capable
    ------

    I used got this warnings as well, but when I appended the composite="disable", the warning diappeared. But not for this time. Could anyone give me a hint? Thanks.
    Last edited by foxtseng; 11-20-2006, 11:08 AM.

  • #2
    And I cannot restore back to the old driver 8.29.6
    Or how can I do that?

    Comment


    • #3
      Not using Livna it works well. I haven't seen any other users with Livna run into this problem yet.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Without using livna's rpm, I can't even compile the ATI's official driver. It always complained missing qt-3.3 lib files, which I believe were installed completely. I installed 8.29.6 from livna, and that works after lots of strugglings. But the same procedures can't make the 8.31.5 work anymore. :-(


        Originally posted by Michael View Post
        Not using Livna it works well. I haven't seen any other users with Livna run into this problem yet.

        Comment


        • #5
          I found the following status in /var/log/Xorg.0.log
          (After updated to driver 8.31.5)
          ------
          (II) fglrx(0): Kernel Module Version Information:
          (II) fglrx(0): Name: fglrx
          (II) fglrx(0): Version: 8.29.6
          (II) fglrx(0): Date: Sep 19 2006
          (II) fglrx(0): Desc: ATI FireGL DRM kernel module
          (WW) fglrx(0): Kernel Module version does *not* match driver.
          ------
          So, it seems that for some reason, the old kernel module is still used and cause the problem. Could anyone point out that how can I assign a specific kernel module? Or it is because livna released a wrong kmod-fglrx.i686 ?

          Originally posted by foxtseng View Post
          Without using livna's rpm, I can't even compile the ATI's official driver. It always complained missing qt-3.3 lib files, which I believe were installed completely. I installed 8.29.6 from livna, and that works after lots of strugglings. But the same procedures can't make the 8.31.5 work anymore. :-(

          Comment


          • #6
            It could be due to the Livna packaging. Otherwise try reinstalling the RPM again.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              I almost can confirm that it is because Livna packaging. Since I successfully restored to 8.29.6 by downloading the old packages and install them locally.

              yum localinstall these,
              kmod-fglrx-8.29.6-1.2.6.18_1.2849.fc6.i686.rpm
              xorg-x11-drv-fglrx-8.29.6-1.lvn6.i386.rpm
              xorg-x11-drv-fglrx-devel-8.29.6-1.lvn6.i386.rpm

              And my video card works fine again. So, be careful to upgrade the 8.31.5 ati driver from Livna.

              Originally posted by Michael View Post
              It could be due to the Livna packaging. Otherwise try reinstalling the RPM again.

              Comment


              • #8
                hey... even though you get the qt3.3 error you should still be able to generate the packages wiht the "--build-pkg" option. While you won't be able to install the fglrxcontrolpanel rpm, you should still be able to install the drivers&module. Maybe it'll work that way.

                Comment


                • #9
                  Originally posted by amenzix View Post
                  hey... even though you get the qt3.3 error you should still be able to generate the packages wiht the "--build-pkg" option. While you won't be able to install the fglrxcontrolpanel rpm, you should still be able to install the drivers&module. Maybe it'll work that way.
                  That would work, only if you remove the fireglcontrolpanel build code from the Fedora packaging scripts.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    I thought there was a separate rpm for fireglcontrolpanel and that you could simply not install that one. Sorry then. But then again, if it worked with livna rpm's, it might work with the generated rpm's as well. I'm just speculating, I'm not really sure about how the ATI installer works.

                    Comment

                    Working...
                    X