Announcement

Collapse
No announcement yet.

Problems of ATI driver 8.31.5 from livna repo

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems of ATI driver 8.31.5 from livna repo

    Hi,

    Is there anyone had the same porblem with me?
    When I updated the fglrx from 8.29.6-livna to 8.31.5-livna today, the OpenGL vendor became Mesa again. The vendor was ATI before.

    Then, I removed all the fglrx packages, and reinstall them. The same.

    These are the packages I installed.
    kmod-fglrx.i686 8.31.5-1.2.6.18_1.2849 installed
    xorg-x11-drv-fglrx.i386 8.31.5-1.lvn6 installed
    xorg-x11-drv-fglrx-devel.i386 8.31.5-1.lvn6 installed

    I had extension section in my xorg.conf,
    ------
    # tail -4 /etc/X11/xorg.conf
    Section "Extensions"
    Option "Composite" "Disable"
    EndSection
    ------

    And I still got the following warnings,
    ------
    # grep WW /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) No FontPath specified. Using compiled-in default.
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) fglrx(0): Kernel Module version does *not* match driver.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    (WW) fglrx(0): Failed to set up write-combining range (0xc7000000,0xfe0000)
    (WW) fglrx(0): Failed to set up write-combining range (0xc6000000,0x1fe0000)
    (WW) fglrx(0): Failed to set up write-combining range (0xc4000000,0x3fe0000)
    (WW) fglrx(0): Failed to set up write-combining range (0xc0000000,0x7fe0000)
    (WW) fglrx(0): Textured Video not supported without DRI enabled.
    (WW) <default pointer>: No Device specified, looking for one...
    ------
    # grep EE /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
    (EE) AIGLX: Screen 0 is not DRI capable
    ------

    I used got this warnings as well, but when I appended the composite="disable", the warning diappeared. But not for this time. Could anyone give me a hint? Thanks.
    Last edited by foxtseng; 11-20-2006, 11:08 AM.

  • #2
    And I cannot restore back to the old driver 8.29.6
    Or how can I do that?

    Comment


    • #3
      Not using Livna it works well. I haven't seen any other users with Livna run into this problem yet.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Without using livna's rpm, I can't even compile the ATI's official driver. It always complained missing qt-3.3 lib files, which I believe were installed completely. I installed 8.29.6 from livna, and that works after lots of strugglings. But the same procedures can't make the 8.31.5 work anymore. :-(


        Originally posted by Michael View Post
        Not using Livna it works well. I haven't seen any other users with Livna run into this problem yet.

        Comment


        • #5
          I found the following status in /var/log/Xorg.0.log
          (After updated to driver 8.31.5)
          ------
          (II) fglrx(0): Kernel Module Version Information:
          (II) fglrx(0): Name: fglrx
          (II) fglrx(0): Version: 8.29.6
          (II) fglrx(0): Date: Sep 19 2006
          (II) fglrx(0): Desc: ATI FireGL DRM kernel module
          (WW) fglrx(0): Kernel Module version does *not* match driver.
          ------
          So, it seems that for some reason, the old kernel module is still used and cause the problem. Could anyone point out that how can I assign a specific kernel module? Or it is because livna released a wrong kmod-fglrx.i686 ?

          Originally posted by foxtseng View Post
          Without using livna's rpm, I can't even compile the ATI's official driver. It always complained missing qt-3.3 lib files, which I believe were installed completely. I installed 8.29.6 from livna, and that works after lots of strugglings. But the same procedures can't make the 8.31.5 work anymore. :-(

          Comment


          • #6
            It could be due to the Livna packaging. Otherwise try reinstalling the RPM again.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              I almost can confirm that it is because Livna packaging. Since I successfully restored to 8.29.6 by downloading the old packages and install them locally.

              yum localinstall these,
              kmod-fglrx-8.29.6-1.2.6.18_1.2849.fc6.i686.rpm
              xorg-x11-drv-fglrx-8.29.6-1.lvn6.i386.rpm
              xorg-x11-drv-fglrx-devel-8.29.6-1.lvn6.i386.rpm

              And my video card works fine again. So, be careful to upgrade the 8.31.5 ati driver from Livna.

              Originally posted by Michael View Post
              It could be due to the Livna packaging. Otherwise try reinstalling the RPM again.

              Comment


              • #8
                hey... even though you get the qt3.3 error you should still be able to generate the packages wiht the "--build-pkg" option. While you won't be able to install the fglrxcontrolpanel rpm, you should still be able to install the drivers&module. Maybe it'll work that way.

                Comment


                • #9
                  Originally posted by amenzix View Post
                  hey... even though you get the qt3.3 error you should still be able to generate the packages wiht the "--build-pkg" option. While you won't be able to install the fglrxcontrolpanel rpm, you should still be able to install the drivers&module. Maybe it'll work that way.
                  That would work, only if you remove the fireglcontrolpanel build code from the Fedora packaging scripts.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    I thought there was a separate rpm for fireglcontrolpanel and that you could simply not install that one. Sorry then. But then again, if it worked with livna rpm's, it might work with the generated rpm's as well. I'm just speculating, I'm not really sure about how the ATI installer works.

                    Comment


                    • #11
                      For Livna RPMs, last time I used them you had the option of installing the control panel or not. However, with the official AMD installer once you pass --buildpkg Fedora/FC6 that is the only option and it will execute the scripts to build all of the RPMs. The way to get the fireglcontrolpanel out of the build stack would be to comment out or eliminate the code in the packaging script.
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment


                      • #12
                        I am not sure how to do this. You mean comment out some lines in the scripts attached before the binary code, or we have to extract out all the stuff first and then play with them?

                        Originally posted by Michael View Post
                        For Livna RPMs, last time I used them you had the option of installing the control panel or not. However, with the official AMD installer once you pass --buildpkg Fedora/FC6 that is the only option and it will execute the scripts to build all of the RPMs. The way to get the fireglcontrolpanel out of the build stack would be to comment out or eliminate the code in the packaging script.

                        Comment


                        • #13
                          Run

                          ./amd-driver-name.run --extract

                          Then in

                          fglrx-install/packages/Fedora

                          open ATI-fglrx.spec-tmpl and remove or comment:

                          %{_bindir}/fireglcontrolpanel
                          In ati-packager.sh open that up and remove or comment out:

                          Code:
                               if [ ! -x ${TMP_RPM_BUILD_DIR}/usr/bin/fireglcontrolpanel ]; then
                                 mkdir ${TMP_RPM_BUILD_DIR}/usr/src/ati/fglrx_panel_sources
                                 pushd ${TMP_RPM_BUILD_DIR}/usr/src/ati/fglrx_panel_sources &> /dev/null
                                 tar xzf ${TMP_RPM_BUILD_DIR}/usr/src/ati/fglrx_panel_sources.tgz
                                 sed -i 's|^LIBQT_DYN = qt$|LIBQT_DYN = qt-mt|' Makefile
                                 sed -i 's|STRIP = strip|STRIP = @echo strip is disabled for:|' Makefile
                                 sed -i 's|BASENAME =  fireglcontrol|BASENAME =  fireglcontrolpanel|' Makefile
                                 [ -n "$QTDIR" ] || . /etc/profile.d/qt.sh && make &> /dev/null
                                 install -p -m 0755 fireglcontrolpanel ${TMP_RPM_BUILD_DIR}/usr/bin/fireglcontrolpanel
                                 popd &> /dev/null
                               fi
                          and then that should probably be it. Then move back into the main fglrx-install folder and run

                          ./ati-installer.sh 8.31.5 --buildpkg Fedora/FC6

                          and it should build without fireglcontrolpanel. If I recall correctly, those should be all of the fireglcontrolpanel references you need to remove. If it still gives you problems when building, just follow where it gives you the problem and then comment/remove those lines.
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #14
                            Sorry for my stupid mistake.

                            I did not remove the old module after upgrade. So, after a reboot and create a symbolic link to the right libGL.so.1.2, it works fine now.

                            Livna's fglrx 8.31.5 driver is okay.

                            Sorry for the confusion. Maybe the whole thread should be removed.

                            Comment


                            • #15
                              Hi every body!
                              I'm new user, (I've used Linux for 2 days) and I have a trouble with install ATI Drv. (Fedora Core 6 ( Zod ) 2.6.18-1.2849.fc6. VGA ATI Radeon 9600 Pro)

                              [root@localhost ~]# yum install kmod-fglrx
                              Loading "installonlyn" plugin
                              Setting up Install Process
                              Setting up repositories
                              Reading repository metadata in from local files
                              Parsing package install arguments
                              Resolving Dependencies
                              --> Populating transaction set with selected packages. Please wait.
                              ---> Package kmod-fglrx.i686 0:8.31.5-1.2.6.18_1.2849.fc6 set to be installed
                              --> Running transaction check
                              --> Processing Dependency: fglrx-kmod-common >= 8.31.5 for package: kmod-fglrx
                              --> Restarting Dependency Resolution with new changes.
                              --> Populating transaction set with selected packages. Please wait.
                              ---> Package xorg-x11-drv-fglrx.i386 0:8.31.5-1.lvn6 set to be updated
                              --> Running transaction check
                              --> Processing Conflict: ati-x11-drv conflicts xorg-x11-drv-fglrx
                              --> Finished Dependency Resolution
                              Error: ati-x11-drv conflicts with xorg-x11-drv-fglrx
                              How can I do???

                              Comment

                              Working...
                              X