Announcement

Collapse
No announcement yet.

AMD's New Catalyst Driver Is Available To All Linux Users

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The driver is not compatible with Ubuntu/saucy... Like the previous version, and like the 3.12... Again... :/ How many time Saucy users have to wait for having our version ? ><

    Comment


    • #17
      Yeah, I can't install these on Ubuntu 13.10 running kernel 3.12.6. When trying to build the packages I get the error:

      Package build failed!
      Package build utility output:
      cat: /tmp/pkg_build.out: No such file or directory
      Removing temporary directory: fglrx-install.UALTBM

      Another leap forward by AMD.

      Comment


      • #18
        Originally posted by MaestroMaus View Post
        So, here is a question: I have been out of the Linux game for the past 3 years and when I left AMD looked like they would have working OS drivers in the next one or two years.; why are these closed drivers still neccesary? Are the OS drivers done yet? If so; what's taking so damn long?
        There ARE working FLOSS drivers for all available hardware. For older hardware (r700 and below) they are pretty much feature-complete too. They are stable, support pretty much everything, and on older hardware often perform almost as fast as the closed blob. For r700 and below, there is really no reason to use the blob anymore. Pre-SI hardware (HD5xxx and HD 6xxx) is also well supported, but a few of the advanced features are missing, and OpenCL support is spotty.

        With newer hardware, the drivers are OK, but still a bit rough around the edges. The Catalyst team has had a head-start of several years, and they have far more manpower. Also, some advanced functionality (needed for OpenGL 4+) still needs to be added to Mesa, so ALL free drivers are waiting for them (Intel, nouveau and radeon). So there are drivers, but they have not yet reached parity with the closed blob.

        The closed-source drivers are just the Windows drivers with some Linux bits added to them. AMD will not discontinue them because, well, they need Windows drivers.

        Comment


        • #19
          Originally posted by molecule-eye View Post
          Yeah, I can't install these on Ubuntu 13.10 running kernel 3.12.6. When trying to build the packages I get the error:

          Package build failed!
          Package build utility output:
          cat: /tmp/pkg_build.out: No such file or directory
          Removing temporary directory: fglrx-install.UALTBM

          Another leap forward by AMD.
          Ok, so I managed to get them to build and install. Performance in Dota 2 is the same--crap. Performance in L4D2 is hard to judge. There's finally no input lag and net_graph 1 shows an fps between 80-120 but the PERCEIVED fps is more like 24. I have to do more testing to see what's up, but I'm not surprised most of the major bugs haven't been squashed.

          Comment


          • #20
            maybe is better to check straight in steamOS and see if there's an improvement there first, specially with the frame rate of games.

            then compare with other distros.

            Comment


            • #21
              Originally posted by MaestroMaus View Post
              So, here is a question: I have been out of the Linux game for the past 3 years and when I left AMD looked like they would have working OS drivers in the next one or two years.; why are these closed drivers still neccesary? Are the OS drivers done yet? If so; what's taking so damn long?
              Ok. The open source drivers work for everything older than the HD 7000 series without a problem and perform at about 80%+ of catalyst in speed.
              The HD 7000 and newer drivers have just got caught up in terms of features and are now starting to get performance optimizations. Just recently, they found a major bottleneck in the drivers so its unknown how they currently perform as Micheal hasn't been able to perform benchmarks because of his trip.

              Big cravat, not all the distro's have the powersaving and performance updates yet as they were ok for release by legal rather recently. New distro releases next year should have the powersave and video updates though.

              Comment


              • #22
                Jumped ship from the official to this beta release. No issues installing after purging out all the old. Game performance seems a bit better, no input lag which to me was one of my biggest annoyances with the official driver. Maybe AMD is finally heading in the right direction with something?

                Comment


                • #23
                  Originally posted by makson View Post
                  The following packages must be installed in order for the AMD Catalyst™ Linux graphics driver to install and work optimally:
                  - gimp-help-en
                  - gimp-help-common
                  ...
                  Why the hell Catalyst is depending on GIMP help files?
                  Originally posted by spartonicus View Post
                  Game performance seems a bit better, no input lag which to me was one of my biggest annoyances with the official driver. Maybe AMD is finally heading in the right direction with something?
                  That Gimp help files works miracles.

                  Anyway it didn't seem to improve stability besides the resize konsole crash and maybe the Opengl Screensaver crash.
                  [372656] : Resolves crash when resizing Konsole
                  [388325] : Resolves brightness adjustment issues
                  [388818] : Resolves kernel module compile failure when CONFIG_UIDGID_STRICT_TYPE_CHECKS is enabled
                  [388335] : Avoids the new GPL symbol acpi_bus_get_device for new kernel support
                  [386897] : Resolves system hang on resume from S4 with OpenGL screen saver running

                  Comment


                  • #24
                    Resolved Issues:
                    [372656] : Resolves crash when resizing Konsole
                    [388325] : Resolves brightness adjustment issues
                    [388818] : Resolves kernel module compile failure when CONFIG_UIDGID_STRICT_TYPE_CHECKS is enabled
                    [388335] : Avoids the new GPL symbol acpi_bus_get_device for new kernel support
                    [386897] : Resolves system hang on resume from S4 with OpenGL screen saver running

                    These ones were fixed in 13.11 version 9.4.

                    Comment


                    • #25
                      Originally posted by LN17 View Post
                      These ones were fixed in 13.11 version 9.4.
                      http://support.amd.com/en-us/kb-arti...ta-Driver.aspx

                      So it seems the release notes of the V9.95 version are just a joke then... cause it only resolves things that are already fixed in 9.4 and add support for SteamOS that is working with the 9.5 already... and the Gimp help files at the bottom...

                      The following packages must be installed in order for the AMD Catalyst™ Linux graphics driver to install and work optimally:

                      gimp-help-en
                      gimp-help-common

                      Comment


                      • #26


                        Catalyst 14.1 Beta - end of January
                        Catalyst 14.2 Final/WHQL - end of February

                        Comment


                        • #27
                          From where do you get end of January/end of February dates ? The slide says Q1 and just 14.1 Beta.

                          I would be interested what the new distribution support means. (it is so general)

                          Comment


                          • #28
                            Originally posted by LN17 View Post
                            I would be interested what the new distribution support means. (it is so general)
                            I'd assume it's kernel and Xorg versions.

                            Comment


                            • #29
                              Randomly kills X11 for me.

                              This driver does seem to be a little snappier and my brightness quick keys now work. I was just starting to feel good about this new beta driver and then I opened up Google chrome and X11 crashed, LOL.

                              Looks like there's already a bug posted on this that looks similar - http://ati.cchtml.com/show_bug.cgi?id=990

                              I hope it doesn't take two years to fix like the brightness issue.

                              Come on AMD, you're almost there, prove to me that you give a crap.

                              Comment


                              • #30
                                Another regression for me. Both Left4Dead 2 and Serious Sam 3 are back to running like shit with this new Catalyst 3.11 Beta 9.5 driver. (I played both just last night and thought to myself that I was content now) If both of those have been degraded, then probably ALL my games will hurt. I can't even be arsed. Those are games that modern hardware doesn't even slow down for in Windows. (I'm not even that modern... Radeon HD 5870 on a Core i7 3.2 GHz system, and both of those games are trivial)

                                Comment

                                Working...
                                X