Announcement

Collapse
No announcement yet.

Fedora Core 6 x86_64, drivers 8.31.5 not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fedora Core 6 x86_64, drivers 8.31.5 not working

    Hi,
    I just upgraded Fedora to FC6 release and can't run my card. I have Radeon X300SE, using dual output, system is 64-bits.

    What is most suprising drivers over 8.29.6 are not working! I can compile versions 8.30.3 and 8.31.5 (with changes according to solve config.h applied) insert gflrx module into memory but while initializing X server I got followin error:

    (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found

    Backtrace:
    0: X(xf86SigHandler+0x71) [0x495ff1]
    1: /lib64/libc.so.6 [0x2aaaabc2d210]

    Fatal server error:
    Caught signal 11. Server aborting

    XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
    after 0 requests (0 known processed) with 0 events remaining.


    Drivers 8.29.6 are not working properly too (I used them successfully on FC5), while primary screen initializes ok secondary screen resolution is lower than primary (and in some non=standard mode) and except mouse pointer I see big dark box.

    Any ideas how to solve those problems? I really need dual-head display with independent desktops.

  • #2
    peper,

    Welcome to the forums.

    I haven't run into the issues you mention with 8.30 and 8.31. The "No matching Device section" is only a warning (WW) and not an error (EE). In regards to your 8.29.6 had you experimented with any pairmode options or anything else through aticonfig to try to correct the resolutions?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Yes I tried. I can't force card to use same resolution on both outputs

      I'm thinking if its not bigger bug in Fedora itself. When I remove BusID definition latest drivers are initializing properly but only in single display mode. I wonder if there is way to initialize dual display mode other than my way:

      Section "Device"

      # Option "UseInternalAGPGART" "no"
      # Option "DesktopSetup" "horizontal,reverse"
      # Option "VideoOverlay" "on"
      # Option "OpenGLOverlay" "off"
      # Screen 0
      Identifier "aticonfig-Device[0]"
      Driver "fglrx"
      # Option " UseInternalAGPGART " " no "
      Option "DesktopSetup" "single"
      Option "HWCursor" "false"
      # Option "UseFBDev" "true"
      # Option "VideoOverlay" "on"
      # BusID "PCI:1:0:0"
      Screen 0
      EndSection

      Section "Device"

      # Option "UseInternalAGPGART" "no"
      # Option "DesktopSetup" "horizontal,reverse"
      # Option "VideoOverlay" "on"
      # Option "OpenGLOverlay" "off"
      Identifier "aticonfig-Device[1]"
      Driver "fglrx"
      # Option " UseInternalAGPGART " " no "
      Option "DesktopSetup" "single"
      Option "HWCursor" "false"
      # Option "UseFBDev" "true"
      # Option "VideoOverlay" "on"
      # BusID "PCI:1:0:1"
      Screen 1
      EndSection

      Section "Screen"
      Identifier "aticonfig-Screen[0]"
      Device "aticonfig-Device[0]"
      Monitor "aticonfig-Monitor[0]"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      Modes "1280x1024"
      EndSubSection
      EndSection

      Section "Screen"
      Identifier "aticonfig-Screen[1]"
      Device "aticonfig-Device[1]"
      Monitor "aticonfig-Monitor[1]"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      Modes "1280x1024"
      EndSubSection
      EndSection

      Section "ServerLayout"

      # Screen 2 "Screen2" RightOf "aticonfig-Screen[0]"
      # Screen 2 "Screen2" 0 0
      Identifier "Multihead Layout"
      Screen 0 "aticonfig-Screen[0]" 0 0
      Screen 1 "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
      InputDevice "Mouse0" "CorePointer"
      InputDevice "Keyboard0" "CoreKeyboard"
      Option "Xinerama" "off"
      Option "Clone" "on"
      EndSection

      Comment


      • #4
        Had you tried using Big Desktop instead? See aticonfig for more information. Not sure though off hand if Big Desktop will satisfy whatever desktop arrangement you're after.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          I need 2 independent desktops. I managed to run it with Option "DesktopSetup" "horizontal" but on right screen resolution is still badly set.

          Comment

          Working...
          X