Announcement

Collapse
No announcement yet.

AMD Catalyst 13.12 GPU Driver For Linux Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by d2kx View Post
    For those with build issues, especially on Ubuntu/DKMS:

    http://archive.ubuntu.com/ubuntu/poo....debian.tar.gz

    Have a look in "/debian/dkms/patches/", especially "replace_acpi_table_handler.patch". It already landed in Ubuntu 14.04 LTS-dev.
    And what am I suppose to do with this?

    Comment


    • #32
      Originally posted by d2kx View Post
      For those with build issues, especially on Ubuntu/DKMS:

      http://archive.ubuntu.com/ubuntu/poo....debian.tar.gz

      Have a look in "/debian/dkms/patches/", especially "replace_acpi_table_handler.patch". It already landed in Ubuntu 14.04 LTS-dev.
      Hehe, i also found this workaround ;P, it was trivial because (it's funny because it's true :P) AMD already used this code in both 13.11 beta 6 and beta 9.4.
      Did they forget about it? LOL
      I got other name for this patch: looks_like_amd_forgot_this.patch
      Code:
      --- 13.12/common/lib/modules/fglrx/build_mod/kcl_acpi.c	2013-12-17 20:05:35.000000000 +0100
      +++ 13.12/common/lib/modules/fglrx/build_mod/kcl_acpi.c	2013-12-19 18:40:18.386568588 +0100
      @@ -995,7 +995,11 @@
       #endif
           {
               return KCL_ACPI_ERROR;
      -    }    
      +    }
      +#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,9,1)
      +    ((acpi_tbl_table_handler)handler)(hdr);
      +#else
           ((acpi_table_handler)handler)(hdr);
      +#endif
           return KCL_ACPI_OK;
      -}
      +}
      \ No newline at end of file
      patch -Np1 -i ../looks_like_amd_forgot_this.patch

      Comment


      • #33
        Originally posted by gutigen View Post
        And what am I suppose to do with this?
        You are supposed to do some of your own research first since if you don't know, you probably shouldn't go there ;-P

        Anyway:
        1. ./amd-catalyst-13.12-linux-x86.x86_64.run --extract NewDirectory
        2. Apply the patch as described by Vi0L0 in the previous post
        3. sudo ./ati-installer.sh 13.251 --buildpkg Ubuntu/saucy
        4. And install the build packages, placed one directory up

        Comment


        • #34
          Originally posted by Forage View Post
          You are supposed to do some of your own research first since if you don't know, you probably shouldn't go there ;-P

          Anyway:
          1. ./amd-catalyst-13.12-linux-x86.x86_64.run --extract NewDirectory
          2. Apply the patch as described by Vi0L0 in the previous post
          3. sudo ./ati-installer.sh 13.251 --buildpkg Ubuntu/saucy
          4. And install the build packages, placed one directory up
          I propably shouldn't, but thanks

          Getting an error though:

          Code:
          File to patch: amd-catalyst-13.12-linux-x86.x86_64.run
          patching file amd-catalyst-13.12-linux-x86.x86_64.run
          Hunk #1 FAILED at 995.
          Rejected part:
          Code:
          --- kcl_acpi.c
          +++ kcl_acpi.c
          @@ -995,7 +995,11 @@
           #endif
               {
                   return KCL_ACPI_ERROR;
          -    }    
          +    }
          +#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,9,1)
          +    ((acpi_tbl_table_handler)handler)(hdr);
          +#else
               ((acpi_table_handler)handler)(hdr);
          +#endif
               return KCL_ACPI_OK;
           }

          Comment


          • #35
            Originally posted by AJSB View Post
            Yeah i knew about be a Adobe Flash bug...but was only affecting some Nvidia cards and actually Nvidia launched a driver version that they said would solve bug and i continued with the darn thing affecting a 9600GT for several more drivers and many months until it finally was solved...
            It was affecting everyone who used VDPAU for presentation but not decoding. Everyone. Including open source drivers. If you think it only affected "some Nvidia cards", it's because only those had out-of-the-box VDPAU. As soon as VDPAU was available on open source radeon (no UVD yet back then, just presentation and a shader-based mpeg2 decoder)... guess what, blue people in flash.

            And Nvidia didn't solve the bug. That would only be possible if the had the flash source, which they of course do not. Only Adobe can fix it, no one else. Current libvdpau works around it, but even that only on browsers that launch flash in a certain way, you'll still get blue people in Opera 12 and I think some other browsers too.

            So don't put this one on Nvidia. If it weren't for them, you wouldn't even have VDPAU, you wouldn't have any sort of hardware accelerated flash.

            Comment


            • #36
              Originally posted by gutigen View Post
              I propably shouldn't, but thanks

              Getting an error though:

              Code:
              File to patch: amd-catalyst-13.12-linux-x86.x86_64.run
              patching file amd-catalyst-13.12-linux-x86.x86_64.run
              Hunk #1 FAILED at 995.
              Lol, I rest my case...

              You forgot the essential first part of the steps I provided: extract the files from the .run file. In there there's the file that needs to be patched.

              Comment


              • #37
                Originally posted by Forage View Post
                Lol, I rest my case...

                You forgot the essential first part of the steps I provided: extract the files from the .run file. In there there's the file that needs to be patched.

                Oh, I should've paid more attention to this. Anyway I've managed to patch and install those drivers, thanks!

                P.S. No performance change in Dota 2 or ANY other Linux game.

                Comment


                • #38
                  AMD is by no means perfect but you are right in this case.

                  Originally posted by AJSB View Post
                  I think people are sometimes too harsh with AMD and not so with NVIDIA...."Na'vi People" in flash anyone ?

                  How much time did it took for Nvidia to fix it ?
                  NVidia has had its problems too. It would be great is AMD had the resources to throw a lot of people at this but they don't. Frankly a fix every three days isn't that bad really, some of these bugs are very hard to chase down.

                  Could AMD do better - sure, but I also want them to stay around for awhile.

                  Comment


                  • #39
                    Originally posted by Gusar View Post
                    It was affecting everyone who used VDPAU for presentation but not decoding. Everyone. Including open source drivers. If you think it only affected "some Nvidia cards", it's because only those had out-of-the-box VDPAU. As soon as VDPAU was available on open source radeon (no UVD yet back then, just presentation and a shader-based mpeg2 decoder)... guess what, blue people in flash.

                    And Nvidia didn't solve the bug. That would only be possible if the had the flash source, which they of course do not. Only Adobe can fix it, no one else. Current libvdpau works around it, but even that only on browsers that launch flash in a certain way, you'll still get blue people in Opera 12 and I think some other browsers too.

                    So don't put this one on Nvidia. If it weren't for them, you wouldn't even have VDPAU, you wouldn't have any sort of hardware accelerated flash.
                    This sounds an awful lot like what AMD supporters say about their WINE support, and somehow that's always considered AMD's fault.

                    Comment


                    • #40
                      Originally posted by tomtomme View Post
                      I am assuming that. Because of the one-bug-fix every 3 days I counted above. I am NOT talking about the FOSS team - they make a great job from my point of view. I was only talking about catalyst. READ my post!
                      You misunderstood me. I think exactly the same thing.

                      Comment


                      • #41
                        Can anyone install the new driver so far?

                        Comment


                        • #42
                          Originally posted by LN17 View Post
                          Can anyone install the new driver so far?
                          Read the thread? That's what its there for. You would have had you answer already if you did.

                          Comment


                          • #43
                            Originally posted by smitty3268 View Post
                            This sounds an awful lot like what AMD supporters say about their WINE support, and somehow that's always considered AMD's fault.
                            Except in this case we know *exactly* where and what the bug is. Flash sets the U/V planes (the parts of the video that contain color information) in wrong order. No "if"s or "but"s about it. It has nothing to do with browsers, it has nothing to do with graphics drivers, be it open source or proprietary. It's all in flash.

                            The situation with WINE is a lot less clear. Is the bug in WINE, in AMD's proprietary driver, or both? Probably each of these, if you go on a case by case basis.

                            Comment


                            • #44
                              Originally posted by Gusar View Post
                              Except in this case we know *exactly* where and what the bug is. Flash sets the U/V planes (the parts of the video that contain color information) in wrong order. No "if"s or "but"s about it. It has nothing to do with browsers, it has nothing to do with graphics drivers, be it open source or proprietary. It's all in flash.

                              The situation with WINE is a lot less clear. Is the bug in WINE, in AMD's proprietary driver, or both? Probably each of these, if you go on a case by case basis.
                              Originally posted by smitty3268 View Post
                              This sounds an awful lot like what AMD supporters say about their WINE support, and somehow that's always considered AMD's fault.
                              This situation have some years ATI/AMD need more attention on linux especially on wine (Opesource driver give compatibility but with low performance and Privative driver give performance but losing performance), NVIDIA (Privative driver) is much better for now especially on wine (performance and compatibility)


                              Comment


                              • #45
                                I am running Ubuntu 12.04 and I installed the new driver with these instruktions:

                                http://askubuntu.com/questions/12429...-drivers-fglrx

                                And I had no problems at all with the installation and didn't need no patch to make it work.

                                I noticed a big differance in performance on dota2....but that said, I had to admit that I only install stable drivers, so haven't used any beta drivers.

                                Comment

                                Working...
                                X