Announcement

Collapse
No announcement yet.

X1950Pro hangs during startup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • X1950Pro hangs during startup

    1. I do have Ultimate Sapphire X1950 Pro PCI-E card.
    2. My computer hangs during X-startup in Ubuntu 7.10 desktop [x86] (in x86_64 drivers worked somewhat, but I had to switch in x86 because some other issues).
    3. Everything else works perfectly but when using fglrx drivers, x-startup hang and I have to do hardreset.
    4. I'm using 2.6.22-14-generic, 8.37.6 from ubuntu repository, also have tried to compile new 8.42.3 but no change.
    5. I have tried several options I know good in xorg.conf but still no change.


    Everything load ok, but this happends:
    ---------------------------------------------------
    (II) fglrx(0): ATI Video BIOS revision 9 or later detected
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 6, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 6, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 6, (OK)
    drmGetBusid returned ''
    (II) Loading sub module "fglrxdrm("
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.1.0, module version = 8.37.6
    ABI class: X.Org Server Extension, version 0.3
    ----------------------------------------------------

    and screen goes blank and computer is frozen. No panics, no warnings, system just get silenced.

    I'm glueless and totally out of ideas.


    Here is my complete xorg.0.log:
    http://pastebin.com/m24e4cc60


    Anyone know or have heard something similar?

    Thanks in advance.

  • #2
    I have now installed 2.16.23.1, fglrx-8.42.3 and applied also patch for it. Still same thing, system get frozen after the following text is written on Xorg.0.log:

    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.1.0, module version = 8.37.6
    ABI class: X.Org Server Extension, version 0.3

    Comment


    • #3
      Installed Fedora 7 and installed 8.42.3 on 2.6.21-1.3194.fc7

      Still no change... starting X does hang after fglrxdrm.

      Comment


      • #4
        [URL="http://ubuntuforums.org/archive/index.php/t-490372.html"]

        *Yarr...!*

        Comment

        Working...
        X