Announcement

Collapse
No announcement yet.

Suggestions about how to make a Radeon HD 7790 work decently?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by A Laggy Grunt View Post
    If you think fglrx was installed, you might want to walk through exactly how you installed it.

    Here's how I did it:
    Become root
    Run fglrx-xxxxx.sh
    Choose the "Install" option (not the generate packages option)
    Finish the install
    Reboot
    And don't forget to disable/ prevent the radeon module from loading (radeon.modeset=0).

    It's easy to tell if it is installed and running: press ctrl+alt+f1 (then alt+f5 or f7 to get back to X)
    Using the open-source radeon driver, the virtual terminal displays at my native resolution (1600x1200) with very small text.
    Using fglrx, it's 640x480.
    Well not always. In my case, the resolution with fglrx is native at 1920x1080 (7970 and A10-5800K).

    --
    Also, I suggest not messing with beta drivers. They're a good way to mess things up.

    Comment


    • #22
      Ignore my previous post (the part with disabling radeon); misunderstood something ^^
      Last edited by flim; 12-12-2013, 04:53 PM.

      Comment


      • #23
        I tried installing the current AMD fglrx driver using their installation script, it failed, it gave me a cryptic message in its log which I posted a couple of days ago (along with a couple of screen shots), but that message didn't seem to get moderated to appear on the forum. I rebooted but the desktop was unusable, though I was able to get in to X. FWIW, my virtual consoles looked 640x480. I was forced to try reinstalling the fglrx driver using X forwarding from another machine since the desktop was almost completely unresponsive. The installer claimed there was a previous install, but even if I used the force it was an unhappy camper. The installer kept giving warnings not to use the force option, but wouldn't proceed and didn't give any alternative. Generally the installer would just stall out rather quickly and not advance. The fgrlx-install logs didn't clarify matters, so I gave up on fglrx. Maybe by the time Jessie becomes stable it will work in Debian.

        I reverted to radeon with oibaf. Every time I start a wine program it just about freezes my desktop, I see one of my 6 cores taking 100% of my CPU (not always the same core). 20-45 MB a day of new updates from http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu/ don't seem to be making my issues disappear. But for now I can play videos and interact with the desktop as long as I don't start a wine program. Wine works fine over X forwarding from another machine, BTW. So I guess I can limp along until 14.04 appears. I may try the Fedora 20 live image next week, which seems to have the right mesa drivers and kernel to work, but I hate using Fedora, seems like the devs just delight in throwing up irritating obstacles. sbin not in root's path, what's up with that? Even if Fedora works like greased lightning with radeon I don't think I'll install it, but I'll report back my experience.

        Comment


        • #24
          Well, Fedora 20 won't help, I didn't bother to download it. It uses mesa 9x and 3.11 so it won't run radeon on a HD 7000, I don't think.
          http://www.phoronix.com/scan.php?pag...nchmarks&num=1

          On the plus side, (K)ubuntu 14.04 Alpha 1 has been released which seems to have mesa 10 (in a special repo, lined up for the release next April) and the 3.12 kernel, so it might well work. I'm downloading the live image and will report back how it does, though I'm hesitant to upgrade 13.10 to an Alpha release.

          I guess I'm meant to be using radeonSi, I have "ati" as the driver in my xorg.conf.
          Code:
          $ grep -i driver /var/log/Xorg.0.log
          [  7948.042]    X.Org Video Driver: 14.1
          [  7948.042]    X.Org XInput driver : 19.1
          [  7948.046] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
          [  7948.046]    Module class: X.Org Video Driver
          [  7948.046]    ABI class: X.Org Video Driver, version 14.1
          [  7948.047] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
          [  7948.047]    Module class: X.Org Video Driver
          [  7948.047]    ABI class: X.Org Video Driver, version 14.1
          [  7948.047] (II) RADEON: Driver for ATI Radeon chipsets:
          [  7948.057] (II) glamor: OpenGL accelerated X.org driver based.
          [  7948.271] (II) RADEON(0): [DRI2]   DRI driver: radeonsi
          [  7948.271] (II) RADEON(0): [DRI2]   VDPAU driver: radeonsi
          [  7948.432]    Module class: X.Org XInput Driver
          [  7948.432]    ABI class: X.Org XInput driver, version 19.1
          Code:
          $ glxinfo | grep OpenGL
          OpenGL vendor string: X.Org
          OpenGL renderer string: Gallium 0.4 on AMD BONAIRE
          OpenGL version string: 2.1 Mesa 10.1.0-devel (git-3b1195f saucy-oibaf-ppa)
          OpenGL shading language version string: 1.30
          OpenGL extensions:
          Does that seem like it is what I want? Wine still freezes my desktop up until I kill it, but on the plus side I can finally enable desktop effects on KDE. I'll post this and see if compiz still freezes my system.

          EDIT: fusion-icon segfaulted but it didn't lock up my system, PROGRESS!
          Last edited by Praxis; 12-20-2013, 06:02 PM.

          Comment


          • #25
            I think that looks right. AFAIK as long as you get "Gallium 0.4 on AMD BONAIRE" then everything else is probably correct.

            Now it's just a matter of updating regularly to get the latest goodness

            Comment


            • #26
              Originally posted by Praxis View Post
              Code:
              $ glxinfo | grep OpenGL
              OpenGL vendor string: X.Org
              OpenGL renderer string: Gallium 0.4 on AMD BONAIRE
              OpenGL version string: 2.1 Mesa 10.1.0-devel (git-3b1195f saucy-oibaf-ppa)
              OpenGL shading language version string: 1.30
              OpenGL extensions:
              Does that seem like it is what I want?
              Yes, except that Mesa was compiled with LLVM 3.3 instead of 3.4, which is why you've only got GL 2.1 support. That also comes with a lot of bug fixes/improvements for SI drivers.

              Hopefully oibaf will start using 3.4 sometime soon. I think it's due to be released any time now, so that might fix his dependency issues he was having.

              Comment


              • #27
                Originally posted by smitty3268 View Post
                Yes, except that Mesa was compiled with LLVM 3.3 instead of 3.4, which is why you've only got GL 2.1 support. That also comes with a lot of bug fixes/improvements for SI drivers.

                Hopefully oibaf will start using 3.4 sometime soon. I think it's due to be released any time now, so that might fix his dependency issues he was having.
                Hasn't Oibaf been using llvm3.4 for a while now?

                Code:
                apt-cache policy llvm3.4
                libllvm3.4:
                  Installed: 1:3.4~+rc3-1ubuntu3
                  Candidate: 1:3.4~+rc3-1ubuntu3
                  Version table:
                 *** 1:3.4~+rc3-1ubuntu3 0
                        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
                        100 /var/lib/dpkg/status
                     1:3.4~+rc3-1ubuntu2~ubuntu13.10.1~gd 0
                        500 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu/ saucy/main amd64 Packages
                libllvm3.4-dbg:
                  Installed: (none)
                  Candidate: 1:3.4~+rc3-1ubuntu3
                  Version table:
                     1:3.4~+rc3-1ubuntu3 0
                        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
                     1:3.4~+rc3-1ubuntu2~ubuntu13.10.1~gd 0
                        500 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu/ saucy/main amd64 Packages

                Comment


                • #28
                  Well, fglrx re-entered Debian testing, so now I can use both monitors on both Debian testing Jessie & Saucy Ubuntu 13.10, the former with fglrx, the later with radeonSI, oibaf & and an out-of-repo updated kernel.

                  jessie/sid
                  fglrx-driver:
                  Installed: 1:13.8~beta1-3

                  I still can't access the rightmost 20mm or so of my right (vertical 1200x1920) monitor, I can't get my cursor there either with the mouse or the keyboard (using Alt+M and enabling moving the cursor with the number pad). So I configured my min-max-close widgets on the left side of my windows (which will take some muscle memory re-programming to use). I can not access the right scroll bars of most apps in maximized windows in my right monitor. It took some fiddling to even get my right panel configured since I couldn't access the KDE cashew when the panel was on the right monitor (and I wasn't able to figure out how to put the cashew anywhere but the right edge of a panel). And KDE desktop effects are still not happening, "Required X extensions (XComposite and XDamage) are not available." I don't have to worry about compiz because it is missing from Debian stable and testing at the moment. Video plays fine, wine apps POUND my CPU for some reason, when starting, but at least in fglrx they pound it across all 6 cores so it doesn't drag my system to its knees, but it is still a PITA. Logging out doesn't kill my sound until I reboot.

                  But with so much weird stuff going on I'm hesitant to start playing around with games, install steam, etc. I think I'll at least wait until the basics are ALL working properly before I start really putting this card through its paces. Hopefully the next major refresh of Debian testing will kick the kernel up to 3.12 and maybe introduce LVM3.4 and mesa 10, which seem to be magic incantations for the radeon driver. Or the next refresh of the fglrx driver will magically make my life worth living again.

                  I was surprised that the amdcccle was not automatically installed by Debian testing when I installed fglrx-driver, I had to install it manually. I notice that xvba-va-driver is also not installed. Should I install it, as well? This is a very powerful system (for me), AMD Phenom(tm) II X6 1055T Processor & 16 GB of RAM, and except in Ubuntu with some drivers it never struggled to play whatever I threw at it.

                  Comment


                  • #29
                    Originally posted by Praxis View Post
                    I notice that xvba-va-driver is also not installed. Should I install it, as well?
                    If you are using fglrx proprietery you can just forget about this one as nothing supports this XvBA. Everyone went with VDPAU which catalyst proprietery does not support.

                    Comment


                    • #30
                      There is absolutely nothing wrong with FGLRX! All you need to do is configure it properly to work right.
                      I have a Sapphire Radeon HD 7790 and I'm running FGLRX on Fedora 20 with it working like a charm, KDE compositing is on,
                      I'm able to play games maxed out like Team Fortress 2, Left4Dead2, DOTA 2, and Trine 2. First thing you're doing wrong is installing
                      the crappy drivers from the repositories! Install the binary drivers!
                      If you're on Ubuntu here are the steps to installing the driver.
                      1. To be able to get into the desktop, you have to first go to terminal (CTRL+ALT+F1), type in your user and password (Make sure you're ROOT or sudo).
                      2. Install FGLRX from perositories: apt-get install fglrx
                      3. After that type: amdconfig --initial && reboot
                      4. Now you can access your desktop, so now you download the 13.11BETA driver from amd.com and unzip it, mine was placed in the Downloads folder so that's how I'll demonstrate it. And make sure to delete the zip file.
                      5. Open terminal, and again make sure you're rooted or sudoed and type the following commands:
                      $ cd Downloads
                      $ chmod 770 amd*
                      $ ./amd*
                      6. Follow the instructions, decline reboot, and again type in the terminal: amdconfig --initial && reboot
                      7. Once rebooted, you'll have everything working. Hope this works, cheers! (Oh and in case you wanna add some dependencies so it won't do any problems when the kernel updates, you might wanna install gcc make git git-core linux-headers-generic dkms build-essential before you install the actual driver.

                      Comment

                      Working...
                      X