Announcement

Collapse
No announcement yet.

9600(xt) + xorg-server 1.4 + fglrx 8.42

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    IgnoreABI is no option for xorg.conf. The option is "-ignoreABI". It is for startx, in kdmrc ,gdmrc or xdm/servers and needed for OLDER fglrx drivers and Xserver 1.4 (Xorg 7.3). Also AIGLX "on" is not a requirement for the new fglrx driver as usually every X server is set to AIGLX on by default.

    Comment


    • #12
      The option is "-ignoreABI". It is for startx, in kdmrc ,gdmrc or xdm/servers and needed for OLDER fglrx drivers and Xserver 1.4 (Xorg 7.3).
      my server doesn't start without it...

      as for the aiglx, on gentoo you can enable or disable as flag. this option sets it to on for sure.

      Comment


      • #13
        Originally posted by Kano View Post
        Also AIGLX "on" is not a requirement for the new fglrx driver as usually every X server is set to AIGLX on by default.
        It's the opposite on OpenSUSE. AIGLX is set to off by default.

        I'm having the same messages on my xpress 1100/200M. AIGLX is reported as working, however compiz segfaults.

        Comment


        • #14
          It's the opposite on OpenSUSE. AIGLX is set to off by default.
          because opensuse by default gets with the xf-86-ati-drivers and not with the fgrlx and the default driver doesn't support aiglx for all ati boards and also they don't really support all the drivers. for that reason sax2 turns off aiglx and 3d acceleration setting the default to vesa with only 2d.
          but if it recognizes the board and the driver supports the various features, 3d and aiglx it enables it by default.

          Comment


          • #15
            why do you need fglrx for aiglx on your old hardware? thats not needed at all to have aiglx.

            Comment


            • #16
              why do you need fglrx for aiglx on your old hardware? thats not needed at all to have aiglx.
              the opensource drivers have aiglx but on some boards don't support compiz/beryl and are slower in performance than than the last 2 releases of fglrx.

              Comment


              • #17
                Originally posted by givemesugarr View Post
                do you have this in your xorg.conf?



                ignoreabi and aiglx are needed to run fglrx and 3d desktop on 1.3 and later.
                I have working AIGLX on xorg-server-1.3 with latest compiz but as I said xorg-server-1.4 + AIGLX = no chance

                Comment


                • #18
                  hey!!
                  i got i finally working! very nice!
                  i'd say compiz runs smoothe, but there are some things that doesn't work... i can't watch videos or dvb while compiz is running, there a very strange distortions in the picture (i use kaffeine and vdr with xineliboutput)
                  another problem is that resizing windows takes nearly 100% cpu usage, that sucks much.
                  one more: scrolling is slow.. i use konqueror, but it's far away from being smoothe

                  so my questions are:
                  how can i get working video playback?
                  and:
                  which options should i use in my xorg.conf?
                  i tried a few, compiz was always running right, but i hope there are some options to improve the performance a bit

                  here my xorg.conf (important parts):

                  Section "Module"
                  Load "dbe"
                  SubSection "extmod"
                  Option "omit xfree86-dga"
                  EndSubSection
                  # Load "type1"
                  Load "freetype"
                  # Load "xtt"
                  # Load "glx"
                  Load "dri"
                  EndSection


                  Section "ServerFlags"
                  Option "AllowMouseOpenFail" "on"
                  Option "IgnoreABI" "on"
                  Option "AIGLX" "on"
                  EndSection


                  Section "Device"
                  Identifier "Device0"
                  Driver "fglrx"
                  # Option "DRI" "true"
                  Option "XAANoOffscreenPixmaps" "true"
                  # Option "AllowGLXWithComposite" "true"
                  # Option "AddARGBGLXVisuals" "true"
                  # Option "TripleBuffer" "true"
                  Option "VideoOverlay" "on"
                  Option "OpenGLOverlay" "off"
                  # Option "TexturedVideo" "True"
                  Option "backingstore" "true"
                  Option "UseFastTLS" "2"
                  Option "BusType" "AGP"
                  Option "AGPMode" "8"
                  Option "EnablePageFlip" "1"
                  EndSection


                  Section "ServerLayout"
                  Identifier "Simple Layout"

                  Screen "Screen 1"

                  InputDevice "Mouse1" "CorePointer"
                  InputDevice "Keyboard1" "CoreKeyboard"
                  Option "AIGLX" "true"
                  EndSection


                  Section "DRI"
                  Group 0
                  Mode 0666
                  EndSection


                  Section "Extensions"
                  Option "Composite" "Enable"
                  EndSection




                  EDIT: a few seconds ago i tried to run glxgears, yes, of course it ran, but it had also these distortions (something like flickering)...
                  Last edited by benneque; 11-11-2007, 06:59 AM.

                  Comment


                  • #19
                    i can't watch videos or dvb while compiz is running, there a very strange distortions in the picture (i use kaffeine and vdr with xineliboutput)
                    manually set the output method to xv.

                    Option "UseFastTLS" "2"
                    this should be 0. else it could give you problems with some apps.

                    # Load "glx"
                    this shoudl be uncommented since should be loaded.

                    remove this:
                    Option "EnablePageFlip" "1"
                    could give problems with video playing.

                    set this
                    Option "backingstore" "true"
                    to false or off.

                    add "Damage" "true"in the extension section.
                    and this in the device section:

                    Option "HWCursor" "On"

                    Comment


                    • #20
                      uh. thanks.. so many things, i'll test it in a few minutes


                      EDIT: sooo.... video still doesn't work! i use XV and the screen ist just darkblue, nothing happens, it just stays blue.
                      have i to use the texturedvideo option ? or what is it for ?

                      EDIT2: with xshm i can watch it, but when i have fullscreen it stutters and has artifacts... opengl out put doesn't work at all... just xshm , please help me
                      Last edited by benneque; 11-11-2007, 09:13 AM.

                      Comment

                      Working...
                      X