Announcement

Collapse
No announcement yet.

fglrx 8.41+8.42 display corrupted

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx 8.41+8.42 display corrupted

    ummm ok so i have a radeon x550 256mb card, and i have a small display corruption at the buttom right part of the screen appearing as 2 lines a few minutes after i start my x server, one blocking my view of the clock and one just a bit over it, and they just stay there and i close it.
    i started getting these corruptions since i installed the fglrx 8.41 driver on ubuntu 7.04 using its packaging scripts, but i knew that my card was not supported on that release, so i waited for the 8.42 and installed it on my slackware 12, and now it does the same thing - so its not the window manager (ubuntu had gnome, slack uses kde) and its not due to my compiz tryouts because it just appears on normal sessions as well.
    i dont want no magic cure for this (mostly because i dont think there is one), but i do want to know if this is a common problem and if it was brought to amd's attention or not. other than this im only having the fglrx problems most people are having, so im good

    *wanted to post a picture but weirdly enough using ksnapshot on the whole screen or just the region doesnt show these curroptions, so i guess they're on the video-card level and not the x server level.

  • #2
    I have the same problem on my xpress 200M/1100M with 8.42. Only I also get display corruption around the mouse sometimes, but this disappears after moving over an area that changes the mouse-icon. It is really irritating.

    Haven't had it in KDE4, which is quite strange. Maybe it has something to do with Qt3 and fglrx?

    Comment


    • #3
      yup i forgot to mention the mouse corruption i also get that the same way you described.
      havent tried kde4 yet, dont think i will until the stable version will be released

      Comment


      • #4
        Re: screen corruption

        That screen corruption you are seeing is an extension of the Watermark issues that flgrx sometimes has. I too was experiencing this until I added the following to my xorg.conf in the device section:
        Code:
                Option          "VideoOverlay" "on"
                Option          "OpenGLOverlay" "off"
                Option          "HWCursor" "On"
                Option          "XAANoOffscreenPixmaps" "true"
                Option          "BlockSignalsOnLock" "on"
                Option          "KernelModuleParm" "locked-userpages=0"
        From what I can tell it might be fixed from just the Kernel Module Parameter one.

        Comment


        • #5
          I had all that on except for XAANoOffscreenPixmaps, and it's definitely not the kernelmodule parameter.

          I'll be trying XAANoOffscreenPixmaps now, and I will see how it goes.

          Comment


          • #6
            Perhaps it is a combination of those? Since adding those lines, I have not experienced the problem.

            Comment


            • #7
              its this "XAANoOffscreenPixmaps" "true" that makes that go away.
              i've had this work on my x200m, and on other people boards. the problem is that if you're using compiz/beryl you have to switch from pixmap texture to copy texture or it won't function correctly.

              Comment


              • #8
                I also enabled XAANoOfscreenPixmaps now, and I haven't seen the corruption since. Thanks! I surely hope AMD fixes the problems with 8.43.

                Comment


                • #9
                  actually i only added the KernelModuleParm line like Shae suggested and it did the trick.
                  there is no XAANoOffscreenPixmaps line on my xorg.conf

                  edit: ok after a few hours the corruptions did appear (used to take only a few minutes), so im gonna add the XAANoOffscreenPixmaps line and comment the KernelModuleParm one and see how things go.
                  so.. anyone has a rough explanation of why this happens?
                  Last edited by kuzco; 11-03-2007, 07:40 PM.

                  Comment


                  • #10
                    That screen corruption you are seeing is an extension of the Watermark issues that flgrx sometimes has
                    for what i know of it, it's an issue that never got fixed and that gets new features as the driver goes on.

                    Comment

                    Working...
                    X