Announcement

Collapse
No announcement yet.

Solution: 8.42.3 openSUSE 10.3 fgl_glxgears

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    @chikazuku:
    thanks, i'll try tat later. Right now, I'm trying how good this version with 'composite enabled' (in Section "Extensions" ... EndSection). So far so good after adding these line except responsive time that too slow (refresh rate).

    @givemesugarr:
    yep, forgot to add '(optional)' to point 6---done. thanks.

    next task:
    enabling compiz/compizfusion (kinda lazy to do this)
    Last edited by t.s.; 11-05-2007, 10:07 PM.

    Comment


    • #17
      I have it working now too. I stumbled across http://dev.compiz-fusion.org/~cybero...-the-hard-way/ and decided to not use the RPM for once and it worked.

      Are you using xgl or aiglx as your DISPLAYMANAGER_XSERVER ?

      Edit: I spoke too soon. After about 10 minutes the window borders disappear. I read something about this somewhere, lol off to search again.
      Last edited by scotsmist; 11-06-2007, 02:04 AM.

      Comment


      • #18
        tried with 'composite enabled': too slow (and draws artifact/garbage at bottom right of my screen sometimes later---about 1 hours or so). turn it off. Then try 'Option "XAANoOffscreenPixmaps" "true"' and, have the exact problem (garbage at bottom right screen).

        @chikazuku, have another suggestion? It seems don't work for me.

        Comment


        • #19
          'composite enabled' (in Section "Extensions" ... EndSection).
          without this on my board compiz/beryl doesn't work.
          for me to make compix work i had to add these:
          Section "Extensions"
          Option "DAMAGE" "true"
          Option "RENDER" "true"
          Option "Composite" "Enable"
          EndSection
          these are fundamental for desktop acceleration. the only one not really needed is the render, but if you want 3d hw rendering you need to add it. (this should speed up the 3d desktop)

          these are needed in the device section to make the watermak issue disappear:

          Option "HWCursor" "On"
          Option "CapabilitiesEx" "0x00000000"
          Option "XAANoOffscreenPixmaps" "true"
          Option "mtrr" "off"
          Option "no_accel" "no"
          Option "BlockSignalsOnLock" "on"
          Option "KernelModuleParm" "locked-userpages=0"
          Option "UseFastTLS" "0"
          Option "AllowGLXWithComposite" "true"
          to make compiz/beryl work i had to put all these options all toghether.
          by the way, compiz is pretty unusable.

          Comment


          • #20
            to make compiz/beryl work i had to put all these options all toghether.
            by the way, compiz is pretty unusable.
            Yeah, I agree..

            and thanks, @givemesugarr, my problem solved with your code.

            Comment


            • #21
              and thanks, @givemesugarr, my problem solved with your code.
              i'm glad that i was able to help you out.

              Comment

              Working...
              X