Announcement

Collapse
No announcement yet.

8.42.3 impossible to launch gui appli from a terminal

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.42.3 impossible to launch gui appli from a terminal

    hi since i updated my ati driver from 8.41.7 to 8.42.3 i cannot launch any graphical application (eg : gedit, compiz , ...) from a terminal except if a launch the terminal itself with gksu and that i m root.

    i have always error messages like this one :

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    cannot open display:

    Could someone help please cause it has been a big source of problem for the first step with compiz

  • #2
    Perhaps if you gave more details others might be able to help you.
    Try giving your distro and version along with kernel. I don't use compiz but the 8.42.3 ATI driver seems to work well with kanotix thorhammer rc6b kernel 2.6.22-10-kanotix #1 SMP, playing doom3 and it seems to run faster than on windows.

    Comment


    • #3
      try:

      ln -s /usr/lib/opengl/ati/lib/libGL.so.1.2 /usr/lib/libGL.so.1

      or

      ln -s /usr/lib64/opengl/ati/lib/libGL.so.1.2 /usr/lib64/libGL.so.1

      if you are on 64bit architecture.

      this should do the trick. it's a knows bug with a soname misreport that should be fixed in the next release.

      Comment

      Working...
      X