Announcement

Collapse
No announcement yet.

8.42.3 / Suse 10.2 64bit / Radeon 9550 issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.42.3 / Suse 10.2 64bit / Radeon 9550 issues

    I have been struggling to get the new 8.42 driver working with my AGP Radeon 9550 256MB card. The good news is that I'm finding the driver better than 8.40, but still not working correctly.

    Installing the driver either directly from the script, or by building the RPM first seems to work correctly and I have been able to use it via sax2 (though if I attempt to Test from within sax I get a black screen that only a hard reboot can correct). When I get a lockup, there are no errors in the X log.

    Once installed X starts as expected and I move to test the installed driver. I get the expected response from fglrxinfo with expected vendor, renderer and version strings. I then run glxgears which starts but with an entirely black window (changing the size has no effect, there is nothing displayed), though I get reported FPS rates of around 4000! This is consistent with then starting a program requiring 3D support, which will similarly display a blank window (or even lock up the entire machine). Running fgl_glxgears produces no output at all.

    A second problem is that if I try to start a parallel session, the screen again goes black and I have to hard reboot. However, I can switch between a KDE session and console windows normally (i.e. CTRL-ALT-F1 / CTRL-ALT-F7 etc).

    As I can't find any other users displaying similar symptoms to mine, it probably means I just have some incorrect setting somewhere. However, with little experience of configuring X, I don't know what I'm looking for. AFAICT there is nothing in the Xorg.log files to cause issues (no EE messages).

    My xorg.conf is as follows (including it all just in case):

    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2007-10-29T23:19:36+0000.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      FontPath     "unix/:7100"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "IgnoreABI" "on"
    EndSection
    
    Section "Module"
      Load         "dbe"
      Load         "type1"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
      Load         "v4l"
      Load         "dri"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "gb"
      Option       "XkbModel" "pc105"
      Option       "XkbRules" "xfree86"
    EndSection
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Sunplus USB Wheel Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  338 270
      HorizSync    30-81
      Identifier   "Monitor[0]"
      ModelName    "SAMTRON"
      Option       "DPMS"
      VendorName   "STN"
      VertRefresh  43-75
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "RV350 AS"
      BusID        "1:0:0"
      Driver       "fglrx"
      Identifier   "Device[0]"
      Option       "FSAADisableGamma" "no"
      Option       "CapabilitiesEx" "0x00000000"
      Option       "ScreenOverlap" "0"
      Option       "FSAAMSPosY0" "0.000000"
      Option       "FSAAMSPosY1" "0.000000"
      Option       "mtrr" "off"
      Option       "FSAAMSPosX4" "0.000000"
      Option       "ForceGenericCPU" "no"
      Option       "FSAAMSPosX5" "0.000000"
      Option       "FSAAMSPosY2" "0.000000"
      Option       "FSAAScale" "1"
      Option       "FSAAMSPosY3" "0.000000"
      Option       "Capabilities" "0x00000000"
      Option       "GammaCorrectionI" "0x00000000"
      Option       "no_accel" "no"
      Option       "FSAAMSPosY4" "0.000000"
      Option       "UseFastTLS" "0"
      Option       "FSAAMSPosY5" "0.000000"
      Option       "FSAACustomizeMSPos" "no"
      Option       "FSAAEnable" "no"
      Option       "BlockSignalsOnLock" "on"
      Option       "GammaCorrectionII" "0x00000000"
      Option       "KernelModuleParm" "locked-userpages=0"
      Option       "FSAAMSPosX0" "0.000000"
      Option       "no_dri" "no"
      Option       "VideoOverlay" "on"
      Option       "UseInternalAGPGART" "no"
      Option       "PseudoColorVisuals" "off"
      Option       "StereoSyncEnable" "1"
      Option       "FSAAMSPosX1" "0.000000"
      Option       "OpenGLOverlay" "off"
      Option       "FSAAMSPosX2" "0.000000"
      Option       "Stereo" "off"
      Option       "FSAAMSPosX3" "0.000000"
      Option       "CenterMode" "off"
      VendorName   "ATI"
    EndSection
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "DAMAGE" "false"
    EndSection
    Is there something obvious I'm missing? Most of the settings are unchanged from the suse defaults, but is there something else I should be doing?

    Thanks for any help
Working...
X