Announcement

Collapse
No announcement yet.

mobile radeon x2300

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mobile radeon x2300

    Hi, sorry for disturbance..
    I have a problem with my laptop: under my Debian Sid (xorg 7.2; 1.3) kernel 22, fglrx 8.42.3 and following xorg:

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dbe"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
    EndSection

    Section "Extensions"
    Option "Composite" "1"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    HorizSync 28.0 - 51.0
    VertRefresh 43.0 - 60.0
    EndSection

    Section "Device"

    Identifier "Device0"
    Driver "fglrx"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "BlockSignalsOnLock" "on"
    Option "KernelModuleParm" "locked-userpages=0"
    Option "MonitorLayout" "LVDS, AUTO"
    Option "AccelMethod" "EXA"
    Option "EXANoOffscreenPixmaps"
    Option "RenderAccel" "true"
    Option "AllowGLXWithComposite" "true"
    Option "CapabilitiesEx" "0x00000000"
    Option "Capabilities" "0x00000000"
    Option "TexturedVideoSync" "on"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    Option "TexturedVideo" "on"
    EndSection


    I have 366 fps max in fgl_glxgears and 1560 in glxgears since 8.40 driver version and with new drivers it doesn't ever coming up... aticc displays 128 mb - my video memory, but as far as i know it can use my RAM like it do in w*ndows for example.

    The second problem - moving Z-like curves on the screen when watching a movie (if image is changing fast)
    I mean it's kinda blinking and not in the movie too.. as ex. If I try too mouseover/mouseout icon in kde very fast it's also blinking

    The third is that compiz-fusion is starting and effects ar working, but content of windows doesn't drawing at all, and console is not redrawing except if I run ncurses based apps.
    No errors except
    Error (dbus): Can't InitObject
    Error (core): Can't start plugin dbus
    - or smth like this


    Anybody, who knows the solution?? Please help, I already don't know what to do except buying an Nvidia card (

  • #2
    First of all you only need 2 options:

    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"

    Disable the rest of em, The ServerFlags section is useless when you want to ENABLE AIGLX, as it defaults to be on, you just need an extra section like:

    Section "Extensions"
    Option "Composite"
    EndSection

    Comment


    • #3
      removing all things from xorg.conf doesn't affect really fps (2-5 fps doesn't matter)

      so.. is this a problem of incompatibility of x2300 with a driver or something else?.. and the bug with the display - z-curves (mb smth like double buffering is working like 1/4 buffering? )..

      Comment

      Working...
      X