Announcement

Collapse
No announcement yet.

8.42.3 DRI initialization failed!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.42.3 DRI initialization failed!

    OK...I'm fed up over this. I can't get the 8.42.3 driver to work with my fresh Ubuntu 7.10 install. Previosly after reinstall I have not enabled the propriatery ATI driver, just been using the VESA (which behaves nicely during suspend). Btw, I have an HP NX9420 laptop with an ATI Radeon Mobility X16000. On Ubuntu 7.04 I have jut several ATI drivers without any problems.

    No my problem is that I can't seem to get ATI to work properly with direct rendering. This is the output of my glxinfo | grep direct:

    Code:
    glxinfo | grep direct
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    OpenGL renderer string: Mesa GLX Indirect
    fglrx says:
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
    My Xlog.0.log goes reports, among other things, this:
    Code:
    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.0.0
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized. 
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    (II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x10000000
    (==) fglrx(0): Write-combining range (0xe0000000,0x10000000)
    (II) fglrx(0): FBMM initialized for area (0,0)-(1728,8191)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1728,1050) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 1728 x 7141
    (==) fglrx(0): Backing store disabled
    (II) Loading extension FGLRXEXTENSION
    (II) Loading extension ATITVOUT
    (**) fglrx(0): DPMS enabled
    (WW) fglrx(0): Textured Video not supported without DRI enabled.
    (WW) fglrx(0): Video Overlay not supported on AVIVO based graphics cards. For XVideo support use Option "TexturedVideo".
    (II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
    	Screen to screen bit blits
    	Solid filled rectangles
    	Solid Horizontal and Vertical Lines
    	Offscreen Pixmaps
    	Setting up tile and stipple cache:
    		32 128x128 slots
    		32 256x256 slots
    		16 512x512 slots
    (II) fglrx(0): Acceleration enabled
    (II) fglrx(0): Direct rendering disabled
    (==) fglrx(0): Silken mouse enabled
    (==) fglrx(0): Using hardware cursor
    (==) RandR enabled
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension XAccessControlExtension
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    (EE) AIGLX: Screen 0 is not DRI capable
    sudo modprobe -l | grep fglrx reports:
    Code:
    /lib/modules/2.6.22-14-generic/misc/fglrx.ko
    I have installed the ATI driver precisly like this:
    Code:
    sudo apt-get remove xorg-driver-fglrx
    sudo rm -f /usr/src/fglrx-kernel*.deb
    sudo gedit /etc/default/linux-restricted-modules-common
          DISABLED_MODULES="fglrx"
    reboot
    wget http://www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run
    sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-generic
    bash ./ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Ubuntu/gutsy
    sudo dpkg -i fglrx-kernel-source_8.42.3-1_i386.deb xorg-driver-fglrx_8.42.3-1_i386.deb
    sudo m-a prepare,update
    sudo m-a build,install fglrx-kernel
    sudo depmod
    sudo gedit /etc/X11/xorg.conf - removed the following:
         Section "Extensions"
            Option        "Composite"        "0"     # or "Disable"
         EndSection
         Section "ServerFlags"
            Option        "AIGLX"            "off"
         EndSection
    reboot

  • #2
    Hi
    I have similar problems like you.
    And i found a workaround in the forum.

    Shutdown your Xserver and then do this:
    Code:
    sudo rmmod fglrx
    cd /lib/modules/*/misc
    sudo insmod fglrx.ko
    modprobe fglrx
    Then restart the Xserver. And now you should have DRI Support, if everything else was right.

    But this works only until you restart your PC.
    Then you have to do it again.

    Greetings
    Manu

    Comment


    • #3
      Originally posted by gzahl View Post
      Hi
      I have similar problems like you.
      And i found a workaround in the forum.

      Shutdown your Xserver and then do this:
      Code:
      sudo rmmod fglrx
      cd /lib/modules/*/misc
      sudo insmod fglrx.ko
      modprobe fglrx
      Then restart the Xserver. And now you should have DRI Support, if everything else was right.

      But this works only until you restart your PC.
      Then you have to do it again.

      Greetings
      Manu
      I have tried that.
      Code:
      :~$ sudo rmmod fglrx
      ERROR: Module fglrx does not exist in /proc/modules
      Does anyone have any suggestions???

      Comment


      • #4
        Hi

        Just igonre this failure:
        Code:
        :~$ sudo rmmod fglrx
        ERROR: Module fglrx does not exist in /proc/modules
        It is expected, if the kernel module isn't loaded. Did you try the other command nevertheless?
        Greetings
        Manu

        Comment


        • #5
          It worked for me, thanks!
          By the way, do you know how can I avoid doing it every time I reboot? Like adding that in some script or something...? Thanks!

          Comment


          • #6
            I had the same problem, finally gave up and installed the one in the repos.

            Comment


            • #7
              Have you seen this thread already?
              http://www.phoronix.com/forums/showthread.php?t=6017

              It worked for me and at least one more Ubuntuuser ...

              Comment


              • #8
                did you make sure to black list the repo version of the drivers? you need to add fglrx to the disable section of /etc/default/linux-restricted-modules-common

                otherwise you're going to always get mesa drivers loaded and you won't have dri.

                alot of guides out there say that you only need to do this if you installed the repo drivers, but from my experience you have to do it no matter what.

                try it out.

                Comment


                • #9
                  Ensure that the Ubuntu version of the driver is blacklisted (else you'll get Mesa again and again).

                  Why? Well the fglrx in restricted-drivers are still hanging around, but now you've gone and got the latest drivers with different kernel headers. Old driver to new kernel headers = DRI initialization fails.

                  Then run the following command after you've done the above commands (rmmod, insmod, modprobe) if you still get issues.

                  Code:
                  sudo depmod -ae
                  Reboot, and see if it works.

                  Comment


                  • #10
                    You mean new drivers with old kernel headers, right?

                    I don't know if you were answering me. In that case it didn't work.
                    When I run rmmod, I get a:

                    ERROR: Module fglrx does not exist in /proc/modules

                    Then the following steps are OK, fglrx.ko is in /lib/modules/fglrx/ as well as in /lib/modules/2.6.20-16-generic/kernel/drivers/char/drm/ (same size, same date). Then modprobe returns no error and fglrx shows up in lsmod.

                    I tried then running 'depmod -ae' and rebooting, but again, the changes aren't permanent... any idea? Thx!

                    Comment

                    Working...
                    X