Announcement

Collapse
No announcement yet.

8.42.3 DRI initialization failed!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    ...and fglrx is blacklisted in /etc/modprobe.d/blacklist correct?

    That is, in the non-commented entry (there is a similar entry, but that's commented out as it's used for an example, you have the following:

    Code:
    Blacklist= fglrx
    or something to that effect.

    If that still does not work, give this solution a try:
    http://www.phoronix.com/forums/showp...36&postcount=4

    Comment


    • #12
      "sudo rmmod fglrx"

      will not work unless you have previously installed drivers. which in this case you shouldn't b/c in your first post you have a clean install of gutsy.

      what you need is

      "gksu gedit /etc/default/linux-restricted-modules-common"

      then in the blacklist section, put fglrx like uchikoma posted.

      also restore your xorg.conf if you made a backup.

      then restart and run aticonfig --initial

      then enable the driver in restrictred driver manager and it'll load the new driver. then reboot again and hopefully have everything working.

      Comment


      • #13
        Originally posted by doccy View Post
        OK...I'm fed up over this. I can't get the 8.42.3 driver to work with my fresh Ubuntu 7.10 install. Previosly after reinstall I have not enabled the propriatery ATI driver, just been using the VESA (which behaves nicely during suspend). Btw, I have an HP NX9420 laptop with an ATI Radeon Mobility X16000. On Ubuntu 7.04 I have jut several ATI drivers without any problems.

        No my problem is that I can't seem to get ATI to work properly with direct rendering. This is the output of my glxinfo | grep direct:

        [...]
        I actually posted already a link, but it seams like it got no attantion .

        I had the same problem with Ubuntu:
        After a flawless installation the module won't load.

        Trying to load module manually...
        Code:
        $ modprobe -vf fglrx
        ...gave me this output:
        Code:
        install /sbin/lrm-video fglrx
        You can get the module to load with something like:
        Code:
        $ sudo insmod /lib/modules/2.6.20-16-generic/misc/fglrx.ko
        $ modprobe fglrx
        But you have to repeat this workaround after every reboot.

        The solution is to modifie the file "/etc/modprobe.d/lrm-video". Comment out the line with fglrx:
        Code:
        #install fglrx /sbin/lrm-video fglrx $CMDLINE_OPTS

        Comment

        Working...
        X